反馈已提交

网络繁忙

Escalation Risk Items and Handling Methods

  • Author:mt6666
  • Edit Times:17次
  • Recent Updates:Jakieeee 于 2022-09-01
  • 1. Environmental detection items

    Detection level
    Test contentSolutionBI interface tipsExport Excel Tips

    BLOCK/

    WARNING


    Disk space detection < 1g, marked as blocking

    No disk space detected, marked as warning.

    Prompt the solution, handle it yourselfIt is detected that the current disk space is less than 1G, please ensure that the disk space is greater than 1G before upgrading, you can clear the disk space before upgrading"It is detected that the current disk space is less than 1G, please ensure that the disk space is greater than 1G before upgrading, you can clear the disk space before upgrading"
    WARNINGWhether an upgrade rollback occursIt is recommended to upgrade in the test environment first-It is detected that your system has been upgraded and the configuration content has not been rolled back according to the document. This operation may generate dirty data. It is strongly recommended that you test the environment for upgrade verification.

    BLOCK/

    WARNING

    Detect the lack of DDL permissions of external libraries and mark them as blocking itemsPrompt the solution, handle it yourself-It is detected that your system uses an external database and the current user does not have the permission to add, delete, modify and search (DDL) tables in the external database. It is recommended that you contact the database operation and maintenance personnel to modify the corresponding permissions before upgrading.

    BLOCK/

    WARNING

    Detect external library encoding

    mysql encoding is not utf8 or utf8mb4, flag blocking

    The SQL server code is not Chinese_PRC_CS_AS, if it is

    Chinese_PRC_CI_AS is marked as warn, others are BLOCK



    Prompt the solution, handle it yourself-

    Detecting that the encoding of the external library is not the required encoding

    WARNINGDetect whether the current environment is a cluster environment, and if so, prompt to update nginxPrompt the handling plan, the customer will handle it by himselfWARN : It is detected that the current environment is a cluster environment. Please refer to the help documentation to update the nginx forwarding configuration after the upgradeWARN : It is detected that the current environment is a cluster environment. Please refer to the help documentation to update the nginx forwarding configuration after the upgrade
    SUGGEST---After the upgrade, you need to clear the browser cache
    BLOCKDetect whether msvcr120.dll exists in the runtime environmentPrompt the solution, handle it yourself-

    The msvcr120.dll runtime library does not exist, you need to install the x64 version of Visual Studio 2010 (VC++ 10.0) before upgrading, please refer to the Microsoft help document: https://docs.microsoft.com/en-US/cpp/windows/latest -supported-vc-redist?view=msvc-160.


    2. Configure class detection items

    Detection levelText content
    SolutionBI interface tipsExport Excel Tips


    WARNING

    1) If the MySQL parameter max_allowed_packet needs to be configured to be less than 1073741824, it will be marked as a warning item

    2) If the MySQL parameter max_allowed_packet cannot be detected, it will be marked as a warning item


    Prompt solution, you need to handle it yourself


    1) WARN: configure the external library as MySQL and the parameter max_allowed_packet is less than 1073741824, which affects the configuration compatibility execution

    2) WARN: The current external library connection user does not have permission to query the max_allowed_packet parameter of MySQL, the parameter value is required to be >=1073741824, please check by yourself

    It is detected that the external library is MySQL, and the parameter max_allowed_packet<1073741824. The configuration needs to be adjusted to be compatible during the upgrade process. If the parameter is too small, the configuration will fail to be written to the database. To ensure the smooth progress of the upgrade, please adjust the max_allowed_packet parameter first. The adjustment method is as follows

    Option One:

    Change the "max_allowed_packet = 1M" in the [mysqld] field in the "my.ini" file in the MySQL installation directory to 1024M, and then restart MySQL.

    Option II:

    1) Use the "set global max_allowed_packet = 1073741824;" statement to set the value of "max_allowed_packet" to 1024M without restarting.

    2) Use the "show VARIABLES like '%max_allowed_packet%';" statement to check whether the modification is successful.

    SUGGESTUpdatePushConfig.open", check whether the value is false, mark it as a prompt item

    Automatic product processing



    FineDB configures UpdatePushConfig.open to true and automatically changes to false
    BLOCKGet the path corresponding to spider_local_root_path and check whether a file can be created in the corresponding pathPrompt solution you can handle it yourselfIt is detected that there is no file creation permission under the XXXX path. This path is the data update path and must have file read and write permissions.It is detected that there is no file creation permission in the XXXX path. This path is the data update path and must have file read and write permissions. Please use the chmod path to authorize the path. The command format is as follows: chmod -R 777 xxx path

    BLOCK/

    WARNING

    1) The jdk version is oracle's 1.8.0.102, you need to upgrade the JDK first, and mark it as a blocking item

    2) The JDK version information cannot be detected and marked as a warning item

    Prompt solution, you can handle it yourself

    BLOCK: The JDK version is lower than 1.8.0.102. After the upgrade, it will cause abnormal startup due to JDK vulnerabilities. Please upgrade the JDK version first before performing the BI upgrade.

    WARN : Currently unable to obtain the JDK version, please confirm that the JDK version is greater than 1.8.0.102

    It is detected that the jdk version is lower than 1.8.0.102, and the old version of JDK has loopholes. After the upgrade, there will be a startup crash. It needs to be replaced with a jdk version after 1.8.0.102 and then upgraded. 

    After the JDK version is updated, the encryption suite is introduced, which may cause the data connection to fail. It needs to be improved according to the following documents
    JDK upgrade and precautions

    WARNING

    Detect FineClusterConfig.params.cluster.is false and

    SystemOptimizationConfig.biClusterMasterNodeHostName  is not null.

    hotBackConf.master is not null.

    SystemOptimizationConfig.ClientMasterId is not null.

    hotBackConf.slave is not null.


    StateServerConfig.type != standone

    StateServerConfig.clusterMode != false


    Prompt solution, you can handle it yourself

    WARN : Detects that the current is a stand-alone environment but has residual cluster-related configuration, and the residual parameters need to be deleted

    To detect the current stand-alone environment but residual cluster-related configuration, the residual parameters need to be deleted, the following hot standby parameters need to be deleted, and the corresponding parameters in the fine_conf_entity table need to be modified in the connection configuration library

    If it is not empty, it will prompt you to delete the ID: SystemOptimizationConfig.biClusterMasterNodeHostName  

    If it is not empty, it will prompt you to delete the ID: hotBackConf.master  

    If it is not empty, it will prompt you to delete the ID: SystemOptimizationConfig.ClientMasterId   

    If it is not empty, it will prompt you to delete the ID: hotBackConf.slave  

    The following are the redis configuration parameters. Please confirm whether the redis configuration is still in use. If you have stopped using the login super administrator, in the intelligent operation and maintenance → cluster configuration, change the state server to the closed state.

    WARNINGCheck if there is a backup file of the dayPrompt solution, you can handle it yourselfWARN : It is detected that the system has not been successfully backed up in the past day, please confirm that the system is configured with backupIt is detected that there is no backup file in the current system in the past day, it is recommended that you back up and then upgrade

    3. Driver file detection item

    Detection level
    Test contentSolutionBI interface tipsExport Excel Tips
    WARNINGDetect that the external library is oracle11g and above and there is no ojdbc8 in the lib directoryPrompt solution, you can handle it yourselfWARN : It is detected that the external library is oracle11g and above, it is recommended that you use the matching driver ojdbc8It is detected that the external library used by the current system is oracle11g and later. It is recommended that you replace the driver with ojdbc8 before upgrading. You need to replace the ojdbc14.jar file with two jar files, ojdbc8.jar and orai18n.jar
    BLOCKInstall driver isolation plugins for hive, phoenix, spark, impala, TRANSWARP, INCEPTOR

    Prompt solution, you can handle it yourself

    BLOCK: driver conflict blockingIt is detected that the system uses big data platforms such as hive, phoenix, spark, impala, TRANSWARP, INCEPTOR, etc. The drivers used are prone to conflict with the BI code. It is strongly recommended that you configure driver isolation to ensure the stable operation of the system. For details, see: Drivers Isolated plugin

    4. lib file detection item

    Detection levelTest contentSolutionBI interface tipsExport Excel Tips
    BLOCKCommons and other jars, prompt to delete after detectionPrompt the solution, handle it yourselfBLOCK: lib exception file conflict blockingIt is detected that this file is prone to conflict with the BI code, you need to delete it and restart BI, and then upgrade
    BLOCKFolders, zip files, and files with the same name under lib, prompt to delete after detectionPrompt the solution, handle it yourselfBLOCK: lib exception file conflict blockingIt is detected that there are folders, zip files, and files with the same name in the lib file. This type of file can easily lead to unstable BI operation. You need to delete it and restart BI before upgrading.
    WARNINGThe non-txt and jar files in the folder under lib are considered illegal files, and prompt to delete after detectionPrompt the solution, handle it yourselfWARNING: lib exception file warning, it is recommended to delete

    It is detected that there are non-jar and non-txt files in the lib file, which may affect the project. Please delete it before upgrading.

    BLOCK

    hive, phoenix, spark, impala, TRANSWARP, INCEPTOR, hbase, maxcomputer, kylin, driver package

    Prompt the solution, handle it yourselfBLOCK: lib exception file conflict blockingIt is detected that there are big data platform drivers such as hive, phoenix, spark, impala, TRANSWARP, INCEPTOR, etc. in the lib file. This file is likely to conflict with the BI code. You need to delete it and restart BI, and then upgrade
    BLOCKDetect the presence of fr-xxxx-8.0, fr-xxxx-9.0, fr-xxxx-4.0, fr-xxxx-4.1, fr-slf4j-frlog4jPrompt the solution, handle it yourselfBLOCK: lib exception file conflict blockingIt is detected that there are jar files of version 8.0 and 9.0 in the lib file. This file is likely to conflict with the BI code. You need to delete it and restart BI, and then upgrade.

    5. Plugin detection items

    Detection levelTest contentSolutionBI interface tipsExport Excel Tips
    WARNINGDetect the existence of two-open plug-ins such as JSD and SLN in the plug-in namePrompt the solution, handle it yourselfWARN: It is detected that there is a two-open plug-in in the plug-in management. It is recommended that you contact technical support to confirm whether the new version of the plug-in is compatible.It is detected that there is a two-open plug-in in the plug-in management. It is recommended that you contact technical support to confirm whether the new version of the plug-in is compatible.
    WARNING

    Plugin detects plugin name exists

    zip filename fr-plugin-platform-bridge,

    The compressed file name is com.tptj.plugin.hg.platform.bridge; the installation file name is plugin-com.tptj.plugin.hg.platform.bridge

    It is clear that the plug-in needs to be upgraded

    Prompt the solution, handle it yourselfWARN: A single-point plug-in is detected in the plug-in management. It is recommended that you contact technical support to obtain a new version of the plug-inIt is detected that there is a single sign-on plug-in in the plug-in management. It is recommended that you contact technical support to confirm whether the new version of the plug-in is compatible.
    SUGGESTDelete the plugin plugin-com.fr.plugin.decision.data.check, compress the file plugin-com.fr.plugin.decision.data.check

    automatic processing


    Export file tipsAn invalid plug-in plug-in is detected in the plug-in management. The plug-in affects the upgrade execution and will be automatically deleted during the upgrade process.
    SUGGESTRemove plugin dataset toggle table plugin

    automatic processing


    Export file tipsAn invalid plug-in plug-in is detected in the plug-in management. The plug-in affects the upgrade execution and will be automatically deleted during the upgrade process.
    SUGGESTRemove plugin dashboard default selection table plugin

    automatic processing


    Export file tipsIt is detected that the dashboard default selection form plugin exists in the plugin management. The new version already includes this function and will be automatically deleted during the upgrade process.
    SUGGESTremove com.fr.plugin.platform.safelogin

    automatic processing


    Export file tipsIt is detected that there is a 9.0 version of the plugin in the plugin management, and the current system is version 10.0. This plugin has hidden dangers to the system stability and has been automatically deleted.
    WARNING

    Check if plugin name exists

    name : Multiple ldap login

    id is not: com.fr.plugin.decision.multi.ldap.passport

    Prompt to reconfigure after upgrade

    Prompt the solution, the customer handles it by himselfExport file tipsIt is detected that the "  Multi-domain LDAP Authentication  " plugin exists in the plugin management. The function logic of the new version of the plugin has changed and needs to be adjusted manually. For details, please refer to the help document https://help.fanruan.com/finebi/doc-view-1188. html
    SUGGEST

    Delete whether the plugin name exists plugin-com.finebi.memory-1.0.5, plugin-com.finebi.memory-1.0.5

    Delete whether the plugin name exists plugin-com.finebi.memory-1.0.6, plugin-com.finebi.memory-1.0.6

    automatic processing


    Export file tipsIt is detected that there is an old version of the memory management plugin in the plugin management. The current system is version 10.0. This plugin has hidden dangers to the system stability and has been automatically deleted.
    SUGGEST

    Compressed file name fr-plugin-bi-inspector id: com.finebi.plugin.bi.inspector Installation file name: plugin-com.finebi.plugin.bi.inspector


    Compressed file name fr-plugin-bi-cleaner id: com.finebi.plugin.bi.cleaner Installation file name: plugin-com.finebi.plugin.bi.cleaner

    automatic processing


    Export file tipsIt is detected that there is an old version of the tool plug-in in the plug-in management. This plug-in has hidden dangers to the system stability and has been automatically deleted.
    WARNINGCheck whether the current environment can be connected to the plug-in mall, and prompt that the plug-in needs to be upgraded after the upgradePrompt the solution, handle it yourself

    WARN : If you can connect to the prompt, log in to the plugin management page to upgrade the corresponding plugin upgrade item after the upgrade.

    If you cannot connect, please open the plugin store https://market.fanruan.com/ to see if there is a new version of the installed plugin.

    (There is an external network) Please log in to the system after the upgrade, and open the plugin management page to upgrade to prompt the plugins that need to be upgraded. Currently, XXX plugins have been installed. If the corresponding plugins are not updated, some functions will be abnormal.

    or

    (No external network) It is detected that the current environment cannot be connected to the plug-in store. Please open the plug-in store https://market.fanruan.com/ to check whether the installed plug-in has a new version update, and download the corresponding plug-in for local update. Install XXX plug-ins, if the corresponding plug-ins are not updated, some functions will be abnormal.

    WARNINGPlugin exceptions that may be caused by the loss of plugin dependenciesPrompt the solution, handle it yourself

    SUGGEST

    remove plugin

    File name: plugin-com.fr.plugin.operation

    ID:com.fr.plugin.operation

    automatic processing




    SUGGESTPlugin class resources are missinghandle it yourself-

    There are missing dependencies, please delete the plugin first, and update the latest plugin after the upgrade is complete

    Dependencies are missing that may affect functionality



    Attachment List


    Theme: Install and Upgrade
    Already the First
    Already the Last
    • Helpful
    • Not helpful
    • Only read

    售前咨询电话

    400-811-8890转1

    在线技术支持

    在线QQ:800049425

    热线电话:400-811-8890转2

    总裁办24H投诉

    热线电话:173-1278-1526

    文 档反 馈

    鼠标选中内容,快速反馈问题

    鼠标选中存在疑惑的内容,即可快速反馈问题,我们将会跟进处理。

    不再提示

    10s后关闭