註冊常見問題

1. 概述

本文將主要介紹不同註冊方式下,系統註冊出現問題的原因和解決方案。

2. Lic上傳卡住

問題描述:

上傳註冊Lic檔案時,卡在上傳中的頁面無進展。

排查步驟:

進入工程%BI_HOME%/webroot/WEB-INF/resources 目錄下,查看「FanRuan.lic」檔案的修改時間,判斷檔案是否成功上傳。

1)檔案未成功上傳

原因分析:若檔案未成功上傳,一般是由於系統禁用了PUT請求,導致請求不正常

解決方案:使用者可透過安裝「PUT、DELETE請求轉成POST」插件,將 PUT、DELETE 請求轉成 POST 請求。詳情請參見:PUT、DELETE請求轉成POST插件

2)檔案成功上傳

原因分析:若檔案成功上傳,可能是前臺沒有即時重新整理。

解決方案:手動重新整理下平台頁面,查看是否顯示註冊成功。若仍未成功註冊,請根據註冊失敗的報錯資訊參考下文解決。

3. Lic上傳失敗

問題描述:

上傳註冊Lic檔案時,彈窗報錯「檔案 FanRuan.lic不能透過校驗,請檢查他。

解決方案:

管理者登入數據決策系統,點選「管理系統>安全管理>安全防護」,臨時關閉「檔案上傳校驗」,待註冊成功後再開啟。

4. 憑證已過期

問題描述:

註冊時,提示「註冊失敗,請重新註冊」。點開詳細資訊,提示:

過期時間:xxxx-xx-xx

原因分析:

當前工程使用的註冊Lic檔案,已到達合同約定的過期時間。

解決方案:

1)若確定已達到合同約定的過期時間,請聯絡銷售進行續購。

2)若合同約定的過期時間還未到,但lic已過期,請聯絡銷售重新索要正確的註冊Lic檔案。

5. 版本不匹配

問題描述:

註冊時,提示「註冊失敗,請重新註冊」。點開詳細資訊,提示:

  • 認證應用版本:9.0

  • 本地應用版本:10.0

原因分析:

帆軟有兩種版本升級情況,大版本(9升10,10升11)和小版本(10.0.1升10.0.2)

1)大版本升級影響授權

跨大版本升級,例如從 9.0 升級到 10.0 ,會對授權檔案有影響,需要重新註冊或遷移授權。

2)小版本升級不影響授權

小版本之間的升級,例如從 10.0.9 升級到 10.0.10 ,對授權檔案無影響。

解決方案:

1)若為全新註冊,且合同約定的工程版本與產品版本一致,請聯絡銷售重新索要正確的註冊Lic檔案。

2)若為升級的新工程,不能直接使用老工程的註冊Lic檔案,請聯絡銷售確定升級後的授權遷移相關事項。

6. MAC地址不匹配

問題描述:

註冊時,提示「註冊失敗,請重新註冊」。點開詳細資訊,提示:

認證 MAC 地址:xxx

本地 MAC 地址:xxx

排查步驟:

MAC 地址,用於在網路中唯一標示一個網卡。一臺裝置可以有多個網卡,每個網卡都有唯一的 MAC 地址。

註冊 Lic 檔案中的 MAC 地址,必須能與伺服器的任意一個 MAC 地址匹配。

Linux 或 Unix 系統的 MAC 地址格式和一般的MAC形式不一樣,比如為 0*001F296EFD64。

伺服器系統
部署方式原因分析和解決方案
Windows-

原因分析:更換了網卡,導致MAC地址變更

解決方案:請聯絡商務重新授權

原因分析:手動修改了工程所在伺服器的MAC地址

解決方案:

方案一:把MAC地址改回來

方案二:聯絡商務重新授權

Linuxdocker部署

原因分析:

若未固定 docker 的 MAC 地址和 UUID,重啟會隨機改變MAC地址

解決方案:

1)docker部署,建議固定MAC地址

2)不綁定MAC地址,建議使用私有雲/公有雲認證

虛擬機

原因分析:

虛擬機的MAC地址分為三種:

1)固定MAC地址:可以配置固定的MAC地址,重啟不變。

2)繼承宿主機MAC地址:和宿主機MAC地址保持一致,重啟不變。

3)動態MAC地址:前綴相同,後四位隨機變動,重啟改變。

解決方案:

1)確認近期是否更換宿主機硬體或重裝系統,若更換會導致MAC地址變更,請聯絡商務重新授權

2)若虛擬機為動態MAC地址,建議使用私有雲/公有雲認證

物理機


原因分析:

使用腳本重啟,腳本中沒有切換 root 使用者, 或者存取對應命令的權限。

解決方案:

儘量使用root使用者啟動並給與存取對應命令的權限

原因分析:

Linux系統的中間軟體(如Tomcat),以root和非root使用者啟動,MAC地址會不一樣

解決方案:

儘量使用root使用者啟動並且保持一致

7. 機器碼不匹配

問題描述:

註冊時,提示「註冊失敗,請重新註冊」。點開詳細資訊,提示:

  • 認證機器碼:xxx

  • 本地機器碼:xxx

排查步驟:

因素
原因分析和解決方案
系統硬體

原因分析:更換了硬體,如cpu,硬碟,主板等,都會導致機器碼變化

解決方案:請聯絡商務重新授權

JDK

原因分析:機器碼的讀取是依賴JDK的,JDK更換可能會導致機器碼變化

解決方案:修改回原先的JDK,修改回原先的環境變數

虛擬機

原因分析:虛擬機重啟會導致機器碼變化

解決方案:請聯絡商務重新授權

虛擬機不建議使用本地機器資訊認證,建議使用私有雲/公有雲認證

權限

原因分析:Linux系統的中間軟體(如Tomcat),以root和非root使用者啟動,機器碼會不一樣,甚至獲取不到

解決方案:儘量使用root使用者啟動並且保持一致

雲系統

原因分析:修改配置就會導致機器碼變化

解決方案:請聯絡商務重新授權

虛擬機不建議使用本地機器資訊認證,建議使用私有雲/公有雲認證

8. 應用名不匹配

問題描述:

註冊時,提示「註冊失敗,請重新註冊」。點開詳細資訊,提示:

  • 認證應用名:xxx

  • 本地應用名:xxx

原因分析:

工程地址形如http://ip:port/工程名/decision,工程名一般為webroot

當出現該報錯時,一般都是由於工程名被改動了

解決方案:

在給商務傳送授權申請郵件時:

  • 若備註了工程名,那麼傳回的註冊Lic檔案就是郵件中備註的工程名

  • 若未備註工程名,那麼傳回的註冊Lic檔案對應的工程名為webroot

請將工程的帳號修改成與註冊Lic檔案一致。

9. 已達可授權數量上限

問題描述:

註冊時,提示「註冊失敗,請重新註冊」。點開詳細資訊,提示:

超過最大註冊數量

排查步驟:

註冊方式因素
原因分析和解決方案
本地機器認證伺服器下存在多個工程

原因分析:

工程所在伺服器下,存在其他工程,佔用了該註冊Lic檔案。

解決方案:

檢查工程所在伺服器下的其他工程%BI_HOME%/webroot/WEB-INF/resources目錄下,查看「FanRuan.lic」檔案的修改時間。

若為新增的註冊Lic檔案,刪除後,進入到正確的工程重新註冊即可。

工程重複載入

原因分析:

Tomcat域名配置不正確,在Tomcat的server.xml中配置了兩個<host>,一個域名一個ip,該配置方式導致工程重複啟動兩次,所以lic會報錯已佔用。

解決方案:

刪除xml中ip的<host>,只保留域名的<host>,ip還是可以正常存取的,不需要單獨配ip。

指定啟動路徑

原因分析:

server.xml中配置了虛擬路徑,導致工程二次重啟了。

解決方案:

Tomcat設定工程存取路徑的正確方式請參見:Tomcat設定工程存取路徑

方案一:註釋掉server.xml中docBase配置,重啟後即可正常註冊。

方案二:將webroot工程行動到webapps資料夾外的路徑,然後指定對應路徑,重啟後即可正常註冊。

公有雲工程佔用授權

原因分析:

申請公有雲授權時,會提交一個最大可註冊量

如果超出了這個最大可註冊量,就會出現此報錯

解決方案:

將老工程上的授權手動解綁,再到新工程上綁定

物理資訊變更

原因分析:

虛擬機重啟,物理資訊變更,導致達到註冊上線

請聯絡技術支援,確認名下是否存在佔用公有雲註冊數的工程

解決方案:

請技術支援協助解綁,再進行工程綁定

10. 憑證內容不正確

問題描述:

註冊時,提示「註冊失敗,請重新註冊」。點開詳細資訊,提示:

憑證內容不正確

排查步驟:

因素
原因分析和解決方案
使用者權限

原因分析:

啟動工程的使用者,沒有寫檔案的權限,配置777權限,日誌報錯: [Resource] Write failed!

解決方案:

重新配置寫權限即可,或儘量使用root使用者啟動

重複運作遷移程式

原因分析:

在授權遷移時,第一次運作遷移程式成功後,會產生一個新授權。

使用新授權註冊成功後,若再次運作遷移程式,會將當前已正式註冊的授權銷燬。

解決方案:

請聯絡商務重新授權

更多原因

出現該報錯的更多情況,都需要根據工程實際情況一一排查,建議聯絡技術支援

技術支援聯絡方式:QQ「800049425」、電話「400-811-8890」。

11. 本地容器認證

11.1 節點已經全部重啟

問題描述:

工程本地容器認證,重啟後註冊頁報錯,提示「節點已經全部重啟」。

原因分析:

重啟伺服器後,本地容器認證就是需要重新註冊,產品設計如此。

解決方案:

重新手機掃碼認證即可。

11.2 錯誤碼40002,lic已在其他機器註冊

問題描述:

修改了伺服器的配置庫後,重啟伺服器,再用手機掃碼認證。

提示「錯誤碼40002,lic已在其他機器註冊」。

原因分析:

修改配置庫後,本地容器認證需要重新註冊。

解決方案:

請聯絡商務取消原伺服器的註冊授權,再次使用商務傳送的 Container.lic 檔案進行註冊。

12. 私有雲認證程式啟動異常

認證程式啟動時,會出現各種報錯資訊,請按照具體報錯排查

報錯

已卸載認證伺服器之前卸載過,如需再次在同一授權伺服器使用認證伺服器,需重新獲取機器資訊重新註冊
已過期

跟系統時間有關係

如註冊時的系統時間是12-21-16:18:55,私有雲生效的時間是12-21-16:40:29

錯誤碼30002

賬戶狀態不正常

1)銷燬原認證伺服器後,沒有重新生成新的機器資訊,而是直接使用了原機器資訊,造成rif機器資訊檔案中sessionid重複

2)跟執行啟動命令權限有關係,推薦root運作

address already in use

埠被佔用。重新換API啟動認證程式:

使用命令行啟動程式的時候後面加參數-port埠指定另外埠

  • Windows下例如:.srever.exe -port 8090

  • Linux/Mac下例如:./server -port 8090

13. 公有雲認證

13.1 網路問題

1)客戶BI工程伺服器必須與授權伺服器透過公網連通,不允許開放外網的客戶無法使用該註冊方式。

需要開放的外網地址包括:

域名
說明
https://register.fanruan.com443公有雲認證伺服器
https://cloud.fanruan.com443地址管理中心

2)連結地址管理中心未開啟,導致工程無法網路連結。

管理者登入數據決策系統,點選「管理系統>系統管理>標準」,開啟「連結地址管理中心」。如下圖所示:

13.2 系統時間問題

原因分析:工程伺服器上的系統時間與當前實際的時間不一致。

解決方案:把伺服器的系統時間修改為當前對應的時間即可。

13.3 帳號存在特殊字元

原因分析:公有雲帳號不支援中文和中文標點符號。

解決方案:聯絡商務更換公有雲帳號。

14. 達到限制值

註冊時,會對註冊時間、資料連結數、併發數、使用者數進行限制。若達到限制值,則會出現報錯或異常狀態。

若當前系統已註冊,超級管理者登入數據決策系統,在當前頁下存取http://IP:埠/webroot/decision/v10/register/info/license,即可查看註冊時的限制值。如下圖所示:

  • 若資料連結數達到限制值,則將無法新增資料連結,新新增的資料連結不顯示。

  • 若併發數達到限制值,則後登入的 IP 地址將無法登入。

  • 若註冊為永久註冊,過期時間為100年後。100年過期後,請聯絡帆軟商務進行免費註冊。

  • 若更換伺服器硬體,有可能造成機器碼更改,進而導致註冊失效。

  • 若更改工程名,會導致工程名不一致,進而導致註冊失效。

  • 若使用者數達到限制值,則將無法新增使用者,新新增的使用者報錯「與其他管理者操作衝突,請重新整理後重試」。

  • 若分佈式節點數達到限制值,則將無法新增節點,新新增的節點不顯示。

15. 缺少功能點

若使用 FineBI 時,發現某些功能不可用,直接報錯或者打不開,

出現類似報錯:您使用了未註冊的功能java.lang.NullPointException 空指標異常

注:功能點的影響請參見:註冊管理

這是由於註冊時未購買某些功能點。在「數據決策系統>管理系統>註冊管理>功能列表」中,可以查看到已註冊的功能點,如下圖所示:

如需新增購買某些功能點,請聯絡帆軟商務,商務信箱 business@fanruan.com

16. 多種註冊並存

當伺服器同時擁有 license 授權檔案和加密鎖,則以 license 授權檔案為主。

因為伺服器首先會去讀取 license 授權檔案,若授權檔案不存在才會讀取加密鎖,因此 MAC 地址註冊的優先高於加密鎖註冊。

17. license 檔案沒有生效導致圖表顯示空白

使用新的 license 檔案後,設計器預覽圖表顯示空白?

因為將獲取的 FanRuan.lic 檔案放到工程%BI-HOME%\webroot\WEB-INF\resources目錄下,沒有重新啟動 Web 伺服器,導致圖表不能預覽。

所以使用 license 檔案必須重新啟動 Web伺服器,license 才能生效。

18. 報空指標錯誤

在預覽一些範本時,報 java.lang.NullPointException 空指標異常。

因為該範本中包含了一些 license 檔案中不包含的功能。

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