网络拦截问题汇总

1. 概述

在使用 FineBI 时,有时会由于网络拦截问题导致出现某些报错或问题,本文提供排查和解决方法。

1.1 问题现象

1.1.1 本机或服务器网络已断开,请连网后重试

  • 平台配置、仪表板创建、数据集修改等操作保存不成功,或者提示本机或服务器网络已断开,请连网后重试

  • 删除仪表板,删除自助数据集等操作提示本机或服务器网络已断开,请连网后重试,如下图所示:

    12.png

1.1.2 页面空白

点击添加 SQL 数据集后页面空白,如下图所示:

21.png

1.2 原因分析

  • 转发或者域名配置导致的问题

  • 网络对特殊字符请求头拦截

  • 服务器停止运行

  • web.xml配置问题

2. 排查步骤

2.1 检查域名 IP 

检查当前访问地址是否配置过域名访问,如果是,可直接用服务器的 IP 登录系统进行操作验证,若操作无异常说明是域名问题,需要联系网络运维人员查看。

2.2 检查 Nginx 配置

检查当前环境是否配置过 Nginx 服务器,如果配置过,直接使用服务器 IP 登录之后进行验证,如果操作无异常则说明是 Nginx 配置问题,可参考 Nginx 文档进行配置,详情参见:Nginx.conf 配置手册

2.3 检查当前网络请求

1)F12 打开控制台,检查当前网络请求,点击 network 查看请求状态是否有502或者403、404报错,如下图所示:

4.png

2)控制台页面是否有大量请求报错网络超时,如下图所示:

3.png

3)如果有证明请求被异常拦截,需要联系网络维护人员确认是否有针对特殊字符请求拦截。

2.4 检查 BI 服务器运行状态

查看 BI 服务器进程,刷新页面查看是否还能正常访问系统,若不能,则需要确保 BI 进程正常。

2.5 检查 web.xml 配置

%FineBI%/webroot/WEB-INF下是否有web.xml文件,如下图所示:

1592366947909473.png

如果有,需要确认文件中是否有针对请求的拦截转发内容。

附件列表


主题: 待翻译
  • 有帮助
  • 没帮助
  • 只是浏览
中文(繁體)

滑鼠選中內容,快速回饋問題

滑鼠選中存在疑惑的內容,即可快速回饋問題,我們將會跟進處理。

不再提示

7s后關閉

獲取幫助
線上支援
獲取專業技術支援,快速幫助您解決問題
工作日9:00-12:00,13:30-17:30在线
頁面反饋
針對當前網頁的建議、問題反饋
售前咨詢
業務咨詢
電話:0933-790886或 0989-092892
郵箱:taiwan@fanruan.com
頁面反饋
*問題分類
不能為空
問題描述
0/1000
不能為空

反馈已提交

网络繁忙