1. 概述
2. 應用商城介面空白/帆軟通行證無法登入
問題描述:
1)以管理者身分進入數據決策系統後,點選「管理系統>插件管理」,應用商城頁面空白,如下圖所示:
2)登入帆軟通行證時,提示:未知錯誤。如下圖所示:
原因分析:
有兩個原因:
1)原因一:伺服器沒有連外網。
2)原因二:伺服器可以通外網,在平台系統管理節點的「標準」 Tab 頁中關閉了連結位址管理中心按鈕,插件引擎模組無法使用。
解決方案:
1)原因一解決方案
伺服器連結外網。
2)原因二解決方案
以管理者身分進入數據決策系統,點選「管理系統>系統管理>標準」,開啓「連結位址管理中心按鈕」,點選儲存。如下圖所示:
注1:遠端環境中若關閉連結位址管理中心按鈕,也將出現本節「問題描述」中的現象。
注2:連結位址管理中心按鈕的介紹請參見:標準 中的 2.2 節內容。
3. 插件商店有新版本
以管理者身分進入數據決策系統時,點選「管理系統>插件管理」,插件管理介面有時會彈窗提示:插件商店有新版本,是否更新?
如下圖所示:
此時更新的是帆軟商城中插件,不會更新已安裝的插件,點選確定按鈕即可。
4. 插件線上安裝/更新無進度
問題描述:
在數據決策系統安裝/更新插件時卡住,不顯示進度條,不顯示「安裝完成」。重新整理頁面後,發現插件已經安裝/更新好了。
原因分析:
WebSocket埠被佔用了,無法主動給瀏覽器派送訊息。
解決方案:
開放 WebSocket 埠,詳情請參見:Websocket 連結失敗 。
5. 插件本地安裝/更新無進度
問題描述:
從本地選擇插件安裝包,安裝插件後,無安裝進度,不顯示「插件安裝成功」。
原因分析&解決方案:
1)插件安裝包過大,安裝較緩慢。請耐心等待即可。
2)工程環境無法連結安裝包所在的位置。例如無法連結外網等。開放網路路徑即可。
3)插件安裝目錄無權限,請給插件安裝的 cache 目錄開下 777 權限。