1. 概述
本文将主要介绍不同注册方式下,系统注册出现问题的原因和解决方案。
2. Lic上传卡住
问题描述:
上传注册Lic文件时,卡在上传中的页面无进展。
排查步骤:
进入工程%BI_HOME%/webroot/WEB-INF/resources 目录下,查看「FanRuan.lic」文件的修改时间,判断文件是否成功上传。
1)文件未成功上传
原因分析:若文件未成功上传,一般是由于系统禁用了PUT请求,导致请求不正常
解决方案:用户可通过安装「PUT、DELETE请求转成POST」插件,将 PUT、DELETE 请求转成 POST 请求。详情请参见:PUT、DELETE请求转成POST插件
2)文件成功上传
原因分析:若文件成功上传,可能是前台没有及时刷新。
解决方案:手动刷新下平台页面,查看是否显示注册成功。若仍未成功注册,请根据注册失败的报错信息参考下文解决。
3. Lic上传失败
问题描述:
上传注册Lic文件时,弹窗报错「文件 FanRuan.lic不能通过校验,请检查他。」
解决方案:
管理员登录FineBI系统,点击「管理系统>安全管理>安全防护」,临时关闭「文件上传校验」,待注册成功后再打开。
4. 证书已过期
问题描述:
注册时,提示「注册失败,请重新注册」。点开详细信息,提示:
过期时间:xxxx-xx-xx
原因分析:
当前工程使用的注册Lic文件,已到达合同约定的过期时间。
解决方案:
1)若确定已达到合同约定的过期时间,请联系销售进行续购。
2)若合同约定的过期时间还未到,但lic已过期,请联系销售重新索要正确的注册Lic文件。
5. 版本不匹配
问题描述:
注册时,提示「注册失败,请重新注册」。点开详细信息,提示:
认证应用版本:9.0
本地应用版本:10.0
原因分析:
帆软有两种版本升级情况,大版本(9升10,10升11)和小版本(10.0.1升10.0.2)
1)大版本升级影响授权
跨大版本升级,例如从 9.0 升级到 10.0 ,会对授权文件有影响,需要重新注册或迁移授权。
2)小版本升级不影响授权
小版本之间的升级,例如从 10.0.9 升级到 10.0.10 ,对授权文件无影响。
解决方案:
1)若为全新注册,且合同约定的工程版本与产品版本一致,请联系销售重新索要正确的注册Lic文件。
2)若为升级的新工程,不能直接使用老工程的注册Lic文件,请联系销售确定升级后的授权迁移相关事项。
6. MAC地址不匹配
问题描述:
注册时,提示「注册失败,请重新注册」。点开详细信息,提示:
认证 MAC 地址:xxx
本地 MAC 地址:xxx
排查步骤:
MAC 地址,用于在网络中唯一标示一个网卡。一台设备可以有多个网卡,每个网卡都有唯一的 MAC 地址。
注册 Lic 文件中的 MAC 地址,必须能与服务器的任意一个 MAC 地址匹配。
Linux 或 Unix 系统的 MAC 地址格式和一般的MAC形式不一样,比如为 0*001F296EFD64。
服务器系统 | 部署方式 | 原因分析和解决方案 |
---|---|---|
Windows | - | 原因分析:更换了网卡,导致MAC地址变更 解决方案:请联系商务重新授权 |
原因分析:手动修改了工程所在服务器的MAC地址 解决方案: 方案一:把MAC地址改回来 方案二:联系商务重新授权 | ||
Linux | docker部署 | 原因分析: 若未固定 docker 的 MAC 地址和 UUID,重启会随机改变MAC地址 解决方案: 1)docker部署,建议固定MAC地址 2)不绑定MAC地址,建议使用私有云/公有云认证 |
虚拟机 | 原因分析: 虚拟机的MAC地址分为三种: 1)固定MAC地址:可以配置固定的MAC地址,重启不变。 2)继承宿主机MAC地址:和宿主机MAC地址保持一致,重启不变。 3)动态MAC地址:前缀相同,后四位随机变动,重启改变。 解决方案: 1)确认近期是否更换宿主机硬件或重装系统,若更换会导致MAC地址变更,请联系商务重新授权 2)若虚拟机为动态MAC地址,建议使用私有云/公有云认证 | |
物理机 | 原因分析: 使用脚本重启,脚本中没有切换 root 用户, 或者访问对应命令的权限。 解决方案: 尽量使用root用户启动并给与访问对应命令的权限 | |
原因分析: Linux系统的中间件(如Tomcat),以root和非root用户启动,MAC地址会不一样 解决方案: 尽量使用root用户启动并且保持一致 |
7. 机器码不匹配
问题描述:
注册时,提示「注册失败,请重新注册」。点开详细信息,提示:
认证机器码:xxx
本地机器码:xxx
排查步骤:
因素 | 原因分析和解决方案 |
---|---|
系统硬件 | 原因分析:更换了硬件,如cpu,硬盘,主板等,都会导致机器码变化 解决方案:请联系商务重新授权 |
JDK | 原因分析:机器码的读取是依赖JDK的,JDK更换可能会导致机器码变化 解决方案:修改回原先的JDK,修改回原先的环境变量 |
虚拟机 | 原因分析:虚拟机重启会导致机器码变化 解决方案:请联系商务重新授权 虚拟机不建议使用本地机器信息认证,建议使用私有云/公有云认证 |
权限 | 原因分析:Linux系统的中间件(如Tomcat),以root和非root用户启动,机器码会不一样,甚至获取不到 解决方案:尽量使用root用户启动并且保持一致 |
云系统 | 原因分析:修改配置就会导致机器码变化 解决方案:请联系商务重新授权 虚拟机不建议使用本地机器信息认证,建议使用私有云/公有云认证 |
8. 应用名不匹配
问题描述:
注册时,提示「注册失败,请重新注册」。点开详细信息,提示:
认证应用名:xxx
本地应用名:xxx
原因分析:
工程地址形如http://ip:port/工程名/decision,工程名一般为webroot
当出现该报错时,一般都是由于工程名被改动了
解决方案:
在给商务发送授权申请邮件时:
若备注了工程名,那么返回的注册Lic文件就是邮件中备注的工程名
若未备注工程名,那么返回的注册Lic文件对应的工程名为webroot
请将工程的用户名修改成与注册Lic文件一致。
9. 已达可授权数量上限
问题描述:
注册时,提示「注册失败,请重新注册」。点开详细信息,提示:
超过最大注册数量
排查步骤:
注册方式 | 因素 | 原因分析和解决方案 |
---|---|---|
本地机器认证 | 服务器下存在多个工程 | 原因分析: 工程所在服务器下,存在其他工程,占用了该注册Lic文件。 解决方案: 检查工程所在服务器下的其他工程%BI_HOME%/webroot/WEB-INF/resources目录下,查看「FanRuan.lic」文件的修改时间。 若为新增的注册Lic文件,删除后,进入到正确的工程重新注册即可。 |
工程重复加载 | 原因分析: Tomcat域名配置不正确,在Tomcat的server.xml中配置了两个<host>,一个域名一个ip,该配置方式导致工程重复启动两次,所以lic会报错已占用。 解决方案: 删除xml中ip的<host>,只保留域名的<host>,ip还是可以正常访问的,不需要单独配ip。 | |
指定启动路径 | 原因分析: server.xml中配置了虚拟路径,导致工程二次重启了。 解决方案: Tomcat设置工程访问路径的正确方式请参见:Tomcat设置工程访问路径 方案一:注释掉server.xml中docBase配置,重启后即可正常注册。 方案二:将webroot工程移动到webapps文件夹外的路径,然后指定对应路径,重启后即可正常注册。 | |
公有云 | 工程占用授权 | 原因分析: 申请公有云授权时,会提交一个最大可注册量 如果超出了这个最大可注册量,就会出现此报错 解决方案: 将老工程上的授权手动解绑,再到新工程上绑定 |
物理信息变更 | 原因分析: 虚拟机重启,物理信息变更,导致达到注册上线 请联系技术支持,确认名下是否存在占用公有云注册数的工程 解决方案: 请技术支持协助解绑,再进行工程绑定 |
10. 证书内容不正确
问题描述:
注册时,提示「注册失败,请重新注册」。点开详细信息,提示:
证书内容不正确
排查步骤:
因素 | 原因分析和解决方案 |
---|---|
用户权限 | 原因分析: 启动工程的用户,没有写文件的权限,配置777权限,日志报错: [Resource] Write failed! 解决方案: 重新配置写权限即可,或尽量使用root用户启动 |
重复运行迁移程序 | 原因分析: 在授权迁移时,第一次运行迁移程序成功后,会产生一个新授权。 使用新授权注册成功后,若再次运行迁移程序,会将当前已正式注册的授权销毁。 解决方案: 请联系商务重新授权 |
更多原因 | 出现该报错的更多情况,都需要根据工程实际情况一一排查,建议联系技术支持 技术支持联系方式:「服务平台>在线支持」、电话「400-811-8890」。 |
11. 本地容器认证
11.1 节点已经全部重启
问题描述:
工程本地容器认证,重启后注册页报错,提示「节点已经全部重启」。
原因分析:
重启服务器后,本地容器认证就是需要重新注册,产品设计如此。
解决方案:
重新手机扫码认证即可。
11.2 错误码40002,lic已在其他机器注册
问题描述:
修改了服务器的配置库后,重启服务器,再用手机扫码认证。
提示「错误码40002,lic已在其他机器注册」。
原因分析:
修改配置库后,本地容器认证需要重新注册。
解决方案:
请联系商务取消原服务器的注册授权,再次使用商务发送的 Container.lic 文件进行注册。
12. 私有云认证程序启动异常
认证程序启动时,会出现各种报错信息,请按照具体报错排查
报错 | |
---|---|
已卸载 | 认证服务器之前卸载过,如需再次在同一授权服务器使用认证服务器,需重新获取机器信息重新注册 |
已过期 | 跟系统时间有关系 如注册时的系统时间是12-21-16:18:55,私有云生效的时间是12-21-16:40:29 |
错误码30002 账户状态不正常 | 1)销毁原认证服务器后,没有重新生成新的机器信息,而是直接使用了原机器信息,造成rif机器信息文件中sessionid重复 2)跟执行启动命令权限有关系,推荐root运行 |
address already in use | 端口被占用。重新换接口启动认证程序: 使用命令行启动程序的时候后面加参数-port端口指定另外端口
|
13. 公有云认证
13.1 网络问题
1)客户BI工程服务器必须与授权服务器通过公网连通,不允许开放外网的客户无法使用该注册方式。
需要开放的外网地址包括:
域名 | 端口 | 说明 |
---|---|---|
https://register.fanruan.com | 443 | 公有云认证服务器 |
https://cloud.fanruan.com | 443 | 网址管理中心 |
2)连接网址管理中心未开启,导致工程无法联网。
管理员登录FineBI系统,点击「管理系统>系统管理>常规」,开启「连接网址管理中心」。如下图所示:
13.2 系统时间问题
原因分析:工程服务器上的系统时间与当前实际的时间不一致。
解决方案:把服务器的系统时间修改为当前对应的时间即可。
13.3 账号存在特殊字符
原因分析:公有云账号不支持中文和中文标点符号。
解决方案:联系商务更换公有云账号。
14. 达到限制值
注册时,会对注册时间、数据连接数、并发数、用户数进行限制。若达到限制值,则会出现报错或异常状态。
若当前系统已注册,超级管理员登录数据决策系统,在当前页下访问http://IP:端口/webroot/decision/v10/register/info/license,即可查看注册时的限制值。如下图所示:
若数据连接数达到限制值,则将无法添加数据连接,新添加的数据连接不显示。
若并发数达到限制值,则后登录的 IP 地址将无法登录。
若注册为永久注册,过期时间为100年后。100年过期后,请联系帆软商务进行免费注册。
若更换服务器硬件,有可能造成机器码更改,从而导致注册失效。
若更改工程名,会导致工程名不一致,从而导致注册失效。
若用户数达到限制值,则将无法添加用户,新添加的用户报错「与其他管理员操作冲突,请刷新后重试」。
若分布式节点数达到限制值,则将无法新增节点,新添加的节点不显示。
15. 缺少功能点
若使用 FineBI 时,发现某些功能不可用,直接报错或者打不开,
出现类似报错:您使用了未注册的功能或java.lang.NullPointException 空指针异常。
注:功能点的影响请参见:注册管理
这是由于注册时未购买某些功能点。在「数据决策系统>管理系统>注册管理>功能列表」中,可以查看到已注册的功能点,如下图所示:
如需新增购买某些功能点,请联系帆软商务,商务邮箱 business@fanruan.com
16. 多种注册并存
当服务器同时拥有 license 授权文件和加密锁,则以 license 授权文件为主。
因为服务器首先会去读取 license 授权文件,若授权文件不存在才会读取加密锁,因此 MAC 地址注册的优先级高于加密锁注册。
17. license 文件没有生效导致图表显示空白
使用新的 license 文件后,设计器预览图表显示空白?
因为将获取的 FanRuan.lic 文件放到工程%BI-HOME%\webroot\WEB-INF\resources目录下,没有重新启动 Web 服务器,导致图表不能预览。
所以使用 license 文件必须重新启动 Web服务器,license 才能生效。
18. 报空指针错误
在预览一些模板时,报 java.lang.NullPointException 空指针异常。
因为该模板中包含了一些 license 文件中不包含的功能。