反馈已提交

网络繁忙

升级风险项及处理方法

  • 文档创建者:Roxy
  • 编辑次数:9次
  • 最近更新:Wendy123456 于 2021-10-11
  • 1. 环境类检测项

    问题
    解决方案
    磁盘空间检测小于1G检测到当前磁盘剩余空间不足 1G ,请确保磁盘空间大于 1G 再进行升级,您可以先清理磁盘空间然后进行升级
    外接数据库权限缺失检测到您系统使用外置库且当前用户无外置库表的增删改查(DDL)权限,建议您联系数据库运维人员修改对应权限后再进行升级
    外接数据库编码有误MySQL 编码修改为 utf8 或 utf8mb4 

    SQLServer 编码修改为 Chinese_PRC_CS_AS 

    msvcr120.dll 运行库不存在

    Windows 系统下,用户从旧版本升级到 5.1.15 及之后版本,部分用户会遇到这个提示。建议安装 msvcr120.dll 文件后再进行升级,缺失文件下载请参见:Microsoft Visual C++ Redistributable 最新支持的下载

    注:只有下载Visual Studio 2010 (VC++ 10.0) SP1版本才能解决该问题

    系统曾发生升级回退不规范检测到您系统曾经发生升级未按照文档回退配置内容,该操作可能产生脏数据,强烈建议您先测试环境进行升级验证
    检测当前环境是否为集群环境,如果是提示更新 nginx参考帮助文档 版本升级Nginx配置指导 更新 nginx 转发配置

    2. 配置类检测项

    问题解决方案
    配置外置库为 MySQL 且参数 max_allowed_packet 小于 1073741824 ,影响配置兼容执行检测到外置库为MySQL,且参数 max_allowed_packet<1073741824,升级过程需要对配置进行兼容调整,参数过小会导致配置写入数据库失败,为保证升级顺利进行,请您优先调整 max_allowed_packet 参数,调整方式如下:

    方案一:

    MySQL 安装目录下的「my.ini」文件中的 [mysqld] 字段中的「max_allowed_packet = 1M」修改为 1024M ,重启 MySQL 即可

    方案二:

    1)使用set global max_allowed_packet = 1073741824;语句将max_allowed_packet的值设置为 1024M,无需重启

    2)使用show VARIABLES like '%max_allowed_packet%'; 语句查看是否修改成功

    数据更新路径没有文件读写权限请使用 chmod 路径给该路径赋权 ,命令格式如下 chmod -R 777 xxx路径
    JDK版本低于1.8.0.102检测到 JDK 版本低于1.8.0.102 ,旧版本 JDK 存在漏洞,升级后会存在启动崩溃的现象,需要更换为 1.8.0.102 以后版本的 JDK 再进行升级。 

    JDK 版本更新后引入加密套件,可能导致数据连接连接不上,需要按照如下文档进行完善:JDK 升级及注意事项

    当前为单机环境但是残留集群相关配置,需删除残留参数检测当前为单机环境但是残留集群相关配置,需删除残留参数,以下热备参数需删除,需连接配置库中将 fine_conf_entity 表中对应参数进行修改:

    非空则提示需删除ID为:SystemOptimizationConfig.biClusterMasterNodeHostName  

    非空则提示需删除ID为:hotBackConf.master  

    非空则提示需删除ID为:SystemOptimizationConfig.ClientMasterId   

    非空则提示需删除ID为:hotBackConf.slave  

    系统近一天内无成功备份建议您 备份 后再进行升级

    3. 驱动文件检测项

    问题解决方案
    外置库为 oracle11g 及以上版本且 lib 目录下无 ojdbc8检测到当前系统使用的外置库为 oracle11g 及之后的版本,建议您将驱动更换为 ojdbc8 再进行升级,需要将 ojdbc14.jar 文件更换为 ojdbc8.jar 和 orai18n.jar 两个 jar 文件
    hive、phoenix、spark、impala、TRANSWARP 、INCEPTOR安装驱动隔离插件检测到系统使用了 hive、phoenix、spark、impala、TRANSWARP 、INCEPTOR 等大数据平台,其使用的驱动容易和BI的代码产生冲突,强烈建议您配置驱动隔离以保证系统的稳定运行,详细配置方式请参见:5.1.2 及之后版本驱动隔离插件

    4. lib 文件检测项

    问题解决方案
    commons 等 jar ,检测后提示删除检测到该文件容易和 BI 的代码产生冲突,需要您删除之后重启BI,然后进行升级
    lib 下文件夹、zip 文件、重名文件,检测后提示删除检测到 lib 文件中存在文件夹、zip文件、重名文件,此类型文件极容易导致BI运行不稳定,需要您删除之后重启 BI,然后进行升级
    lib文件中存在大数据平台的驱动检测到 lib 文件中存在 hive、phoenix、spark、impala、TRANSWARP 、INCEPTOR 等大数据平台的驱动,该文件容易和 BI 的代码产生冲突,需要您删除之后重启 BI ,然后进行升级
    存在 fr-xxxx-8.0、fr-xxxx-9.0、fr-xxxx-4.0、fr-xxxx-4.1、fr-slf4j-frlog4j检测到 lib 文件中存在 8.0、9.0 版本的 jar 文件,该文件容易和 BI 的代码产生冲突,需要您删除之后重启 BI ,然后进行升级
    lib 下文件夹下非 txt 和 jar 文件认为是非法文件,检测后提示删除检测到 lib 文件中存在非 jar 和非 txt 的文件,可能对工程产生影响,请删除后在升级

    5. 插件检测项

    提示
    解决方案
    存在二开插件检测到插件管理中存在二开插件,建议您联系技术支持确认新版本插件的是否兼容
    插件管理中存在单点插件检测到插件管理中存在单点登录插件,建议您联系技术支持确认新版本插件的是否兼容
    插件管理中存在「多域LDAP认证插件」检测到插件管理中存在「多域LDAP认证插件」,该插件新版本功能逻辑发生变更,需手动进行调整,详见:多域LDAP认证

    检测当前环境是否能连接到插件商城,提示升级后插件需要升级

    (有外网)升级后请登陆系统,打开插件管理页面升级提示需要升级的插件,当前已经安装XXX个插件,如不更新对应的插件将导致部分功能异常。

    (无外网)检测到当前环境无法连接到插件商城,请打开 插件商城 查看已安装插件是否有新版本更新,并下载对应的插件进行本地更新,当前已经安装 XXX 个插件,如不更新对应的插件将导致部分功能异常



    附件列表


    主题: 产品简介
    • 有帮助
    • 没帮助
    • 只是浏览

    售前咨询电话

    400-811-8890转1

    在线技术支持

    在线QQ:800049425

    热线电话:400-811-8890转2

    总裁办24H投诉

    热线电话:173-1278-1526

    文 档反 馈

    鼠标选中内容,快速反馈问题

    鼠标选中存在疑惑的内容,即可快速反馈问题,我们将会跟进处理。

    不再提示

    10s后关闭