内置jdbc驱动版本总结

  • 文档创建者:doreen0813
  • 编辑次数:4次
  • 最近更新:Wendy123456 于 2021-04-25
  • 1. 概述

    FineBI 包含了很多的内置驱动,这些驱动对应的 JDK 版本为 JDK1.8 。在使用过程中,须确保驱动与 JDK 版本的一致性。若使用内置的驱动,则环境 JDK 需为 1.8 版本;若不想更换环境的 JDK 版本,则需在工程下替换与该 JDK 一致的驱动版本。下面我们将列出 FineBI 所包含的一些内置驱动和匹配 JDK 版本。

    2. 内置驱动

    内置驱动和匹配 JDK 版本如下表所示:

    数据库驱动JDK
    SQL Serversqljdbc42.jar
    JDK 1.8 且小版本需在 JDK8u102 以上
    DB2db2jcc4.jar、db2jcc_license_cu.jar
    H2h2-1.4.192.jar
    Informixifxjdbc.jar
    Sybasesybase.jar
    MySQLmysql-connector-java-5.1.6-bin.jar
    Oracleojdbc14.jar

    驱动 JAR 包地址为:%FineBI%/webapps/webroot/WEB-INF/lib下,若 JDK 版本不匹配,可去该路径下替换驱动版本。

    如环境 JDK 版本为 1.7 ,想要连接 SQL Server 数据库,但是版本与内置驱动不匹配,需将 SQL Server 的驱动sqljdbc41.jar 拷贝至上述目录,并删除 sqljdbc42.jar 。

    附件列表


    主题: 连接到数据
    • 有帮助
    • 没帮助
    • 只是浏览

    售前咨询电话

    400-811-8890转1

    在线技术支持

    在线QQ:800049425

    热线电话:400-811-8890转2

    总裁办24H投诉

    热线电话:173-127-81526