反馈已提交

网络繁忙

您正在浏览的是 FineBI6.1 帮助文档,点击跳转至: FineBI5.1帮助文档

权限管理异常排查步骤

  • 文档创建者:Roxy
  • 历史版本:18
  • 最近更新:Suki陈 于 2023-09-13
  • 1. 概述

    用户在使用 BI 时,由于不规范的操作,可能会出现仪表板访问报错无权限、权限设置未生效等问题。

    本文提供权限异常后的排查步骤。

    2. 仪表板访问报错无权限

    2.1 仪表板整体报错

    2.1.1 问题现象

    访问仪表板时,仪表板整体都报错:非常抱歉,您无法查看该页面,您没有该页面的访问权限,如需访问请联系管理员,如下图所示:

    1592471587484947.png

    2.1.2 排查步骤

    1)进入 管理系统>模板认证,查看是否开启了模板认证。若配置了 角色权限认证 ,并且是直接分享仪表板出现该报错,直接分享报错如下图所示:

    配置了 角色权限认证 并且以模板预览 URL 的方式分享报错如下图所示:

    333.png

    解决方法:

    • 若不需要开启模板认证,则直接进入管理系统>模板认证,关闭模板认证并点击保存,如下图所示:

    模板认证详情参见:模板认证 

    • 若不需要开启某张模板的模板认证,可在需要认证的模板里找到想要查看的模板并关闭认证,例如公司综合运营驾驶舱显示没有权限,可设置该模板为不需要认证的模板,如下图所示:

    • 若问题模板需要开启模板认证,可在认证配置里为其配置查看权限,如下图所示:

    2)管理员进入管理系统>用户管理>PC端使用用户>平台使用用户,确认当前用户归类,需要确认首先将其添加至PC端使用用户,然后添加至 BI 使用用户下的查看用户或者设计用户中,详情参见:平台使用用户

    2.2 部分组件报错无数据权限

    2.2.1 问题现象

    访问仪表板时,仪表板中部分组件报错:您暂时无权限查看该组件数据,如下图所示:

    1592477022291999.png

    2.2.2 排查步骤

    1)进入管理系统>权限管理,管理员检查用户对组件使用的数据表是否有「组件数据」权限,如下图所示:

    2)若使用的数据表为自助数据集,则需要检查自助数据集是否开启了权限继承,用户是否有自助数据集父表的查看权限。

    详情参见:权限继承 

    3. 过滤权限未生效

    3.1 确认用户基本信息

    管理系统>用户管理中输入用户信息进行查询,锁定用户所在的所有部门、角色,如下图所示:

    查看根据部门、职务、角色进行设置的权限。

    3.2 确认用户已经配置权限

    确认用户已经配置了对应仪表板或者数据准备文件夹下数据表的权限。

    3.3 确认用户权限设置符合逻辑

    详情参见:行列权限特殊场景

    4. 目录处仪表板无导出选项

    4.1 问题现象

    登录 Alice 账号,在目录查看整个仪表板无法导出,单个组件也无法导出,如下如所示:

    4.2 排查步骤

    4.2.1 确认配置导出权限

    管理员进入「管理系统>权限管理>目录权限」,确认开启「导出权限」,如下图所示:

    4.2.2 确认是否开启模板认证

    若开启了 角色权限认证,要想拥有目录仪表板的导出权限,需要「权限配置」和「模板认证」都配置了模板「导出」权限。

    注:在模板认证中若设置了部门/角色/用户无导出权限,不论是否在「权限管理>目录权限」中开启了导出权限,在仪表板编辑状态下、目录查看仪表板、首页查看仪表板、查看分享给我的仪表板都不能导出,包括全局导出和组件导出。

    因此管理员需要给 Alice 开启模板认证对应 BI 模板的「导出」权限,如下图所示:

    注:对于用户直接分享或者 URL 的方式分享的模板,查看和导出的权限取决于模板认证中给此用户配置的权限情况,即:配置了模板认证的查看权限,即可查看此仪表板;配置了模板认证的导出权限,即可导出此仪表板。

    5. 无法添加/修改 SQL 数据集和添加数据库表

    注:在「公共数据」指定文件夹下添加/编辑/删除数据库表、SQL数据集、Excel数据集的详细操作步骤请参考:公共数据管理权限

    5.1 问题现象

    用户拥有「公共数据」下指定文件夹的管理权限,但无法在该文件夹下添加/修改 SQL 数据集,添加数据库表。如下图所示:

    5.2 排查步骤

    5.2.1 检查用户数据连接权限

    点击「管理系统>权限管理>数据连接」,查看用户是否拥有想要添加的数据库表和 SQL 数据集所使用的数据连接使用/管理权限,如下图所示:

    注:需要开启全局设置才能设置数据连接,详情参见:数据连接控制

    5.2.2 检查外接数据库的字符排序规则

    若 FineBI 系统配置了 MySQL 类型的外接数据库,且用户拥有相应数据连接的管理权限,则可能是外接数据库的排序规则导致的数据连接权限异常。

    可参考 配置MySQL5外接数据库 或 配置MySQL8外接数据库 的 4.2 节进行排查修改。

    6. 无法移动文件夹

    6.1 问题描述

    用户无法移动文件夹到其他分组,如下图所示:

    6.2 原因分析

    用户需要拥有需要移动到的「分组」节点的管理权限,且「被移动的文件夹」必须是拥有「管理」权限的。

    例如,用户 Alice 希望能将「功能数据」文件夹移动至「行业数据>机械制造」分组下,如下图所示:

    此时管理员必须为用户授权「功能数据」分组节点的「管理」权限,以及「行业数据>机械制造」文件夹「管理」权限,如下图所示:

    但用户无法将「功能数据」分组下的文件夹移动到「行业数据」分组下,因为用户没有「行业数据」分组的「管理」权限。

    7. 无法在对应分组下创建文件夹和数据集

    7.1 问题描述

    用户无法在对应分组下新建文件夹和数据集,如下图所示:

    7.2 原因分析

    管理员必须为用户开启对应分组管理权限,例如开启功能数据分组的管理权限,如下图所示:

    此时用户即可拥有新建文件夹和数据集的权限,如下图所示:

    详情参见:公共数据文件夹管理权限

    附件列表


    主题: 管理系统
    已经是第一篇
    已经是最后一篇
    • 有帮助
    • 没帮助
    • 只是浏览
    中文(简体)

    鼠标选中内容,快速反馈问题

    鼠标选中存在疑惑的内容,即可快速反馈问题,我们将会跟进处理。

    不再提示

    10s后关闭



    AI

    联系我们
    在线支持
    获取专业技术支持,快速帮助您解决问题
    工作日9:00-12:00,13:30-17:30在线
    页面反馈
    针对当前网页的建议、问题反馈
    售前咨询
    采购需求/获取报价/预约演示
    或拨打: 400-811-8890 转1
    qr
    热线电话
    咨询/故障救援热线:400-811-8890转2
    总裁办24H投诉:17312781526
    提交页面反馈
    仅适用于当前网页的意见收集,帆软产品问题请在 问答板块提问前往服务平台 获取技术支持