反馈已提交

网络繁忙

FDL启动问题排查

  • 文档创建者:fanruan12321
  • 历史版本:19
  • 最近更新:Wendy123456 于 2024-06-13
  • 1.1 平台界面报错:数据平台启动未成功,请稍等

    原因1

    查看fanruan.log日志,报错未知的名称或服务

    服务器的主机地址没有绑定ip地址

    解决方案:

    Linux服务器下输入hostname,查看主机名。

    在etc/hosts的127.0.0.1的后面加上查到的hostname。

    参考:https://blog.csdn.net/M983373615/article/details/103195151

    原因2

    日志无相关报错,但是缺少jar包:fine-bi-engine-third-5.1.jar,报错:

    解决方案:

    一般是FineReport集成部署FDL时出现。

    可以联系帆软技术支持获取对应版本的jar包;

    原因3

    FR版本和FDL版本不匹配,报错Data Platform start failed,fine-data-prep-11.0.jar:?

    fine-data-prep-11.0.jar还是插件版本的FDL,属于很久之前的版本,而FR已经是最新的版本,两者之间不匹配,查看catalina.out日志报错如下:

    解决方案:

    升级FDL版本,参考帮助文档即可,插件版FDL需要先删除旧jar包[fine-data-prep-11.0.jar],再放入新jar包,注意备份。

    原因4:

    BI6.0集成的数据平台,Spider引擎启动失败,导致FDL启动失败。BI启动失败是因为netty-all-4.1.17.Final.jar冲突,该jar包内容已做到主线jar里,可以删除。fanruan.log日志报错如图。

    解决方案:

    移除netty-all-4.1.17.Final.jar。

    1.2 启动报错:检测到1项配置异常,数据库连接异常

    原因:

    一般是集成版本FDL会出现该问题,主要是FR的内置库不能多线程连接,有其他应用正在使用内置库,导致报错。

    解决方案:

    切换为外置库,或者删除db.lck。FR安装目录\webapps\webroot\WEB-INF\embed\finedb 下的 db.lck 文件删除。

    注:该方法在运行一次后仍会报错,需要反复删除 db.lck 文件。

    1.3 Linux环境FDL启动报错

    Could not initialize class sun.awt.X1Graphics Environment

    原因:

    FDL安装包默认通过GUI图形化页面启动,但是在linux环境下是没有图形化页面的,所以报错 ,在启动时添加 -c命令,使启动策略调整成通过控制台的方式。

    解决方案:

    报错文档:https://stackoverflow.com/questions/21131855/could-not-initialize-class-sun-awt-x11graphicsenvironment-on-solaris,操作方法:./XXX.sh -c

    1.4 使用sh安装文件,在linux用./FineDataLink命令无法启动安装程序


    产生原因:

    linux环境语言不对

    解决方案:

    linux语言LANG改为zh_CN.UTF-8,改好后重连一下shell再启动FDL

    1.5 使用sh安装文件,报错Unpacking JRE


    解决方案:

    执行以下yum命令

    yum install -y fontconfig

    yum install -y urw-fonts

    安装一下字体,检查安装路径下面有没有文件残留,有的话删掉,再重新部署下就可以

    1.6 安装启动进入浏览器异常,日志报错database is not initilized

    原因:

    tomcat和服务器内存都比较小,数据库没有启动

    解决方案:

    修改tomcat内存大小,catalina.bat.参考BI是增加如下语句,具体数值需要自己修改

    set JAVA_OPTS=%JAVA_OPTS% -Xms4g -Xmx8g

    set  JAVA_OPTS=%JAVA_OPTS% -XX:PerBytecodeRecompilationCutoff=-1

    set  JAVA_OPTS=%JAVA_OPTS% -XX:PerMethodRecompilationCutoff=-1

    保存后重启即可。

    1.7 安装FDL报错环境缺少文件

    原因:

    Windows环境缺少文件

    解决方案:

    参考百度,修改环境:https://blog.csdn.net/Tianxuan_kong/article/details/120060738

    1.8 浏览器访问工程异常,页面空白

    原因:

    FR的jar自动升级,版本太高导致和FDL不匹配

    解决方案:

    根据FR版本,升级FDL工程,重启后可以了

    1.9 Tomcat启动失败,Catalina.out中报错如图内容

    原因:

    一些线程依然在运行,这个时候由于堆栈跟踪调试的,想试图终止线程,导致非法访问。

    解决方案:

    修改FDL目录下conf文件夹下的server.xml,在Host标签把reloadable(或者autoDeploy)的属性值设为:reloadable=“false”(autoDeploy="false")。可参考以下链接内容。

    https://blog.csdn.net/xiaozhuzhuyang/article/details/113186452

    1.10 FDL和BI同一浏览器访问时不能同时登录

    现象描述:

    部署包安装的FDL

    同一个浏览器,访问BI和FDL的平台,登录其中一个平台,另一个平台会被登出需要重新登录;

    同一个浏览器,访问同一个服务器下部署在不同路径的工程,仅端口号不同,当其中之一登录另一个被踢出。

    原因分析:

    身份信息存在token中,token存在cookie中,cookie只到域名。

    解决方案:

    • 在FDL工程的fine_conf_entity表中添加字段ServerConfig.cookiePath,值设置为/webroot1,将tomcat/webapps的工程名也改为webroot1,此时工程A的cookie将存入/webroot1中,工程访问路径为:http://localhost:8080/webroot1/decision

    • 在BI工程的fine_conf_entity表中添加字段ServerConfig.cookiePath,值设置为/webroot2,将tomcat/webapps的工程名也改为webroot2,此时工程B的cookie将存入/webroot2中,工程访问路径为:http://localhost:8081/webroot2/decision

    1.11 FDL提示网页无法访问,可以查到tomcat的进程

    现象描述:

    fdl无法打开,重启tomcat也不行,能查到tomcat进程。

    原因分析:

    重启服务器,再重启tomcat,发现真正报错. /tmp 无法写入。

    解决方案:

    通过 du -sh * 命令从根目录一层一层找下,发现catalina.out达到32G,清理日志并设置日志级别Tomcat日志文件过大的解决方案 。

    1.12 提示数据平台未启动

    现象描述:

    FDL 启动后进入平台,提示数据平台未启动,之后也一直是未启动的状态。 日志报错Caused by: java.lang.IllegalStateException: Duplicate key SUCCESS

    解决方案:

    升级到 4.0.26 及之后版本。

    1.13 启动报错404

    现象描述:

    启动工程后,访问工程报错 404 。

    解决方案:

    磁盘空间满了。可清除大文件/磁盘扩容来解决。



    附件列表


    主题: 部署升级
    • 有帮助
    • 没帮助
    • 只是浏览
    • 评价文档,奖励 1 ~ 100 随机 F 豆!

    鼠标选中内容,快速反馈问题

    鼠标选中存在疑惑的内容,即可快速反馈问题,我们将会跟进处理。

    不再提示

    10s后关闭



    AI

    联系我们
    在线支持
    获取专业技术支持,快速帮助您解决问题
    工作日9:00-12:00,13:30-17:30在线
    页面反馈
    针对当前网页的建议、问题反馈
    售前咨询
    采购需求/获取报价/预约演示
    或拨打: 400-811-8890 转1
    qr
    热线电话
    咨询/故障救援热线:400-811-8890转2
    总裁办24H投诉:17312781526
    提交页面反馈
    仅适用于当前网页的意见收集,帆软产品问题请在 问答板块提问前往服务平台 获取技术支持