概述
本文讲解,在「运维平台接入已有项目」时,常见问题的排查步骤和解决方案。
接入项目过程失败
Get versionAck failed
问题描述:
管理员在帆软应用端发起对接请求,点击「保存」后,提示「Get versionAck failed」
原因分析:
运维平台与帆软应用的对接,依赖帆软应用中的「系统运维」插件。两者有版本匹配要求。
解决方案:
1)请确保FineReport/FineBI/FineDataLink应用安装了「系统运维」插件。
如果应用配置了CAS单点登录,安装「系统运维」插件后,需要重启应用,方可正常与FineOps运维平台对接。
2)请根据FineOps运维平台版本,确认需要安装的「系统运维」插件版本。
优先建议将运维平台与插件均升级到最新版本,再尝试对接。
FineOps运维平台版本 | 工程需要安装的「系统运维」插件版本 |
---|---|
V2.0以下 | V3.0.0以下 |
V2.x版本 | V3.0.0及以上 |
Socket connect timeout
问题描述:
管理员在帆软应用端发起对接请求,点击「保存」后,提示「Socket connect timeout」
排查步骤:
1)检查使用前提
请先参考「接入已有项目使用前提」文档,逐一排查运维平台对接项目的使用前提。
尤其请检查运维平台与「系统运维」插件的版本,建议直接升级到最新版本再进行尝试。
尤其请检查运维平台与帆软应用网络是否互通,建议直接开放内网联通。
2)检查地址指向的服务器
请检查填写的运维平台地址,其中的IP、或域名对应的IP,是否为运维平台ops组件所在服务器
如果自行额外配置了负载均衡,请自行排查负载均衡转发是否配置错误。
3)检查域名对应SSL证书
如果运维平台地址,是域名形式的
请检查证书、域名、服务器IP三者一致。
请检查证书是否公有。如为私有证书,请给帆软应用节点配置信任。
不显示发现新项目弹窗
问题描述:
管理员在帆软应用端发起对接请求,保存成功后显示「待接入」。
但是登录运维平台,并没有出现「发现新项目」弹窗。
解决方案:
1)检查运维平台中已对接的项目,可能之前已经对接过了,无需确认。
2)刷新浏览器窗口,重新访问运维平台。
接入成功后异常
The request authentication failed
问题描述:
项目已成功接入运维平台,项目可用,但状态突然显示为「不可用」
重新编辑测试接入时,报错:The request authentication failed
排查方向一:
原因分析:运维项目被其他运维平台接入了
解决方案:
管理员登录帆软应用,点击「管理系统>系统管理>常规」。在「运维平台连接设置」中,输入「运维平台地址」,点击「保存」。
2)请在五分钟内,使用管理员账号登录运维平台。
运维平台提示「发现新项目」。
点击「添加项目」,设置「项目名称」,点击「确认」即可。
排查方向二:
原因分析:帆软应用的配置库出现了变更,在迁移外接库的过程中,导入了其他配置,导致运维平台读取的项目ID发生了变更,认定为是其他项目。
解决方案:管理员需要在项目管理中,删除该运维项目,重新接入该项目。
can not find cluster
报错信息:2024/07/15 11:25:18 http-nio-8080-exec-37 ERROR [standard] can not find clustercom.fr.ops.exception.ClusterNotFoundException: can not find cluster
原因分析:使用了不满足条件的浏览器访问运维平台,并进行相关运维操作
解决方案:请使用以下版本的浏览器访问运维平台,否则可能导致界面展示和功能操作异常。
浏览器类型 | 推荐版本 |
---|---|
Chrome | 88以上版本 |
Edge | 88以上版本 |
Safari | 14以上版本 |
Firefox | 78以上版本 |
IE | 不支持 |