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Mobile Terminal Functionality FQA

  • Last update:  2023-07-21
  • Overview

    This document mainly summarizes common problems and corresponding solutions on mobile app of FineReport.

    Data Analysis App Homepage not Displaying Parameter Panel

    Problem:

    Data Analysis App does not display the parameter panel (if any) in the mobile homepage template.

    Solution:

    It is a normal phenomenon. You can install the parameter panel plugin.

    Display Style of Foldable Smartphones

    Problem:

    If you use a foldable smartphone, the template style changes after unfolding (display normally when folded).

    Cause:

    After the foldable smartphone is unfolded, it is recognized as a tablet mode and displayed in a tablet style due to the screen width. Displaying the same style as a regular smartphone is not supported temporarily.

    Legend Sliding

    Problem:

    When there are many legends, the mobile end will display them in pages. Button switching/carousel switching (both hidden buttons) in the layout disables internal gestures in the chart, which does not support sliding operations for legends.

    Solution:

    Hold your finger on the legend for a moment to slide it. Otherwise, the entire report will be slid by default.

    Directory Title Modification

    Problem:

    You want to customize the display title. For example, change the current mobile directory title Production Environment.

    Solution:

    Rename the title by the user who has created the mobile server.

    No Display of Vertical Text

    Cause:

    The app has not been specifically adapted for vertical text, and some Android models may automatically parse it (iOS can not). Therefore, there may be a situation where vertical text can wrap on Android but not on iOS within the app.

    Solution:

    Set the text to display as a line break.

    White Borders Appearing When Inserting Images into Cells

    Cause:

    There are gaps between cells after scaling due to a browser bug.

    Solution:

    Adjust the position of the cell by setting rounded corners.

    White Spaces Appearing Between Components on HTML5 Preview

    Problem:

    There are white spaces between components.

    Solution:

    Adjust the spacing (between components on the mobile terminal) to 0.

    Inconsistent Thousands Separator Display Between HTML5 and App Preview

    Problem:

    The display on App is similar to a mark(), while on HML5 similar to a comma(,).

    Cause:

    The mobile apps for iOS and HTML5 use different fonts. In the font used by the app for iOS, the comma(,) is displayed in a form similar to the mark(). On HTML5, the comma is displayed in a similar comma form. There are font differences between native apps and HTML5 apps in different operating systems. For example, there are font differences between mac OS and Windows on the designer.

    Template Content Appearing Blank on HTML5 on Android App

    Problem:

    If multiple report blocks or cells with rounded corners are set in the template, scrolling up and down the template can easily cause some components to fail to load, thus appearing blank.

    Solution:

    Reduce the use of rounded corners for report blocks or cells or use images instead.

    Unable to Find Exported or Downloaded Files on iOS

    Problem:

    After exporting a file through a URL in the iPhone browser, the file cannot be found (normal on Android).

    Cause:

    On iOS 11 and later systems, the app file manager (Files) has been updated, and downloaded files on the phone can be saved to Files. On the earlier system, files were stored in iCloud Drive. After exporting the file, even though the browser progress bar has finished loading, there is no indication that the file has been successfully exported. It seems that the export has failed, but in fact, the file has been downloaded and is being previewed in the browser, which may appear as a page refresh.

    Solution:

    1. After exporting the file, click the share button in the browser and share the file with other apps that can read files.

    2. On iOS11 and later systems, you can save and find the file in the file manager.

    HarmonyOS Preview Network Exception

    Problem:

    After a few minutes of accessing a template, a network exception occurs with a message indicating that the network is unavailable. Restarting the phone can restore the connection, but the issue occurs again after a period of time.

    Cause:

    It takes too long to calculate formulas used in cells, causing a timeout for the mobile request.

    Solution:

    Modify the formulas in cells and update the HTML5 plugin.

    No Effect on Font Color Setting on Android

    Problem:

    The font settings on Android do not take effect.

    Cause:

    There is a problem with phone settings.

    Solution:

    Disable High Contrast Text in Settings > Accessibility.

    Mobile End not Displaying the Template Mounted on PC

    Problem:

    Mount a new template on PC and set the mobile phone as the display terminal, but the app does not display the template. The previously mounted template is displayed normally on the mobile end, but the directory cannot be operated.

    Cause:

    An error in the log: java.lang.NullPointerException

    Solution:

    Restart the designer or find dirty data to delete them.

    The directory fine_authority_object mounts FR templates whose expandType is 102. All FR templates include an additional information in fine_report_extend, which records the parameters and types.

    The error log seems to indicate that there is a problem with the report template. You can execute the SQL sentence select * from fine_authority_object where expandType = '102' and expandId not in(select id from fine_report_expand) to find the dirty data.

    Unable to Get Prompt Information When a Mouse is Connected to Mobile TV

    Problem:

    When you display a large screen on a TV (Android system), remove the HTML5 effect for PC display, and place the connected mouse on the map, there is no prompt information, and clicking the page does not respond.
    Cause:

    Even if the preview mode of the linked content is set to PC preview, the environment is still a mobile device. When the code detects a mobile device, it can only trigger touch events and cannot listen for click events (caused by the mouse). Therefore, an external mouse connected to an Android will not work for clicking.
    Solution:

    Use a touchscreen TV (touch the screen to pop up prompts) or project to an external TV from a computer.

    Implementing Pagination in a Mobile Template Embedded in a Webpage Frame

    Problem:

    A .cpt template (embedded in a webpage frame) is used as the mobile template, and you want the .cpt template to display pagination. However, currently, if it is directly embedded, the toolbar is not displayed in the webpage frame, and the .cpt template cannot be paginated. The pagination button can be displayed by concatenating the parameter op=page_plus (pagination parameter for the new engine), but it may cause a lagging effect.

    Cause:

    Mobile terminal does not support the parameter op=page_plus. The current display logic on mobile is that when the .cpt template is placed in the web frame, the toolbar and the pagination button are not displayed.

    Solution:

    Use report blocks instead of webpage frames, and you can use the toolbar of report blocks.

    Truncation of Cell Content in Report Blocks

    Problem:

    When multiple characters are input into a report block cell, they are truncated when opened on HTML5 on Android app.

    Cause:

    Spaces in the cell characters due to a browser bug
    Solution:

    Remove spaces.

    Error 500 Occurring on App Preview Report

    Problem:

    In the FineBI project, the FineReport template file was placed and mounted. An error message occurs when you preview the template: An unknown error has occurred. Error code: 500. Please contact the administrator.

     

     

    Cause:

    The product does not allow deploying two projects under one container, otherwise it will cause a series of plugin issues.

    Solution:

    Remove conflicting plugins or redeploy the project.

    Template Name Visible but No Icon and Unable to Open on Mobile (Opening Normally on PC)

    Problem:

    The .frm template mounted on the server can be seen normally on PC and App, but the icon of this template cannot be seen on HTML5, and only the name of this template can be seen, as shown in the figure.

    Cause:

    Mismatched plugin version

    Solution:

    Replace the plugin version to make it match the server JAR files.


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