當前為10.0版本文檔,更多實例內容將在最新幫助文檔中展現,點選跳轉至 最新版幫助文檔

插件管理FAQ

1. 概述

1.1 版本

報表服務器版本
10.0

1.2 問題描述

插件安裝和管理過程中,可能會出現一些問題。

本文将提供常見插件安裝/維護問題的解決方案。

2. 插件功能無法使用

問題描述:

數據決策系統(服務器端)安裝插件後,設計器端遠程連接該工程,無法使用插件功能。

原因分析:

1)對於設計器和服務器都會用到的插件,要求服務器端和設計器端都要安裝:

  • 若服務器端安裝了插件,設計器端沒有安裝插件,則插件不會生效,需要切換到本地進行插件安裝。

  • 若服務器端和設計器端均安裝了插件,服務器端的插件下載、删除、禁用不會立即生效,需要等幾分鍾才會生效。

  • 若服務器端和設計器端均安裝了插件,設計器切換到本地,禁用該插件,不影響遠程連接時服務器端的插件使用。

2)若設計器端和服務器端均安裝了插件,但是插件版本不一緻,可能導緻插件功能失效

3. 插件管理界面空白

問題描述:

以管理員身份進入數據決策系統後,點擊管理系統>插件管理,提示:您還沒有插件商店的資源,是否下載?

點擊确定按鈕後,「插件管理」界面依然空白。如下圖所示:

15.png

原因分析&解決方案:

1)設計器和服務器 JAR 包不一緻,保持一緻之後即可恢複正常。

2)用戶在本地或遠程工作目錄中,勾選了使用新插件管理器按鈕。

注:「使用新插件管理器」按鈕具體介紹可參考 選項 中的 3.4 節内容。

image.png

  • 外網用戶:外網用戶在插件管理頁面的彈窗上,點擊确定按鈕後,清理浏覽器緩存,重新進入數據決策系統即可。

  • 内網用戶:請聯系技術支持獲取 upm 文件夾,将 upm 文件夾放到%HOME%\webapps\webroot文件夾下。

      注:技術支持聯系方式:QQ:800049425;電話:400-811-8890

4. 應用商城界面空白/帆軟通行證無法登錄

問題描述:

1)以管理員身份進入數據決策系統後,點擊管理系統>插件管理,應用商城頁面空白,如下圖所示:

24.png

2)登錄帆軟通行證時,提示:未知錯誤。如下圖所示:

2.png

3)設計器中點擊右上角登錄,提示:網絡連接失敗。如下圖所示:

5.png

原因分析:

有兩個原因:

1)原因一:服務器沒有連外網。

2)原因二:服務器可以通外網,在平台系統管理節點的「常規」 Tab 頁中關閉了連接網址管理中心按鈕,插件引擎模塊無法使用。

解決方案:

1)原因一解決方案

服務器連接外網。

2)原因二解決方案

以管理員身份進入數據決策系統,點擊「管理系統>系統管理>常規」,開啓「連接網址管理中心按鈕」,點擊保存。如下圖所示:

注1:遠程環境中若關閉連接網址管理中心按鈕,也将出現本節「問題描述」中的現象。

注2:連接網址管理中心按鈕的介紹請參見:常規 中的 2.2 節内容。

6.png

5. 插件商店有新版本

以管理員身份進入數據決策系統時,點擊「管理系統>插件管理」,插件管理界面有時會彈窗提示:插件商店有新版本,是否更新?

如下圖所示:

01.png

此時更新的是帆軟商城中插件,不會更新已安裝的插件,點擊确定按鈕即可。

6. 插件在線安裝/更新無進度

問題描述:

在數據決策系統安裝/更新插件時卡住,不顯示進度條,不顯示「安裝完成」。刷新頁面後,發現插件已經安裝/更新好了。

image.png

原因分析:

WebSocket端口被占用了,無法主動給浏覽器推送消息。

解決方案:

開放 WebSocket 端口,詳情請參見:Websocket 連接失敗

7. 插件本地安裝/更新無進度

問題描述:

從本地選擇插件安裝包,安裝插件後,無安裝進度,不顯示「插件安裝成功」。

原因分析&解決方案:

1)插件安裝包過大,安裝較緩慢。請耐心等待即可。

2)工程環境無法連接安裝包所在的位置。例如無法連接外網等。開放網絡路徑即可。

3)插件安裝目錄無權限,請給插件安裝的 cache 目錄開下 777 權限。

附件列表


主題: 原簡體文檔
  • 有幫助
  • 沒幫助
  • 只是瀏覽

文 檔回 饋

滑鼠選中內容,快速回饋問題

滑鼠選中存在疑惑的內容,即可快速回饋問題,我們將會跟進處理。

不再提示

9s后關閉

反饋已提交

網絡繁忙