反馈已提交

网络繁忙

网络检测

  • 文档创建者:Leo.Tsai
  • 历史版本:9
  • 最近更新:Carly 于 2023-09-20
  • 1. 概述

    1.1 版本

    报表服务器版本功能变更
    11.0.11
    -

    1.2 应用场景

    一般,报表工程都是部署在中间件上,依托 JDBC 连接数据库,用户通过互联网访问平台资源。

    因而在出现诸如模板响应慢等性能问题时,需要定位是不是网络问题导致的。

    1.3 功能简介

    FineReport中内置了系统检查插件,帮助提供「网络检测」功能,当遇到性能问题时,可通过该工具一键检测是否存在网络问题。

    • 基础网络检测:该工具可以检测当前的网络环境,对链路耗时进行分析,实现网络环境外部问题和内部问题的检查。

    • 网络组件检测:可以对 FineDB、业务数据库、FTP文件服务器、Redis状态服务器、OSS存储服务器等网络组件进行检查。

    单机环境和集群环境下都可以使用该工具,集群环境下可以选择任意节点进行检测。

    2. 基础网络检测

    基础网络检测,检测的是用户到报表服务器的网络环境和链路耗时。

    2.1 设置检测配置项

    在进行基础网络检测前,管理员可以对检测配置进行自定义设置。

    管理员登录数据决策系统,点击「管理系统>智能运维>网络检测>全局设置」,支持调整基础网络检测设置。如下图所示:

    设置项
    说明默认值支持配置值
    传输数据包大小基础网络检测时传递的数据包大小10M5、10、15、20、25
    传输超时时间基础网络检测时判断传输超时的时长20秒5、10、20、30、60
    传输次数基础网络检测时传输测试的次数5次3、5、10、20

    2.2 进行检测

    设置好配置项后,即可进行基础网络检测。

    管理员登录数据决策系统,点击「管理系统>智能运维>网络检测>基础网络检测」,建议先进行「网络环境检测」,再进行「链路耗时分析」。

    检测过程中需要等待一段时间,且提供了中止检测按钮,可随时取消检测。

    2.3 查看检测结果

    检测完毕后,本次检测结果显示在「基础网络检测」页面中,如下图所示:

    1)网络环境检测

    注:对于下载上传速度的检测,测出来的速度只代表用户和平台之间的下载、上传速度,而不是用户网络连接的实际带宽。

           因此和其他测速工具测出的速度可能会出现较大差距。

    检测项
    说明
    时延检测耗时极差,单位ms
    下载

    下载:检测过程下载数据量,单位Mbps

    耗时:检测过程下载耗时,单位ms

    抖动:检测过程下载耗时平均值,单位ms

    上传

    上传:检测过程上传数据量,单位Mbps

    耗时:检测过程上传耗时,单位ms

    抖动:检测过程上传耗时平均值,单位ms

    检测结果

    基于以上检测项,对网络环境进行综合评估

    包括:良好、中等、偏差

    服务器地址默认为工程IP

    2)链路耗时分析

    支持对浏览器发送请求、服务器收到请求、服务器发送响应、浏览器收到响应的链路名称、时刻、状态进行记录。

    3. 网络组件检测

    网络组件检测,可以对 FineDB、业务数据库、FTP文件服务器、Redis状态服务器、OSS存储服务器等网络组件进行检测。

    3.1 设置检测配置项

    在进行网络组件检测前,管理员可以对检测配置进行自定义设置。

    管理员登录数据决策系统,点击「管理系统>智能运维>网络检测>全局设置」,支持调整网络组件检测设置。如下图所示:

    设置项
    说明默认值支持配置值
    传输超时时间网络组件检测时判断传输超时的时长20秒5、10、20、30、60
    传输次数网络组件检测时传输测试的次数5次3、5、10、20

    3.2 添加组件

    对组件进行检测前,需要先将组件添加进来。

    管理员登录数据决策系统,点击「管理系统>智能运维>网络检测>网络组件检测」,点击「添加网络组件」,即可添加网络组件。如下图所示:

    支持添加的网格组件包括:

    组件
    说明
    FineDB

    支持检测 外接FineDB

    如果工程配置了外接FineDB,会自动添加到网络组件检测页面

    无需手动添加,也不支持删除该组件

    业务数据库

    支持手动添加当前系统存在的数据连接

    业务数据库检测时默认是查询获取到的第一张表,用户也可以自定义查询语句进行检测

    FTP支持手动添加当前系统存在的FTP文件服务器
    Redis支持手动添加当前系统存在的Redis状态服务器
    OSS支持手动添加当前系统存在的OSS存储服务器

    3.3 进行检测

    用户可对添加的网络组件进行单个检测/全部检测,如下图所示:

    3.4 查看检测结果

    检测完毕后,本次检测结果显示在「网络组件检测」页面中,如下图所示:

    各种组件的检测逻辑和返回结果如下表所示:

    组件检测逻辑
    FineDB

    1)连通性检测:

    检测组件是否正常连接

    检测浏览器与组件连接耗时

    2)组件网络检测:

    依次存入binary 1M、10M、100M并查询、删除

    记录存入时间、查询时间、删除时间

    业务数据库

    1)连通性检测:

    检测组件是否正常连接

    检测浏览器与组件连接耗时

    2)组件网络检测:

    查询一条语句,默认采用默认select获取到的第一个表,用户可修改语句

    记录浏览器发送请求、数据库收到请求、数据库发送响应、浏览器收到响应的时间、查询语句执行的时间

    FTP

    1)连通性检测:

    检测组件是否正常连接

    检测浏览器与组件连接耗时

    2)组件网络检测:

    存入一个1M、10M、100M的文件并下载、删除

    记录上传耗时、下载耗时、删除耗时

    Redis

    1)连通性检测:

    检测组件是否正常连接

    检测浏览器与组件连接耗时

    2)组件网络检测:

    存入value1M、10M、100M的string并下载、删除

    记录 上传耗时、下载耗时、删除耗时

    OSS

    1)连通性检测:

    检测组件是否正常连接

    检测浏览器与组件连接耗时

    2)组件网络检测:

    存入一张图片并读取、删除

    记录上传耗时、下载耗时、删除耗时

    4. 历史检测记录

    4.1 查看历史检测记录

    对于基础网络检测和网络组件检测的每一次记录,都可在「历史检测记录」中查看。

    在历史记录页面:

    • 可以查看每条检测记录的检测内容和检测结果。

    • 可以对每条检测记录执行复制记录、删除记录、生成报告的操作。

    • 可以多选多个检测记录批量生成报告。

    4.2 清理历史检测记录

    由于网络检测历史记录会占用内存,因此管理员需要设置好自动清理历史检测记录。

    管理员登录数据决策系统,点击「管理系统>智能运维>网络检测>全局设置」,支持配置历史检测记录清理频率。如下图所示:

    默认每隔 3 个月自动清理一次,保留近 3 个月的数据。

    注:近 3 个月是指当前日期往前 3 个月的数据,例如 2019-8-19 日手动清理,默认保留 2019-5-19 ~ 2019-8-19 日的数据。

             因此最少会保留3个月,最多实际上会有6个月。

    5. 注意事项

    问题描述:

    对MySQL数据库执行网络组件检测时,报错:

    if you are using the mysql client program,it's default max_allowed_packet variable is 16MB.To set a large value

    原因分析:

    检测操作的数据量传输可能会超出 MySQL 的限制,

    MySQL 数据库中「max_allowed_packet」值设置过小,导致数据传输量超出限制。

    解决方案:

    此时修改并将配置项 max_allowed_packet 调大即可。

    方案一:

    MySQL 安装目录下的「my.ini」文件中的[mysqld] 字段中的「max_allowed_packet = XM」修改为 500M ,重启 MySQL 即可。

    方案二:

    1)使用「set global max_allowed_packet = 524288000;」 语句将「max_allowed_packet」的值设置为 500 M。

    2)使用「show VARIABLES like '%max_allowed_packet%';」 语句查看是否修改成功。

    附件列表


    主题: 数据决策系统
    • 有帮助
    • 没帮助
    • 只是浏览
    中文(简体)

    鼠标选中内容,快速反馈问题

    鼠标选中存在疑惑的内容,即可快速反馈问题,我们将会跟进处理。

    不再提示

    10s后关闭

    联系我们
    在线支持
    获取专业技术支持,快速帮助您解决问题
    工作日9:00-12:00,13:30-17:30在线
    页面反馈
    针对当前网页的建议、问题反馈
    售前咨询
    采购需求/获取报价/预约演示
    或拨打: 400-811-8890 转1
    qr
    热线电话
    咨询/故障救援热线:400-811-8890转2
    总裁办24H投诉:17312781526
    提交页面反馈
    仅适用于当前网页的意见收集,帆软产品问题请在 问答板块提问前往服务平台 获取技术支持