目录:
1. 概述编辑
本文总结了 FineReport 与钉钉集成的常见问题及解决方案。
2. 定时调度钉钉发送的pdf文件打开方式编辑
问题描述:
安卓需要下载后第三方应用打开但是苹果的可以直接打开
原因分析:
安卓不支持的附件类 url 比如 office文档、pdf、压缩包之类的,都需要通过第三方 App 下载和打开。
3. PC 端钉钉集成环境,新前端样式下的工具栏不支持导出编辑
问题描述:
在PC端的集成环境,从钉钉侧打开报表,新前端样式下,点击报表工具栏导出,会新打开浏览器页面,页面报错:非常抱歉,您无法查看页面。Request method 'GET' not supported。在浏览器去访问平台,打开报表,可以正常导出。
原因分析:
11.0的新前端样式下,工具栏的导出,不支持在集成的环境(微信、钉钉)下进行导出。
解决方案:
更换工具栏样式为经典。
4. 定时调度推送消息到钉钉群消息异常编辑
问题描述:
定时调度推送消息到钉钉群,提示:获取不到钉钉应用,请检查网络配置。钉钉调试工具检查网络请求正常
原因分析:
推送到钉钉群需要调用群消息接口,需要钉钉后台未开启获取群会话信息权限。
解决方案:
钉钉后台开启权限即可。
5. 定时调度部分用户无法接收编辑
问题描述:
钉钉部分用户定时调度消息收不到消息。
原因分析:
钉钉中有多个企业,且多个企业中都有该用户,用户用于匹配的信息一样,但是对应的 userid 不一样。
解决方案:
方案一:手动匹配,将用户匹配到不同的报表用户。
方案二:修改用户信息成一致或删除微信/钉钉后台的用户,重新添加一样的信息。
6. 钉钉集成新建应用空白编辑
问题描述:
新添加了钉钉应用,显示添加成功了,但是下面并没有显示出来(没有数据),日志没有报错。
排查步骤:
在报表服务器物理机上访问钉钉的接口:https://oapi.dingtalk.com/microapp/list?access_token=,如果能访问到,说明网络正常。让客户自己更改了网络的配置。可以正常的提示错误。 新报错“访问IP不在白名单中”,但是客户的钉钉配置中,白名单就是明确的 IP,尝试将IP的最后一个字段修改为 * ,进行测试。
7. 钉钉推送失败,日志报错人员匹配失败编辑
原因分析:
匹配关系表没有更新导致人员匹配失败。
排查步骤:
1)确定定时调度勾选的人员信息,未使用自定义数据集,人员信息正确。
2)确认匹配关系表更新过了,手动操作同步更新钉钉通讯录,再次操作定时调度。
解决方案:
手动同步钉钉通讯录(最好设置自动更新)。
8. 钉钉扫码插件-跳转失败编辑
问题描述:
配置完相关配置,扫码登陆跳转页面提示:如需访问请联系管理员。
原因分析:
钉钉后台对时间有限制,不能相差超过一分钟,要不然传递过去的参数就不合法。
9. 同步的钉钉用户,调用添加部门接口报错编辑
问题描述:
平台用户是同步的钉钉数据集,然后调用添加部门的接口报错Manual source data can not be added under synchronous sources。
原因分析:
这个报错中文翻译就是“无法在同步源下添加手动源数据”,也就是说明无法往同步用户的部门下手动添加部门,调用接口添加也不能。
解决方案:
使用导入用户重新配置用户数据。