1. 概述编辑
1.1 版本
报表服务器版本 |
---|
10.0 |
1.2 问题描述
插件安装和管理过程中,可能会出现一些问题。
本文将提供常见插件安装/维护问题的解决方案。
2. 插件功能无法使用编辑
问题描述:
数据决策系统(服务器端)安装插件后,设计器端远程连接该工程,无法使用插件功能。
原因分析:
1)对于设计器和服务器都会用到的插件,要求服务器端和设计器端都要安装:
若服务器端安装了插件,设计器端没有安装插件,则插件不会生效,需要切换到本地进行插件安装。
若服务器端和设计器端均安装了插件,服务器端的插件下载、删除、禁用不会立即生效,需要等几分钟才会生效。
若服务器端和设计器端均安装了插件,设计器切换到本地,禁用该插件,不影响远程连接时服务器端的插件使用。
2)若设计器端和服务器端均安装了插件,但是插件版本不一致,可能导致插件功能失效
3. 插件管理界面空白编辑
问题描述:
以管理员身份进入数据决策系统后,点击管理系统>插件管理,提示:您还没有插件商店的资源,是否下载?
点击确定按钮后,「插件管理」界面依然空白。如下图所示:
原因分析&解决方案:
1)设计器和服务器 JAR 包不一致,保持一致之后即可恢复正常。
2)用户在本地或远程工作目录中,勾选了使用新插件管理器按钮。
注:「使用新插件管理器」按钮具体介绍可参考 选项 中的 3.4 节内容。
外网用户:外网用户在插件管理页面的弹窗上,点击确定按钮后,清理浏览器缓存,重新进入数据决策系统即可。
内网用户:请联系技术支持获取 upm 文件夹,将 upm 文件夹放到%HOME%\webapps\webroot文件夹下。
注:技术支持联系方式:QQ:800049425;电话:400-811-8890
4. 应用商城界面空白/帆软通行证无法登录编辑
问题描述:
1)以管理员身份进入数据决策系统后,点击管理系统>插件管理,应用商城页面空白,如下图所示:
2)登录帆软通行证时,提示:未知错误。如下图所示:
3)设计器中点击右上角登录,提示:网络连接失败。如下图所示:
原因分析:
有两个原因:
1)原因一:服务器没有连外网。
2)原因二:服务器可以通外网,在平台系统管理节点的「常规」 Tab 页中关闭了连接网址管理中心按钮,插件引擎模块无法使用。
解决方案:
1)原因一解决方案
服务器连接外网。
2)原因二解决方案
以管理员身份进入数据决策系统,点击「管理系统>系统管理>常规」,开启「连接网址管理中心按钮」,点击保存。如下图所示:
注1:远程环境中若关闭连接网址管理中心按钮,也将出现本节「问题描述」中的现象。
注2:连接网址管理中心按钮的介绍请参见:常规 中的 2.2 节内容。
5. 插件商店有新版本编辑
以管理员身份进入数据决策系统时,点击「管理系统>插件管理」,插件管理界面有时会弹窗提示:插件商店有新版本,是否更新?
如下图所示:
此时更新的是帆软商城中插件,不会更新已安装的插件,点击确定按钮即可。
6. 插件在线安装/更新无进度编辑
问题描述:
在数据决策系统安装/更新插件时卡住,不显示进度条,不显示「安装完成」。刷新页面后,发现插件已经安装/更新好了。
原因分析:
WebSocket端口被占用了,无法主动给浏览器推送消息。
解决方案:
开放 WebSocket 端口,详情请参见:Websocket 连接失败 。
7. 插件本地安装/更新无进度编辑
问题描述:
从本地选择插件安装包,安装插件后,无安装进度,不显示「插件安装成功」。
原因分析&解决方案:
1)插件安装包过大,安装较缓慢。请耐心等待即可。
2)工程环境无法连接安装包所在的位置。例如无法连接外网等。开放网络路径即可。
3)插件安装目录无权限,请给插件安装的 cache 目录开下 777 权限。