Deployment Environment Exception

  • Last update:  2023-04-04
  • Overview

    When you deploy FineBI on servers, the deployment may fail for different reasons. For details of how to check and fix the problem, see Introduction to Server Deployment Page.

    One of the reasons is Deployment environment exception. There are different causes behind this problem, varying by circumstances. This article will introduce different error messages and how to solve those errors.

    Missing tools.jar

    Notes:

    1. Tomcat is used as an example here. For other containers, the tools.jar file needs to be copied to the lib folder of the corresponding container.

    2. The tools.jar file here is the one under %{JAVA}_HOME%/jdk/lib on the server, not the one on the local device.

    Solution:

    Copy tools.jar under %JAVA_HOME%/jdk/lib to the server which FineBI is deployed on. In this case, the directory is %TOMCAT_HOME%/lib and %TOMCAT_HOME%/webapps/{project name}/WEB_INF/lib.

    1661325657hJvU.png

    tools.jar Mismatching with the System

    For example, the error message is: Caused by: java.lang.UnsatisfiedLinkError: sun.tools.attach.LinuxVirtualMachine.isLinuxThreads()Z.

    Cause:

    The toors.jar file is placed in the wrong system.

    Solution:

    Based on the prompt, move the tools.jar file to the corresponding system.

    Missing attach.dll

    There is an error message in the log: Caused by: com.sun.tools.attach.AttachNotSupportedException: no providers installed.

    Cause:

    When you install JDK in the Windows system, an independent JRE will be installed at the same time. There is no attach.dll file under the independently installed JRE, but this file is needed for FineBI startup.

    Solution:

    In this case, you need to copy attach.dll to %JAVA_HOME%/jdk/jre/bin to %JRE_HOME%/bin.

    Unable to Write to /tmp

    There is an error message in the log: Caused by: com.sun.tools.attach.AttachNotSupportedException: Unable to open socket file: target process not responding or HotSpot VM not loaded.

    You cannot add files to the /tmp directory. The possible causes and solutions for this problem are:

    1. Ordinary users do not have the permission. To address the issue, the admin needs to use the chmod command to grant permission to the /tmp folder. The specific command for this action is chmod -R 1777 /tmp. The number 1 means this is a sticky bit, only the creator and root can delete the directory.

    2. The disk space where /tmp is located is full. Clean up the disk.

    Unable to Write to Java.io.tmp

    When you deploy FineBI in different containers, the location of java.io.tmp may vary, so you may be unable to write to Java.io.tmp. Possible reasons and solutions for this problem:

    1. You do not have the permission. Ask the admin for the permission.

    2. The disk space where java.io.tmp is located is full. Clean up the disk.

    Incompatible GLIBC Version

    Solution:

    Upgrade gcc. Enter ldd FineAssist_x86_64.so in the command line. If you see the image shown below, the upgrade is successful.

    1645429220719435.png

    Unknown FinePrivacy Exception

    Solution:

    You can send an email with the startup log to international@fanruan.com or click  at https://intl.finebi.com/ for technical help.

    Missing fontconfig/Dec-Basic_Non_Existent

    Cause:

    The OpenJDK in the server deployment package does not have font packages due to the lack of copyright. If Linux lacks font packages, an error message will occur indicating that fontconfig or Dec-Basic_Non_Existent is missing.

    Therefore, you need to check fontconfig before deploying.

    Detection method:

    To check whether fontconfig has been installed on the server, you can execute the fc-list command on the server or check whether the fc-list file exists in the /usr/bin directory.

    Installation method:

    For Linux systems, you can typically use the command yum install fontconfig, and then restart the Linux system to complete the installation.

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