FineBI无法启动排查步骤

  • Last update:  2022-11-07
  • 1. 概述

    1.1 问题描述

    有时由于各种复杂的情况导致用户在安装后无法成功启动 BI 服务器。

    1.2 解决思路

    总的概括有如下原因导致无法启动成功,如下所示:

    原因
    没有使用管理员权限启动BI
    启用外连接数据库在启动BI时没有启动相应的数据库,或相应的数据库服务已关闭,需要重启
    BI 重复启动两个线程
    48888 端口占用或者 37799 端口占用
    webapps 目录下有多个工程或者没有工程
    db.lck 文件报错,Windows 使用其他工具打开 FineDB 数据库并且未关闭
    Linux 文件权限导致无法启动
    磁盘剩余空间不足

    2. 排查和处理步骤

    下文详细介绍如何进行排查和处理。

    2.1 使用管理员权限启动BI

    确认是否使用管理员权限启动BI,若没有,则需要停止进程,重新使用管理员权限启动。Windows 系统如下图所示:

    1591010570672175.png

    2.2 检查 BI 是否重复启动两个线程

    1)输入命令 ps -ef|grep java ,查看当前路径下的BI 启动了多少线程,如下图所示:

    1588220199305329.png

    2)若有多个线程则全部结束,输入 kill -9 进程号,如下图所示:

    1588224754844662.png

    2.3 检查端口占用情况

    注:端口号只能被一个进程占用。

    1)使用lsof -i:端口号 命令检查当前端口是否被占用,若如下图所示,则表示端口未被占用:

    1588219468834145.png

    注:若报错-bash: lsof-i:xx: command not found,则需要输入命令 yum install lsof ,才能使用 lsof 命令。

    若如下图所示,则表示进程 ID 为 8152 的 java 应用占用 80 端口:

    1588224939231636.png

    2)端口号只能被一个进程占用,若当前端口号已经被占用,则需要将 BI 服务器的端口号调整为未被占用的端口号。详情参见:Tomcat 端口配置如何修改FineBI端口号 。

    2.4 检查 webapps 目录下是否有多个工程/没有工程

    进入 BI 安装目录,查看 %FineBI%\webapps 目录下是否有多个webroot文件,若没有,需要将安装的 webroot 文件放置在 webapps 下,如下图所示:

    1588225747220501.png

    注:备份文件都以压缩文件夹形式存放,或者把备份文件拷贝到非工程所在目录,确保 Web 容器里只有一个名为webroot的工程。

    2.5 db.lck 文件报错

    Windows 使用其他工具打开 FineDB 数据库并且未关闭,检查是否有其他软件连接 FineDB 内置数据库,如果有,需要关闭工程并重启 BI 。

    2.6 检查 Linux 文件权限

    若工程无法启动,在 %FineBI%/logs下打开fanruan.log,日志报错 permission denied ,需要输入命令 chmod -R 777 文件根目录权限,然后重启即可,如下图所示:

    1588235032760279.png

    2.7 磁盘剩余空间不足

    若工程无法启动,在%FineBI%/logs下打开fanruan.log日志报错:磁盘剩余空间不足。

    使用 df -h 命令检查当前各分区磁盘占用大小,如下图所示:

    1588235309273097.png

    使用命令 du -sh * 查看当前目录下每个文件夹大小,如下图所示:

    1590546336382359.png

    将不需要的文件清理即可。

    附件列表


    主题: 安装与升级
    • Helpful
    • Not helpful
    • Only read

    滑鼠選中內容,快速回饋問題

    滑鼠選中存在疑惑的內容,即可快速回饋問題,我們將會跟進處理。

    不再提示

    10s後關閉

    Get
    Help
    Online Support
    Professional technical support is provided to quickly help you solve problems.
    Online support is available from 9:00-12:00 and 13:30-17:30 on weekdays.
    Page Feedback
    You can provide suggestions and feedback for the current web page.
    Pre-Sales Consultation
    Business Consultation
    Business: international@fanruan.com
    Support: support@fanruan.com
    Page Feedback
    *Problem Type
    Cannot be empty
    Problem Description
    0/1000
    Cannot be empty

    Submitted successfully

    Network busy