FAQs During External Database Configuration

  • Last update:  2023-07-13
  • Overview

    This document lists the possible errors and solutions that may occur when you configure an external database.

    Failed to Open the Platform After Database Migration and JAR Upgrade

    Problem:

    Users cannot open the platform after configuring an external database and upgrading JAR. In this case, the error message "TASKNAMECALCCULATEATEONCE and USERALIAS identifiers are invalid" is displayed.

    Cause:

    Migration users do not have the alter permissions, generating no fields.

    Solution:

    Grant the alter permission to migration users.

    Failed to Log In as the root User

    Problem:

    An error message is displayed when configuring an external database, indicating that login as the root user failed (ClientConnectionId:e484a26e-8f2b-4e28-b9e4-32798ec032b7) and external data cannot be connected.

    Cause:

    The external database of FineBI is incorrectly configured.

    Solution:

    Delete the file with the db.properties extension in FineBI/webapps/webroot/WEB-INF/config, and reconfigure the external database of FineBI.

    Failed to Log In to the Platform After Migrating Data to the Database and Rolling Back the JAR Package

    Problem:

    If the report project migrated to an external database is re-migrated to another external database after JAR upgrade, platform login fails after JAR rollback. In this case, a database connection exception message is displayed, as shown in the following figure.


     1回退JAR包平台登录失败.png 

    Cause:

    The file with the db.properties extension that stores external database configuration does not change as JAR is rolled back.

    Solution:

    Check the file with the db.properties extension in the %FineBI%/webapps/webroot/WEB-INF/config path and manually modify the related configuration.

    For example, if a project migrated to the MySQL8 database is re-migrated to the MySQL5.7.28 database after JAR upgrade, startup fails after rollback. In this case, a message indicating database connection failure is displayed on the frontend. To solve this problem, you need to change the value of dialect from MySQL8Dialect to MySQL5Dialect in the file with the db.properties extension.

    Before modification:

    hibernate.dialect=com.fr.third.org.hibernate.dialect.MySQL8Dialect

    After modification:

    hibernate.dialect=com.fr.third.org.hibernate.dialect.MySQL5Dialect

    Failed to Migrate Data from FineDB in a Cluster Environment

    Problem:

    A page shown in the following figure is displayed when you attempt to migrate data from the FineDB database in a cluster environment using the migration function on the platform. If you click the login button in this case, the page will keep refreshing.

     

     2集群环境下FineDB迁移失败.png

    Cause:

    Migration cannot be performed in a cluster environment.

    Solution:

    Enable only one node in the cluster for migration.

    After data is migrated successfully, copy the file with the db.properties extension to other nodes to which no data is migrated, disable all nodes in the cluster, and restart the cluster.

    Failed to Migrate Data from FineDB in the CAS Single-Node Environment

    Problem:

    (1) Data import keeps running during data migration from an external database.

    (2) An error message indicating that the database is locked is displayed.

    (3) The CAS single-node operation is implemented for the project. CAS-related logs are recorded in the error message.

    Cause:

    During migration, other users access the platform, causing lock of some tables and migration failure.

    Solution:

    First remove the single CAS node to ensure that no users access the platform.

    After data is migrated successfully from the external database, add the single CAS node.

    Failed to Migrate Data Due to Task Schedule

    Problem:

    The following error message is displayed, indicating that data failed to be migrated from an external database:

    Null value was assigned to a property [class com.fr.scheduler.quartz.entity.QuartzFiredTriggers.isNonconcurrent] of primitive type setter of com.fr.scheduler.quartz.entity.QuartzFiredTriggers.isNonconcurrent

    Cause:

    During task schedule, the QRTZ_FIRED_TRIGGERS table in FineDB will temporarily record the task schedule data. The data will be automatically deleted after task schedule is successfully executed.

    When task schedule is halfway executed, data is generated. If you migrate data from the external database in this case, task schedule cannot be suspended, resulting in migration failure.

    Solution:

    According to the error message, clear the related tables, for example, the QRTZ_FIRED_TRIGGERS table.

    Failed to Execute Clauses by MySQL

    Problem:

    Data failed to be imported during MySQL database configuration. In this case, the error message "could not execute statement" is displayed on the frontend.

    The error message in %FineBI%/logs/fanruan.log is "Table 'finedb.QRTZ_PAUSED_TRIGGER_GRPS' doesn't exist".

    Troubleshooting (1):

    Check whether the MySQL database uses correct encoding formats. The character set should be in UTF-8 format (in utf8_binorder).

    If the MySQL database uses incorrect encoding formats (for example, utf8mb4), modify the database encoding format to UTF-8.

    Troubleshooting (2):

    Check whether the MySQL database uses the correct data engine. If not, change it to InnoDB as follows:

    (1) Add default-storage-engine=INNODB under [mysqld] in the my.cnf configuration file of the MySQL database and save the settings.

    (2) Run the mysqladmin -u root -p shutdown or service mysqld restart command to restart the MySQL server.

    (3) Log in to the MySQL database and enter the show engines command under the mysql> prompt. If InnoDB | DEFAULT is displayed, InnoDB is set as the default engine successfully.

    Failed to Execute Batch by MySQL

    Problem:

    The following error log is recorded when you configure MySQL (an external database):

    16:59:48 Thread-45 ERROR [standard] could not execute batch
    com.fr.third.org.hibernate.exception.GenericJDBCException: could not execute batch

    ......Caused by: java.sql.SQLException:Incorrect string value: 'xE6xA8xA1xE6x9DxBF...' for column 'id' at row 1

    Cause:

    Verify that the required permission is assigned.

    Incorrect string value: 'xE6xA8xA1xE6x9DxBF...' for column 'id' at row 1

    Verify that the database encoding causes the fault.

    Solution:

    Check the clause used by customers to create the FineDB database.

    create database finedb

    Check whether any constraint is added. If not, change the clause to create database finedb DEFAULT CHARSET utf8 COLLATE utf8_bin.

    Verify that import is successful.

    Error Message "migrate table com.fr.config.entity.Entity failed" Displayed During MySQL Database Configuration

    Problem:

    The error message "java.lang.Exception: migrate table com.fr.config.entity.Entity failed" is displayed when you import data during MySQL database configuration.

     

    3 MySQL导入数据失败.png

    Solution:

    Modify the my.ini file of MySQL, change the value of character-set-server to utf8, as shown in the following figure.

     

    4 修改字符集.png

    Error Message "The table 'fine_conf_entity' is full" Displayed During MySQL Database Configuration

    Problem:

    The error message "java.lang.Exception: migrate table com.fr.config.entity.Entity failed" is displayed when you import data during MySQL database configuration.

    The error message "The table 'fine_conf_entity' is full" is recorded in %FineBI%/logs/fanruan.log, as shown in the following figure.


    7.png

    Solution:

    Add tmp_table_size = 256M and max_heap_table_size = 256M under [mysqld] in the /etc/my.cnf configuration file of MySQL to change 16M (default system size) to 256M, and restart MySQL.

    Database Connection Failed

    Problem:

    The error message "wait millis 10000, active0, maxActive 50" (indicating database connection failure) is displayed when you configure databases containing modes such as SQL Server and Oracle, as shown in the following figure.


    5 数据库连接失败.png

    Troubleshooting:

    (1) Verify that the name, host address, port number, username, and password of the database are correct.

    (2) Check whether this server and port are open to other computers (that is, whether database connection can be tested elsewhere).

    (3) Change the mode to one matching the username of the database, as shown in the following figure.


    6 更改模式.png

    Failed to Execute Clauses by Oracle

    Problem:

    The error message "oracle could not execute statement" or "Oracle could not execute statement" is displayed when you configure Oracle (an external database).

    Cause:

    The database uses an incorrect mode.

    Solution:

    Check whether the mode is set to thin. If so, change it to the username.

    Error Message "migrate table com.fr.config.entity.Entity failed" Displayed During Oracle Database Configuration

    Problem:

    The error message "java.lang.Exception: migrate table com.fr.config.entity.Entity failed" is displayed when you configure Oracle (an external database).

    The error log "Caused by: java.sql.BatchUpdateException: ORA-01654: Failed to expand index BI_REPORT_RO.SYS_C0011297 by 128 (in the BI_REPORT_RO table space)" is recorded.

    Data import failed after the data table is created successfully.

    Cause:

    The table space of the database is insufficient.

    Solution:

    The default size (a maximum of 32 GB by default) of the table space data file is related to that of DATA BLOCKS.

    You can run the alter tablespace USERS add datafile 'D:appAdministratororadataorclUSERS02.DBF' size 10240M command to add the table space data file.

    Failed to Proceed from Oracle19c Data Migration

    Problem:

    After data is connected successfully from the Oracle19c database, you failed to proceed from connection during external database configuration.

    Cause:

    The PUT and DELETE requests are forbidden in the user environment, causing some requests on the platform to be abnormal.

    Solution:

    You can convert PUT and DELETE requests to POST requests.


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