Common Problems and Solutions of Designer Startup

  • Last update:September 29, 2025
  • Overview

    In some cases, the designer may fail to start, but you have no clue how to identify the cause or resolve the problem. To help with this, this document summarizes common causes of startup-related bugs and their solutions, and provides a standard troubleshooting flowchart. You can refer to the document for solutions to the specific problems as needed.

    Designer Crash

    Common reasons of designer crashes include:

    1. Product-related causes:

    • Insufficient memory

    • Issues with the finedb folder or files within

    • For example, in Windows, frequent use of the Plugin Management function implemented with JavaFX may cause the designer to crash unexpectedly. (The issue is caused by a known JavaFX bug, which can be resolved by upgrading JDK to a version that includes the fix or directly upgrading to the latest version of FineReport.)

    2. System-related causes:

    • Issues with the system permission

    3. Conflicts with other software:

    • DLLs from input method editors (IMEs)

    • DLLs from other systems or third-party software

    • Antivirus software

    The following figure shows a common troubleshooting workflow for designer crashes.

    The designer starts, loads the UI, and then crashes. The error is recorded in the fanruan.log file in the logs folder.

    Problem: The designer starts, loads the UI, and then crashes. You can open the fanruan.log file in the logs folder and find an error message like this: 

    "2019-03-12T15:06:50.153+0800 WARN Could not find matching type descriptor for requested Java class [java.util.List]; using fallback
    2019-03-12T15:06:50.159+0800 WARN Could not find matching type descriptor for requested Java class [com.fr.swift.source.alloter.AllotRule]; using fallback".

    Cause: The global style in the configuration file is problematic.

    Solution: You can check the finedb folder and replace it with a finedb folder from a project that starts normally.

    The designer starts, loads the UI, and then crashes. No error is recorded in the fanruan.log file.

    Cause: There is an issue with the current operating system.

    Solution: You can reinstall the operating system.

    The designer crashes at startup. The error.log file in the bin folder records only the crash without additional error information.

    Cause: An exception occurred during designer installation.

    Solution: You can reinstall the designer and upgrade the JAR packages on the server where the designer is installed for the designer to function normally.

    The designer keeps crashing at startup. Logs indicate that it referenced a project on a disk other than the installation disk.

    Cause: There might be an issue with the working directory.

    Solution: Locate the hidden FineReportEnv.xml file on the C drive, save the activation code, then delete the file, and restart the designer.

    The designer crashes, despite the memory pool size being set to 4 GB.

    Cause: The designer is not correctly installed.

    Solution: You can confirm if the operating system matches the installation requirements of the designer. If not, you can reinstall the designer.

    Designer Startup Failure

    The designer is freshly installed but fails to start. An error is recorded in the fanruan.log file.

    Problem: The designer is freshly installed but fails to start. You can open the fanruan.log file in the logs folder and find an error message like this: 

    "17:54:56 Thread-16 ERROR [standard] C:\FineReport_11.0\webapps\webroot\WEB-INF\assist\phantomjs\lib\vancharts-all.js (Access denied.)

    java.io.FileNotFoundException: C:\FineReport_11.0\webapps\webroot\WEB-INF\assist\phantomjs\lib\vancharts-all.js (Access denied.)".

    Cause: The designer was installed by a non-admin user on the system drive (C:), and the user lacks read/write permissions on the files in the startup process.

    Solution:

    1. You can install the designer on a non-system drive (a drive other than C:).

    2. If the designer is installed on the system drive, you need to grant full read/write permissions on the installation folder to all users.

    3. You can install and start the designer as the admin.

    The designer fails to start after installation.

    Cause:

    1. Cache/memory issues

    2. You have connected to a remote server configured with an external database, whose root username and password are invalid.

    3. JAR packages are placed in the wrong folder; multiple JAR packages are missing; or the versions of JAR packages are mismatched.

    Solution:

    1. You can end the processes desginer.exe and OpenJDK Platform binary in Task Manager, delete the system cache on the C drive, and restart the designer. Alternatively, you can clear the cache and start the designer with the maximum memory pool. For details, see Modifying Memory Settings.

    2. You can log in to the external database again and restart the server.

    3. You can check the environment to see if JAR packages are placed in the correct folder, complete, and matched in version. If not, you can replace or add JAR packages as needed.

    designer.exe does not respond to clicks.

    Problem: designer.exe does not respond to clicks; no designer process exists in Task Manager; and error.log is generated in the bin folder without any content. However, you can start the designer via the BAT script.

    Cause: Encryption software exists in the operating system.

    Solution: You can add the designer to the whitelist of the encryption software.

    The designer fails to start; starting via the BAT script crashes partway; and the error is recorded in error.log.

    Problem: The designer fails to start; starting via the BAT script crashes partway; and you can find an error message like this in error.log

    "SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".

    SLF4J: Defaulting to no-operation (NOP) logger implementation

    SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details."

    Solution:

    1. You can check if the issue is caused by antivirus software.

    2. You can find the designer process in Task Manager, end it, and restart the designer.

    The designer fails to start after the JAR packages are replaced.

    Solution: You can reinstall the designer.

    After you boot the computer and start the designer for the first time, the designer remains stuck on the splash screen for a long time, and then throws the error "An unexpected error occurred." The designer can be restarted normally after you close it.

    Solution: You can back up the project and reinstall the designer.

    The designer gets stuck on the startup animation.

    Solution: You can clear the cache and restart the designer.

    The designer fails to start, and the error is related to JDK.

    Problem: The designer fails to start, and throws the error: "OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=128m; support was removed in 8.0".

    Solution: You can reinstall the designer.

    The designer fails to start, and the error is logged.

    Problem: The designer fails to start, and an error message like this is logged: 

    "please check the database service to ensure that it is available 

    jdbc:hsqldb:file://X:\FineReport_XX\webapps\webroot\WEB-INF/embed/finedb/db:hsqldb.tx=mvcc".

    Cause: There is an issue with the finedb folder or files within.

    Solution: You can delete the db.lck file in the finedb folder and the cache files on the C drive, and restart the designer.

    The designer fails to start, and throws the error: "A process was found to conflict with the designer port. Please end the process or change the designer port".

    Solution:

    1. Run the command netstat -ano | findstr "port number" in Terminal to find the process occupying the port of the designer.

    2. After finding the process, run the command tasklist |findstr "PID" with the process PID to search for the corresponding process name. 3. Run the command taskkill /f /t /im "process name or PID" with the process name or PID to kill the process. For example, taskkill /f /t /im "java.exe" or taskkill /f /t /im "16516".

    iconNote:

    In Windows, after finding the process PID or name, you can also end the process directly in Task Manager.

    The designer of V11.0 fails to start and throws the error: "Exception in thread' main” java. lang. NoClassDefF oundError: com/fr/base/theme/ThemedTemplate".

    Cause: There is a problem with the JAR packages.

    Solution: You can replace the JAR packages with the correct ones.

    The designer throws an error at startup.

    Problem: The designer throws the error at startup: "please check the database service to ensure that it is available ".

    Cause: The built-in FineDB database can not be accessed, or it is being accessed by multiple projects simultaneously, which causes a conflict.

    Solution:

    1. You can delete all the cache files in C:\Users\Username to clear the local cache.

    2. You can delete the db.lck file in \webapps\webroot\WEB-INF\embed\finedb.

    3. If you attempt to open the finedb folder in \webapps\webroot\WEB-INF\embed as a non-admin user, the admin permission will be required. In this case, you can start the designer as the admin.

    4. If both the designer and Tomcat are installed locally, they may access the FineDB database at the same time, which can cause a conflict. The most direct solution to the issue is deleting the cache files. Alternatively, you can configure the cache path in the FineReportEnv.xml file in the FineReportXXX folder to avoid conflicts between the designer and Tomcat.

    5. If the db.properties file exists — whether because you previously configured an external database and later reverted to the internal database, or for other unknown reasons—you can simply delete the file in /webapps/webroot/WEB-INF/config.

    The designer stays on the loading screen after startup.

    Problem: The designer stays on the loading animation screen for a long time without entering the main interface.

    Cause: An OutOfMemoryError exception in Java occurs due to an insufficient memory pool for the designer. Solution: You can open the designer.vmoptions file in %FR_HOME%\bin with a text editor and increase the value of -Xmx. For details about how to modify the memory settings for the designer, see Modifying Memory Settings.

    The FineReportEnv.xml file is corrupted.

    Problem: The designer fails to start, and throws the error: "Sorry! An unexpected error occurred in the designer." -1 is displayed in Problem details.

    3.14-1.png

    Solution: The FineReportEnv.xml file in the FineReportXXX folder on the system drive is corrupted. You can resolve the issue by simply deleting the file, as shown in the following figure.

    3.14-2.jpg

    The localized designer fails to start after installation.

    Problem: The designer of the Linux version is installed on the NeoKylin ARM system with a Linux kernel. The designer throws the errors at startup: "OpenJDK 64-Bit Server VM warning ignoring option MaxPermSize=128msupport was removed in 8.0" and "Failed to load /etc/os-release".

    Solution:

    1. You can ignore the first error, as it does not affect startup.

    2. The second error is related to the operating system environment. You can check whether the /etc/os-release file exists in the Linux environment.

    Designer Restart Issue

    The designer fails to save templates, and crashes with an immediate restart in some cases.

    Problem: The designer fails to save templates, and crashes with an immediate restart in some cases. The server throws the error: 

    "Exception caught during execution of add command".

    Cause: Memory is insufficient.

    Solution: You can free up disk space.

    After you click Restart Now following a plugin update, the designer keeps calling restart.exe and fails to start.

    Problem: After updating the designer plugins, you click Restart Later instead of Restart Now. When you then switch the language, Restart Now is displayed. At this point, the designer crashes and repeatedly calls retart.exe, but still fails to start.

    Solution: If the designer is stuck in an infinite restart loop, you can delete the delete.properties and restart.lock files located in the same directory as webroot.

    iconNote: 

    You need to end the restart process before deleting these files.

    Method One: You can restart the computer.

    Method Two: You can rename the restart.exe in the bin folder, and then end the restart process in Task Manager.

    Exception After Designer Startup

    The JVM could not be started.

    Problem: When you start the designer, a dialog box pops up, displaying the error message: "The JVM could not be started. The maximum heap size (-Xmx) might be too large or an anti-virus or firewall tool could block the execution", and the designer fails to start.

    Solution: You can open the designer.vmoptions file in %FR_HOME%\bin, reduce the value of -Xmx, and restart the designer for the modification to take effect, as shown in the following figure.

    5.1.jpg

    The layout of the designer is disrupted.

    Problem: When you connect to a remote server to design reports, the designer may freeze. In this case, you need to restart and log in to the designer again, but only to find that the interface layout is disrupted.

    Solution: You can press Ctrl and N to create a report, switch the working directory from the remote server to the local directory, and restart the designer to resolve the issue.

    The FineDB database is corrupted.

    Problem: The designer throws the error at startup: "Configuration database error. Reset? A backup will be generated in the embed folder and then reset.", as shown in the following figure.

    iconNote:

    If you reset the corrupted FineDB database, the reset database will contain no data. Exercise caution with the resetting operation.

    5.3.png

    Cause:

    1. FineReport is installed on the C drive, which requires elevated permissions. The problem may occur due to insufficient user permissions.

    2. You open the designer as a non-admin user of the operating system, without read/write permissions on the folders of FineReport.

    Solution:

    1. You can uninstall FineReport and install it on the D drive.

    2. You can open the designer as the admin of the operating system, or the admin can assign the read/write permission on the folders to the non-admin user.

    The FineDB database is occupied by lingering designer processes.

    Problem: When you start the designer, a dialog box pops up, displaying the error message: "The designer process is not closed properly last time. Do you want to end the process and perform restart?", as shown in the following figure.

    5.4.png

    Solution:

    1. Click End Session. The displayed session is terminated, and the designer is restarted.

    2. Click Cancel or the close icon. The designer restart is cancelled, and the displayed session is terminated in the backend.

    The designer port is occupied by another process.

    Problem: When you start the designer, a dialog box pops up, displaying the error message: "A process was found to conflict with the designer port. Please end the process or change the designer port". This indicates that the designer port is occupied by another process, as shown in the following figure.

    5.5-1.png

    Solution: You can click Change Port to open the Change Port window, and input the new port number in the text box.

    5.5-2.png

    iconNote: 

    1. The default port of the built-in server is 8075, which is used for template preview in a browser after you click a preview mode in the designer. 51462 is the default port of the designer, reserved to prevent multiple instances from running. Therefore, when changing the port number, you should not use the two port numbers to prevent conflicts.

    2. Valid port numbers range from 1024 to 65535.

    Unknown startup issues

    Problem: When the designer encounters an unknown error during startup, a dialog box pops up, displaying the error message: "Sorry! An unexpected error occurred in the designer.".

    5.6.png

    Solution:

    1. You can click Restart to restart the designer.

    2. You can click OK to close the dialog box and the designer at the same time, end the designer process in Task Manager or in Terminal, and restart the designer. Alternatively, you can reinstall and start the designer.

    3. You delete the FineReportXXX folder under C:\Users\Username after backup, and restart the designer.

    The designer UI is broken and incomplete.

    Problem: The issue may be caused by a bug in JDK 1.8.

    Solution: You can install the designer with the built-in JDK 1.7.

    The designer UI trails the cursor to leave ghost images.

    Problem: After you open the designer, the UI trails the cursor to leave multiple ghost images, making normal operation impossible. Restarting or reinstalling FineReport does not resolve the issue.

    Solution: The issue is caused by the graphics driver. To resolve it, you can disable the Java3D API by adding the parameter -Dsun.java2d.d3d=false in the designer.vmoptions file.

    Designer Ghosting

    Problem: After you switch to a new computer with a resolution of 2560 × 1600, the designer UI appears misaligned with ghosting issues.

    Solution: You can add the parameter -Dsun.java2d.d3d=false in the designer.vmoptions file, and restart the designer.

    The designer starts with a white screen.

    Problem: The designer of any version opens to a white screen, even after reinstallation.

    5.11.jpg

    Solution: You can add the parameter -Dsun.java2d.d3d=false in the designer.vmoptions file, and restart the designer.

    You cannot log in to the designer with Passport or download plugins. The designer cannot perform the auto-update.

    Problem:

    1. When you use a network proxy, the designer can start normally, but you cannot log in to the designer or the decision-making platform with FanRuan Passport.

    2. When you use a network proxy, the designer cannot perform the auto-update or download plugins.

    Cause:

    The designer of versions earlier than 11.0.8 does not support network proxies.

    Solution:

    For details, see FineReport Extranet Address. 

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    Theme: Designer Installation and Upgrade
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