反馈已提交

网络繁忙

微信集成后扫码控件无法使用

  • 文档创建者:April陶
  • 历史版本:7
  • 最近更新:TW 于 2023-07-14
  • 1. 概述

    1.1 版本

    报表服务器版本微信管理插件版本
    钉钉管理插件版本
    11.0V11.0V11.0

    1.2 问题描述

    微信集成环境中,点击文件控件无反应,点击文本控件扫码,有无法扫码的弹窗提示「当前浏览器无法扫描」,但 PC 端和 App 内正常。报错如下图所示:

    1612149930845970.png

    1.3 原因分析

    微信集成环境下,要求实现单点登录,域名必须经过校验。本文讲述如何校验域名。

    2. 解决方案

    • 确认是否配置单点,确认是否做了域名校验,且txt文件存放路径是否正确。

    • 单点登录和域名校验后的步骤,可以参考帮助文档:微信管理插件

    2.1 进入微信管理后台

    进入微信管理后台检查,是否做了域名校验。入口如下图所示:

    1588070435370040.png

    2.2 申请域名校验

    1)若未做域名校验,点击设置「申请域名校验」即可。如下图所示:

    1598840464816796.png

    2)填入域名进行校验。如下图所示:

    1612150957679093.png

    3)下载校验文件。点击下载文件,如下图所示:

    1612150893947194.png

    4)文件放在部署工程的根目录下。以 Tomcat 工程为例,是在 %Tomcat%/webapps/ROOT路径下,如下图所示:

    注:若修改了服务器根目录的,就要做对应调整。

    1612151067480523.png

    5)确保校验文件域名下访问正确,格式类似于:http://secure.finedevelop.com:63776/WW_verify_ygTgbZrsftIC6fmA.txt

    确保可以访问再进行下一步。如下图所示:

    1598840560993250.png

    6)勾选「已上传域名目录校验文件」,点击「确定」。如下图所示:

    1612151958561702.png

    2.3 校验成功

    校验成功,如下图所示:

    1612152146658086.png

    1598840599825980.png

    附件列表


    主题: 移动端应用
    • 有帮助
    • 没帮助
    • 只是浏览
    中文(简体)

    鼠标选中内容,快速反馈问题

    鼠标选中存在疑惑的内容,即可快速反馈问题,我们将会跟进处理。

    不再提示

    10s后关闭



    AI

    联系我们
    在线支持
    获取专业技术支持,快速帮助您解决问题
    工作日9:00-12:00,13:30-17:30在线
    页面反馈
    针对当前网页的建议、问题反馈
    售前咨询
    采购需求/获取报价/预约演示
    或拨打: 400-811-8890 转1
    qr
    热线电话
    咨询/故障救援热线:400-811-8890转2
    总裁办24H投诉:17312781526
    提交页面反馈
    仅适用于当前网页的意见收集,帆软产品问题请在 问答板块提问前往服务平台 获取技术支持