反馈已提交

网络繁忙

钉钉集成常见问题

  • 文档创建者:帆软应用复用-Cat
  • 历史版本:17
  • 最近更新:Carly 于 2024-01-02
  • 1. 概述

    本文总结了 FineReport 与钉钉集成的常见问题及解决方案。

    微信钉钉推送/单点/同步失败解决方案可参考:微信钉钉推送/单点/同步失败日志定位

    2. 钉钉集成

    2.1 钉钉集成新建应用空白

    问题描述:

    新添加了钉钉应用,显示添加成功了,但是下面并没有显示出来(没有数据),日志没有报错。

    排查步骤:

    在报表服务器物理机上访问钉钉的接口:https://oapi.dingtalk.com/microapp/list?access_token=,如果能访问到,说明网络正常。让客户自己更改了网络的配置。可以正常的提示错误。 新报错“访问IP不在白名单中”,但是客户的钉钉配置中,白名单就是明确的 IP,尝试将IP的最后一个字段修改为 * ,进行测试。

    2.2 同步的钉钉用户,调用添加部门接口报错

    问题描述:

    平台用户是同步的钉钉数据集,然后调用添加部门的接口报错Manual source data can not be added under synchronous sources。

    原因分析:

    这个报错中文翻译就是“无法在同步源下添加手动源数据”,也就是说明无法往同步用户的部门下手动添加部门,调用接口添加也不能。

    解决方案:

    使用导入用户重新配置用户数据。

    3. 推送钉钉消息

    3.1 定时调度钉钉发送的pdf文件打开方式

    问题描述:

    Android需要下载后第三方应用打开但是苹果的可以直接打开

    原因分析:

    Android不支持的附件类 url 比如 office文档、pdf、压缩包之类的,都需要通过第三方 App 下载和打开。

    3.2 定时调度推送消息到钉钉群消息异常

    问题描述:

    1)定时调度推送消息到钉钉群,提示:获取不到钉钉应用,请检查网络配置。钉钉调试工具检查网络请求正常

    2)钉钉群推送只有第一个群能收到消息。

    原因分析:

    1)推送到钉钉群需要调用群消息接口,需要钉钉后台未开启获取群会话信息权限。

    2)钉钉后台群会话消息权限未全部开启,下边两个都要开放权限“chat相关接口的管理权限”、“chat相关接口的读取权限”。

    解决方案:

    请参考钉钉操作文档开启权限,详情请参见:https://open.dingtalk.com/document/orgapp/add-api-permission

    3.3 定时调度部分用户无法接收

    问题描述:

    钉钉部分用户定时调度消息收不到消息。

    排查步骤:

    1)用户是否匹配了平台用

    2)用户匹配的平台用户是否在推送的范围内

    3)检查在触发消息推送的时间点,是否有同步通讯录的操作,导致匹配关系更新或更新不及时出现匹配失败

    3.4 钉钉推送失败,日志报错人员匹配失败

    原因分析:

    匹配关系表没有更新导致人员匹配失败。

    排查步骤:

    1)确定定时调度勾选的人员信息,未使用自定义数据集,人员信息正确。

    2)确认匹配关系表更新过了,手动操作同步更新钉钉通讯录,再次操作定时调度。

    解决方案:

    手动同步钉钉通讯录(最好设置自动更新)。

    3.5 钉钉重复消息收不到

    问题描述:

    用户给钉钉推送消息,刚新建任务时能收到。但再编辑后,收不到消息。或设置了重复推送消息,但是只能收到一条消息。

    原因分析:

    由于钉钉 APP 本身的限流政策,有如下规定:

    1)给同一用户发相同内容消息一天仅允许一次;

    2)如果是 ISV 接入方式,给同一用户发消息一天不得超过 100 次;如果是企业接入方式,此上限为 500 。

    因此如果给用户推送消息且每次推送的内容一致的话,只接收第一个消息。

    注:当定时调度设置了「图文推送>自定义链接」的情况,重复链接可以正常推送。

           因为图文推送,都会往调用钉钉图片上传接口,钉钉返回一个图片 url ,每次返回的 url 都不同,所以不会接受不到。

    解决方案:

    在推送消息时,给推送的主题或者内容加一个时间变量 ${now()} (也可以是别的变量)即可。钉钉消息推送详情参考:钉钉定时推送消息


    4. 钉钉单点

    4.1 corpid不合法

    解决方案:

    1)应用 A 生成的链接放在应用 B 的应用首页

    2)跨版本升级(9升11/10升11)之后没有在钉钉管理后台更新单点链接,可参考单点链接的生成 4.2.3 节:企业微信集成

    4.2 errorcode: -8

    问题描述:

    钉钉单点集成后保存

    解决方案:

    工程部署在内网/局域网内,需要确保设备网络和服务器网络在同一个网段。

    4.3 1002 对应企业没有域名微应用

    问题描述:

    用户配置好钉钉集成环境以后,手机上进行单点登录操作,发现如下报错:

    排查步骤:

    1)排查域名一致性:

    钉钉应用如果跟配置了对应的域名环境,由于本身钉钉那边已经配置过对应域名URL了,故本地钉钉配置的时候会报错:为保证企业自建应用安全,同一个域名只能被一个企业使用,该自建应用与XXX使用的域名相同。然后对比这个报错,排查钉钉后台对应的应用中的首页地址,跟实际环境的地址,查看是否是由于域名不匹配引起的。

    2)检查具体参数:

    既然提示信息说的是对应企业没有该域名微应用,而实际上钉钉企业号里是正常配置了域名微应用,故怀疑是否添加的钉钉应用信息与钉钉后台对应的参数不一致,这里需要检查下 corpID,APPkey,APPsecret 是否正确。

    4.4 60011 没有调用该接口的权限

    问题描述:

    钉钉集成帆软应用,单点登录失败,报错:{"errcode":60011,"errmsg":"没有调用该接口的权限,接口权限申请参考:https://open.dingtalk.com/document/orgapp-server/add-api-permission"}

    原因分析:

    钉钉未分配相关接口权限,需要用户自行开启

    解决方案:

    请参考钉钉操作文档开启权限,详情请参见:https://open.dingtalk.com/document/orgapp/add-api-permission

    5. 模板预览

    5.1 PC 端钉钉集成环境,新前端样式下的工具栏不支持导出

    问题描述:

    在PC端的集成环境,从钉钉侧打开报表,新前端样式下,点击报表工具栏导出,会新打开浏览器页面,页面报错:非常抱歉,您无法查看页面。Request method 'GET' not supported。在浏览器去访问平台,打开报表,可以正常导出。

    原因分析:

    11.0的新前端样式下,工具栏的导出,不支持在集成的环境(微信、钉钉)下进行导出。

    解决方案:

    更换工具栏样式为经典。

    5.2 移动端文本控件、文件控件点击均无反应

    问题描述:

    钉钉集成后配置应用的首页链接是钉钉管理页面生成的单张模板链接,设置了之后钉钉打开页面正常展示,但是文本控件的扫码上传和文件控件点击都没有反应

    原因分析:

    钉钉管理生成 url 时参数解析的问题

    解决方案:

    删除其他的默认参数,只保留 op=write 这个参数就可以成功扫码、拍照。

    5.3 获取不到$fine_username等系统参数

    问题描述:

    钉钉集成帆软应用,挂载单个模板链接,获取不到$fine_username等系统参数

    原因分析:

    钉钉未分配该接口调用权限,需要用户自行开启

    解决方案:

    请参考钉钉操作文档开启权限,详情请参见:https://open.dingtalk.com/document/orgapp/add-api-permission

    6. 其他

    6.1 飞书同步不到用户

    原因分析:

    飞书应用目前只支持可见范围是全体成员,如果选择单个部门,飞书管理的用户管理处无法获取到飞书用户。

    解决方案:

    移动端插件 11.0.65 版本之后支持可见范围是部门,可以更新插件解决该问题。

    6.2 钉钉扫码插件-跳转失败

    问题描述:

    钉钉扫码登录决策平台,报错:非常抱歉,您无法查看此页面,检查日志发现签名时间戳参数超时

    原因分析:

    工程服务器与钉钉服务器存在时间差超过1分钟

    解决方案:

    修改工程服务器系统时间

    附件列表


    主题: 移动端应用
    已经是第一篇
    已经是最后一篇
    • 有帮助
    • 没帮助
    • 只是浏览
    中文(简体)

    鼠标选中内容,快速反馈问题

    鼠标选中存在疑惑的内容,即可快速反馈问题,我们将会跟进处理。

    不再提示

    10s后关闭



    AI

    联系我们
    在线支持
    获取专业技术支持,快速帮助您解决问题
    工作日9:00-12:00,13:30-17:30在线
    页面反馈
    针对当前网页的建议、问题反馈
    售前咨询
    采购需求/获取报价/预约演示
    或拨打: 400-811-8890 转1
    qr
    热线电话
    咨询/故障救援热线:400-811-8890转2
    总裁办24H投诉:17312781526
    提交页面反馈
    仅适用于当前网页的意见收集,帆软产品问题请在 问答板块提问前往服务平台 获取技术支持