Backup and Restoration

  • Last update:March 20, 2025
  • Overview

    For FanRuan projects deployed in FineOps, the Backup & Restoration function is provided in Intelligent Q&M. One-click backup, automatic backup, and off-site backup are supported.

    The backup and restoration function introduced in this document is not suitable for FanRuan projects deployed in FineOps.

    You are advised to back up and restore projects in FineOps. One-click backup, automatic backup, and off-site backup are supported. One-click restoration and downtime restoration are supported.

    Version

    FineBI Version
    Functional Change

    6.0

    -

    6.1.5

    Added the alerts related to manual restart of the project after the FineBI configuration of restoration.

    Application Scenario

    Only the latest version of a plugin can be found in Plugin Management when you need its old versions.

    You deleted important report templates or dashboards accidentally.

    You want to roll back after the JAR package update.

    Function Description

    You can back up and restore Platform Configuration, Report Template, JAR Package, and Plugin.

    Unsupported Scenario

    Projects deployed with compressed WAR packages do not support backup and restoration, while those deployed with uncompressed WAR packages can be backed up and restored.

    By default, WAR package deployment in WebLogic Server is a compression deployment. In WebSphere and Tomcat, WAR package deployment is a non-compression deployment.

    Backup

    Backup Path Setting

    iconNote:
    Only the super admin can set the backup path.

    Log in to the FineBI system as the super admin, choose System Management > Intelligent O&M > Backup & Restoration, and click the global setting icon to set the backup path, as shown in the following figure.

    The default backup path is .../backup. The backup file is stored under the path %FineBI%/webapps/webroot/backup.

    You can modify the backup folder to another folder but cannot store the backup file under non-project paths.

    If you remove the characters (../) at the beginning when modifying the backup storage path, the backup file will be stored under the path %FR_HOME%/webapps/webroot/WEB-INF of the project.

    Backup Methods

    Platform Configuration, Report Template, JAR Package, and Plugin tab pages support the two methods: Manual Backup and Auto Backup.

    Manual Backup

    Click Manual Backup, customize the backup name in the pop-up dialog box, and click OK to finish the manual backup.

    Auto Backup

    The super admin can set Backup Frequency, Maximum Records, Backup Capacity, and Backup Failure Reminder under Global Setting > Auto Backup.

    The following table describes the setting items.

    Settings
    DescriptionNotes

    Backup Frequency

    The default frequency is Every Week, with the auto backup time as 2:00 AM.

    -

    Maximum Records

    The maximum record of auto backup in each module is 5.

    If the upper limit is reached, the earliest auto backup needs to be deleted when you create a new one.

    The upper limit after modification does not take effect until the auto detection is performed when the next backup is triggered.

    Backup Capacity

    By default, the available disk capacity for auto backup in each module is 1024 MB.

    If the disk capacity is full, the earliest auto backup will be deleted when you create a new one.

    The backup capacity after modification does not take effect until the auto detection is performed when the next backup is triggered.

    Backup Failure Reminder

    You can be notified through SMS Reminder, Platform Message, or Email Notification if the backup fails.

    Before selecting SMS Reminder, you need to enable the SMS function.

    Before selecting Email Reminder, you need to configure the email service.

    Backup File

    The backup files are stored by default under the path %FineBI%\webapps\webroot\backup, as shown in the following table.

    iconNote:
    1. The super admin can modify the storage location of backup files. For details, see section "Backup Path Setting".
    2. To enhance security, the names of auto-backup files are appended with random characters (not garbled code).


    Backup Content
    DescriptionFolder After Backup

    Platform Configuration

    Platform settings of the backup system and related configuration of FineBI dashboards.

    config

    Report Template

    Back up templates under the path %FineBI%\webapps\webroot\WEB-INF\reportlets.

    reportlets

    JAR Package

    Back up JAR packages under the path %FineBI%\webapps\webroot\WEB-INF\lib.

    jar

    Plugin

    Back up installed plugins.

    plugins

    Take platform configuration backup as an example. The backup files are stored under the path %FineBI%\webapps\webroot\backup\config, in which the folder name is consistent with the backup method. (The manual folder stores manual-backup files while the auto folder stores auto-backup files.)

    Backup Management

    You can rename and delete the backup. The renaming and deletion procedures are the same between Manual Backup and Auto Backup.

    1. Renaming

    Select the to-be-renamed backup, click the renaming button, enter the new name, and click OK.

    2. Deletion

    Select the to-be-deleted backup, click the deletion button, and click OK.

    Notes

    Problem

    The backup fails with an error "java.sql.SQLDataException: data exception: string data, right truncation; table: FINE_CONF_ENTITY column: VALUE" is displayed.

    Cause:

    There exists excessively long data in the fine_conf_entity table, causing backup failure.

    Solution:

    1. Filter out and delete excessively long data fields.

    2. (This solution can only be used in external databases like MySQL.)

    The super admin can adjust the maximum length limit by modifying the value of the parameter BackupConfig.customValueLength through the Fine_Conf_Entity Visual Configuration plugin. The setting takes effect after you restart the server.

    Configuration Item
    Modification Rule

    BackupConfig.customValueLength

    Positive integer (defaulting to 65536)

    Restoration

    Notes

    Auto deletion of the Restored Version

    The backup for one version to be restored can still be retained after restoration. At the same time, the system automatically backs up the current version.

    For example, you back up a plugin at 0:00 AM on August 1st, with Backup A being generated.

    If you restore Backup A at 0:00 AM the next day, the system automatically backs up the plugin used at this time, with Backup B being generated. After restoration, Backup A is still retained.

    If the to-be-restored content is important, backup corresponding files again before the restoration in section "Backup File." You can also contact our technical support for help in restoration.

    Unsupported Restoration in Certain Conditions

    During the restoration, some JAR packages cannot be restored to certain versions in Platform Configuration. The following table shows detailed information.

    Current JAR Package Version
    To-Be-Restored JAR Package Version

    2019-11-08, 2019-12-20, 2020-01-15

    2020-04-03, 2020-05-19, 2020-07-17

    2019-04-30, 2019-06-14, 2019-07-15

    2019-08-15, 2019-09-18, 2019-11-22

    Immediate Execution of Scheduled Task Restoration

    Restoration may influence scheduled tasks and scheduled backups.

    After the restoration, the project may compare the current system time and determine that the scheduled task is not executed. As a result, the scheduled task is executed immediately after the restoration.

    Restoration Method

    Select the backup file in Manual Backup/Auto Backup, click the restoration button, and click OK to restore the backup file.

    Different restoration contents take effect in different ways, as shown in the following table.

    Restoration Content
    Description

    Platform Configuration

    Restoration Notes:

    During the backup and restoration, all users (including admins and business users) cannot use the project. Please inform users in advance.

    After the restoration, you need to restart the project to continue using it. 

    Once the restoration is started, it cannot be terminated, so be careful.

    Restoration in Effect:

    The restoration takes effect after you restart the project. 

    After the restoration, all the dashboards in the current project will be deleted, which will be replaced by the backup dashboards.

    If the project is not restarted immediately and operations are performed based on the project cache, the operations may be lost after a subsequent restart.

    Therefore, you need to manually restart the project immediately after restoring the FineBI configuration.

    Report Template

    The restoration can take effect immediately without restarting.

    The backup templates that are not in the current project will be added. 

    The backup templates that already exist in the current project will be overwritten and updated.

    The project templates that are not in the backup will be retained.


    JAR Package

    The restoration takes effect after you restart the project.

    Plugin

    The restoration can take effect immediately without restarting.


    iconNote:
    Ensure that the server is closed normally when restarting the server. Do not forcefully close the server, for example, directly closing the running window in the Tomcat server.


    附件列表


    主题: System Management
    Previous
    Next
    • Helpful
    • Not helpful
    • Only read

    滑鼠選中內容,快速回饋問題

    滑鼠選中存在疑惑的內容,即可快速回饋問題,我們將會跟進處理。

    不再提示

    10s後關閉

    Get
    Help
    Online Support
    Professional technical support is provided to quickly help you solve problems.
    Online support is available from 9:00-12:00 and 13:30-17:30 on weekdays.
    Page Feedback
    You can provide suggestions and feedback for the current web page.
    Pre-Sales Consultation
    Business Consultation
    Business: international@fanruan.com
    Support: support@fanruan.com
    Page Feedback
    *Problem Type
    Cannot be empty
    Problem Description
    0/1000
    Cannot be empty

    Submitted successfully

    Network busy