For FanRuan projects deployed in FineOps, the Backup & Restoration function is provided in Intelligent Q&M. One-click backup, automatic backup, and off-site backup are supported.
The backup and restoration function introduced in this document is not suitable for FanRuan projects deployed in FineOps.
You are advised to back up and restore projects in FineOps. One-click backup, automatic backup, and off-site backup are supported. One-click restoration and downtime restoration are supported.
Version
6.0
-
6.1.5
Added the alerts related to manual restart of the project after the FineBI configuration of restoration.
Only the latest version of a plugin can be found in Plugin Management when you need its old versions.
You deleted important report templates or dashboards accidentally.
You want to roll back after the JAR package update.
You can back up and restore Platform Configuration, Report Template, JAR Package, and Plugin.
Projects deployed with compressed WAR packages do not support backup and restoration, while those deployed with uncompressed WAR packages can be backed up and restored.
By default, WAR package deployment in WebLogic Server is a compression deployment. In WebSphere and Tomcat, WAR package deployment is a non-compression deployment.
Log in to the FineBI system as the super admin, choose System Management > Intelligent O&M > Backup & Restoration, and click the global setting icon to set the backup path, as shown in the following figure.
The default backup path is .../backup. The backup file is stored under the path %FineBI%/webapps/webroot/backup.
You can modify the backup folder to another folder but cannot store the backup file under non-project paths.
If you remove the characters (../) at the beginning when modifying the backup storage path, the backup file will be stored under the path %FR_HOME%/webapps/webroot/WEB-INF of the project.
Platform Configuration, Report Template, JAR Package, and Plugin tab pages support the two methods: Manual Backup and Auto Backup.
Click Manual Backup, customize the backup name in the pop-up dialog box, and click OK to finish the manual backup.
The super admin can set Backup Frequency, Maximum Records, Backup Capacity, and Backup Failure Reminder under Global Setting > Auto Backup.
The following table describes the setting items.
Backup Frequency
The default frequency is Every Week, with the auto backup time as 2:00 AM.
Maximum Records
The maximum record of auto backup in each module is 5.
If the upper limit is reached, the earliest auto backup needs to be deleted when you create a new one.
The upper limit after modification does not take effect until the auto detection is performed when the next backup is triggered.
Backup Capacity
By default, the available disk capacity for auto backup in each module is 1024 MB.
If the disk capacity is full, the earliest auto backup will be deleted when you create a new one.
The backup capacity after modification does not take effect until the auto detection is performed when the next backup is triggered.
Backup Failure Reminder
You can be notified through SMS Reminder, Platform Message, or Email Notification if the backup fails.
Before selecting SMS Reminder, you need to enable the SMS function.
Before selecting Email Reminder, you need to configure the email service.
The backup files are stored by default under the path %FineBI%\webapps\webroot\backup, as shown in the following table.
Platform Configuration
Platform settings of the backup system and related configuration of FineBI dashboards.
config
Report Template
Back up templates under the path %FineBI%\webapps\webroot\WEB-INF\reportlets.
reportlets
JAR Package
Back up JAR packages under the path %FineBI%\webapps\webroot\WEB-INF\lib.
jar
Plugin
Back up installed plugins.
plugins
Take platform configuration backup as an example. The backup files are stored under the path %FineBI%\webapps\webroot\backup\config, in which the folder name is consistent with the backup method. (The manual folder stores manual-backup files while the auto folder stores auto-backup files.)
You can rename and delete the backup. The renaming and deletion procedures are the same between Manual Backup and Auto Backup.
1. Renaming
Select the to-be-renamed backup, click the renaming button, enter the new name, and click OK.
2. Deletion
Select the to-be-deleted backup, click the deletion button, and click OK.
Problem
The backup fails with an error "java.sql.SQLDataException: data exception: string data, right truncation; table: FINE_CONF_ENTITY column: VALUE" is displayed.
Cause:
There exists excessively long data in the fine_conf_entity table, causing backup failure.
Solution:
1. Filter out and delete excessively long data fields.
2. (This solution can only be used in external databases like MySQL.)
The super admin can adjust the maximum length limit by modifying the value of the parameter BackupConfig.customValueLength through the Fine_Conf_Entity Visual Configuration plugin. The setting takes effect after you restart the server.
BackupConfig.customValueLength
Positive integer (defaulting to 65536)
The backup for one version to be restored can still be retained after restoration. At the same time, the system automatically backs up the current version.
For example, you back up a plugin at 0:00 AM on August 1st, with Backup A being generated.
If you restore Backup A at 0:00 AM the next day, the system automatically backs up the plugin used at this time, with Backup B being generated. After restoration, Backup A is still retained.
If the to-be-restored content is important, backup corresponding files again before the restoration in section "Backup File." You can also contact our technical support for help in restoration.
During the restoration, some JAR packages cannot be restored to certain versions in Platform Configuration. The following table shows detailed information.
2019-11-08, 2019-12-20, 2020-01-15
2020-04-03, 2020-05-19, 2020-07-17
2019-04-30, 2019-06-14, 2019-07-15
2019-08-15, 2019-09-18, 2019-11-22
Restoration may influence scheduled tasks and scheduled backups.
After the restoration, the project may compare the current system time and determine that the scheduled task is not executed. As a result, the scheduled task is executed immediately after the restoration.
Select the backup file in Manual Backup/Auto Backup, click the restoration button, and click OK to restore the backup file.
Different restoration contents take effect in different ways, as shown in the following table.
Restoration Notes:
During the backup and restoration, all users (including admins and business users) cannot use the project. Please inform users in advance.
After the restoration, you need to restart the project to continue using it.
Once the restoration is started, it cannot be terminated, so be careful.
Restoration in Effect:
The restoration takes effect after you restart the project.
After the restoration, all the dashboards in the current project will be deleted, which will be replaced by the backup dashboards.
If the project is not restarted immediately and operations are performed based on the project cache, the operations may be lost after a subsequent restart.
Therefore, you need to manually restart the project immediately after restoring the FineBI configuration.
The restoration can take effect immediately without restarting.
The backup templates that are not in the current project will be added.
The backup templates that already exist in the current project will be overwritten and updated.
The project templates that are not in the backup will be retained.
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