Overview
Version
FineBI Server Version | Functional Change |
6.0.6 | / |
Application Scenarios
FineBI project is generally deployed on middleware, relying on JDBC to connect to the database. You can access platform resources through the Internet.
Therefore, when performance issues like slow template response occur, it is necessary to determine whether it is caused by network problems.
Functions
FineBI has built-in system operation and maintenance plugins that provide network detection. When encountering performance issues, you can use this tool to quickly detect whether there are any network problems.
Basic Network Inspection: detecting the current network environment, analyzing link latency, and checking external and internal network problems.
Network component detection: checking FineDB, business database, FTP file server, Redis status server, OSS storage server and other network components.
Network detection can be used in both standalone and cluster environments. In cluster environments, you can select any node for testing.
Basic Network Inspection
Basic network inspection checks the network environment and link latency from the server of a user to the FineBI server.
Setting Inspection Configurations
Before conducting basic network inspection, admins can customize the inspection configurations.
Log into the FineBI system and go to Manage > Intelligent Operations > Network Detection > Global Setting. You can adjust the basic network inspection settings.
Settings | Description | Default Value | Configuration Value |
Transfer package size | The size of packages passed during basic network inspection. | 10 MB | 5, 10, 15, 20, and 25 |
Transfer timeout time | Checking the duration of transmission timeout during basic network inspection. | 20 seconds | 5, 10, 20, 30, and 60 |
Number of transmissions | The number of transmission tests during basic network inspection. | 5 times | 3, 5, 10, and 20 |
Inspecting
Admins log into the data decision-making system and go to Manage > Intelligent Operations > Network Detection > Basic Network Inspection. It is recommended to first perform Network environment detection before conducting Link time consumption analysis.
You need to wait for a period of time to finish the inspection. You can cancel the inspection at any time by clicking Stop checking.
Viewing Inspection Results
The results are displayed on the Basic Network Inspection page.
1. Network Environment Inspection
Note: The measured speeds of download and upload only represent the download and upload speeds between a user and the platform, not the actual bandwidth of the user's network connection.
Therefore, there may be a significant difference in speed compared to other speed measurement tools.
Inspection Content | Description |
Time delay | The range of the duration during inspection. Its unit is ms. |
Download | Download: The downloaded data volume during inspection. Its unit is Mbps. Time consuming: Time taken to download during inspection. Its unit is ms. Jittering: The average download time during inspection. Its unit is ms. |
Upload | Upload: The uploaded data volume during inspection. Its unit is Mbps. Time consuming: Time taken to upload during inspection. Its unit is ms. Jittering: The average upload time during inspection. Its unit is ms. |
Detection Results | Evaluate network environment comprehensively based on the above inspection. The result is divided into three levels: good, moderate, and rather poor. |
Server Address | The default is FineBI's IP address. |
2. Link Time Consumption Analysis
Record the name, time, and status of the link for sending requests to the browser, receiving requests on the server, sending responses from the server, and receiving responses on the browser.
Network Component Inspection
Check network components like FineDB, business database, FTP file server, Redis status server, and OSS storage server.
Setting Inspection Configurations
Before conducting network component inspection, admins can customize the inspection configurations.
Log into the FineBI system and go to Manage > Intelligent Operations > Network Detection > Global Setting. You can adjust the network component inspection settings.
Settings | Description | Default Value | Configuration Value |
Transfer timeout time | The duration of transmission timeout during network component inspection. | 20 seconds | 5, 10, 20, 30, and 60 |
Number of transmissions | The number of transmission tests during network component inspection. | 5 times | 3, 5, 10, and 20 |
Adding a Component
Before inspecting a component, you need to add it first.
Log into the FineBI system, go to Manage > Intelligent Operations > Network Detection > Network component detection, and click Add network component.
Supported grid components are shown as follows:
Component | Description |
FineDB | External FineDB can be inspected. If the project is configured with an external FineDB, it will be automatically added to Network component detection. No manual addition is required. Deletion of this component is not supported either. |
Business Database | Manually add data connections that currently exist in the system. The first table will be queried by default during business database inspection. You can also customize the query statement for inspection. |
FTP | Manually add FTP file servers that currently exist in the system. |
Redis | Manually add Redis status servers that currently exist in the system. |
OSS | Manually add existing OSS storage servers in the current system. |
Inspecting
You can perform individual or all inspections on the added network components.
Viewing Inspection Results
The inspection results will be displayed in Network component detection.
The inspection logic and return results of various components are shown in the following table:
Component | Detection Logic |
FineDB | 1. Connectivity inspection: Inspect if the component is properly connected. Inspect the connection time between a browser and a component. 2. Component network inspection: Store binary files of 1 MB, 10 MB, and 100 MB in sequence, and then query and delete them. Record the time of storage, query, and deletion. |
Business Database | 1. Connectivity inspection: Inspect if the component is properly connected. Inspect the connection time between a browser and a component. 2. Component network inspection: Query a statement. The first table retrieved by the SELECT statement will be used by default. You can modify the statement. Query the time that the statement is executed and record the time of a browser sending requests, the database receiving requests, the database sending responses, and the browser receiving responses. |
FTP | 1. Connectivity inspection: Inspect if the component is properly connected. Inspect the connection time between a browser and a component. 2. Component network inspection: Store files of 1 MB, 10 MB, and 100 MB, and then download and delete them. Record the time of upload, download, and deletion. |
Redis | 1. Connectivity inspection: Inspect if the component is properly connected. Inspect the connection time between a browser and a component. 2. Component network inspection: Store string data into files of 1 MB, 10 MB, and 100 MB, and download and delete them. Record the time of upload, download, and deletion. |
OSS | 1. Connectivity inspection: Inspect if the component is properly connected. Inspect the connection time between a browser and a component. 2. Component network inspection: Store an image and read and delete it. Record the time of upload, download, and deletion. |
Inspection History
Viewing Inspection Histories
You can view histories of basic network inspection and network component inspection in Historical testing records.
On the Historical testing records interface:
You can view the inspection content and results of each record.
You can copy, delete, or generate reports for each record.
You can select multiple records to generate reports in batch.
Clearing Historical Inspection Records
Historical inspection records will take up certain room of memory. Therefore, admins need to make relevant settings to delete them automatically in a regular time.
Log into the decision-making system and go to Manage > Intelligent Operations > Network Detection > Global Setting to set the frequency of clearing up historical inspection records.
The system will clear up records every three months and retain records for the latest three months by default.
Note: Records of the latest three months refer to the records of the previous three months of the current date. For example, records from August 19, 2019 were deleted manually. Then the system would retain records from May 5, 2019 to August 19, 2019.
Therefore, at least three months of records will be retained. In fact, at most six months of records can be retained sometimes.
Notes
Problem:
When you perform network component inspection on the MySQL database, an error occurs:if you are using the mysql client program, its default max_allowed_packet variable is 16MB. To set a large value
In this case, you can modify and increase the value of the configuration item max_allowed_packet. For how to modify it, you can refer to relevant online materials.
Cause:
The amount of data transferred during inspection may exceed the limit of MySQL.
This is because that the value of max_allowed_packet in the MySQL database is too small.
Solutions:
One:
In my.ini file of the MySQL installation directory, modify the value of max_allowed_packet = X MB in the field of mysqld to max_allowed_packet = 500 MB. Then restart MySQL.
Two:
1. Use the statement set global max_allowed_packet = 524288000; to set the value of max_allowed_packet to 500 MB.
2. Use the statement show VARIABLES like '%max_allowed_packet%'; to check whether the modification is successful.