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Network Detection

  • Last update:  2023-07-21
  • Overview

    Version

    Report Server Version

    Functional Change

    11.0.11

    /

    Application Scenarios

    Generally, FineReport projects are deployed on middleware, relying on JDBC to connect to the database. You can access platform resources through the Internet.

    When performance issues (such as slow template response) occur, it is necessary to determine whether they are caused by network issues.

    Functions

    FineReport has built-in system operation and maintenance plugins that support Network Detection. When encountering performance issues, you can use this tool to quickly detect whether there are any network issues.

    • Basic Network Detection: detects the current network environment, analyzes link latency, and checks external and internal network issues.

    • Network Component Detection: checks network components like FineDB, business database, FTP file server, Redis status server, and OSS storage server.

    Network Detection can be used in both standalone and cluster environments. In cluster environments, you can select any node for detection.

     

    Basic Network Detection

    Basic network detection checks the network environment and link latency from the server of a user to the FineReport server.

    Setting Detection Configuration

    Before conducting basic network detection, admins can customize the detection configurations.

    Log into the decision-making platform as the admin and choose System Management > Intelligent O&M > Network Detection > Global Setting. You can adjust the basic network detection settings.

    Settings

    Description

    Default Value

    Supported Configuration Value

    Data Packet Size

    Packet size passed during basic network detection

    10 MB

    5, 10, 15, 20, and 25

    Transmission Timeout

    Checking the duration of transmission timeout during basic network detection

    20 seconds

    5, 10, 20, 30, and 60

    Transmission Times

    Number of transmission tests during basic network detection

    5 times

    3, 5, 10, and 20

     

    Performing Detection

    After setting the configurations, you can perform basic network detection.

    Log into the decision-making platform as the admin and choose System Management > Intelligent O&M > Network Detection > Basic Network Detection. You are advised to perform Network Environment Detection first before conducting Link Time Consumption Analysis.

    You need to wait for a period of time to finish the detection. You can cancel the detection at any time by clicking the Stop Detection button.

     

    Viewing Detection Result

    The detection result is displayed on the Basic Network Detection page.

     

    1. Network Environment Detection

    Note: The measured speeds of download and upload only represent the download and upload speeds between a user and the platform, rather than the actual bandwidth speed of the user's network connection.

    Therefore, there may be a significant difference in speed compared to other speed test tools.

    Detection Item

    Description

    Delay

    Detection time range (unit: ms)

    Download

    Download: Downloaded data volume during detection (unit: Mbps)

    Time Consumption: Time taken to download during detection (unit: ms)

    Jittering: Average download time during detection (unit: ms)

    Upload

    Upload: Uploaded data volume during detection (unit: Mbps)

    Time Consumption: Time taken to upload during detection (unit: ms)

    Jittering: Average upload time during detection (unit: ms)

    Inspection Result

    Evaluating network environment comprehensively based on the above detection items

    Three levels of results: good, moderate, and poor

    Server Address

    Project's IP address (by default)

    2. Link Time Consumption Analysis

    Record the name, time, and status of the link for sending a request by the browser, receiving the request by the server, sending the response by the server, and receiving the response by the browser.

    Network Component Detection

    Check network components like FineDB, business database, FTP file server, Redis status server, and OSS storage server.

    Setting Detection Configuration

    Before conducting network component detection, admins can customize the detection configurations.

    Log into the decision-making platform as the admin and choose System Management > Intelligent O&M > Network Detection > Global Setting. You can adjust the basic network detection settings.

    Settings

    Description

    Default Value

    Supported Configuration Value

    Transmission Timeout

    Duration of transmission timeout during network component detection

    20 seconds

    5, 10, 20, 30, and 60

    Transmission Times

    Number of transmission tests during network component detection

    5 times

    3, 5, 10, and 20

     

    Adding a Component

    You need to add a component first before detecting it.

    Log into the decision-making platform as the admin, choose System Management > Intelligent O&M > Network Detection > Network Component Detection, and click Add Network Component.

     

    Supported network components are shown as follows.

    Component

    Description

    FineDB

    Supports detection of external FineDB.

    If the project is configured with an external FineDB, the FineDB will be automatically added to the Network Component Detection page.

    Require no manual addition. Not support deletion of this component.

    Business Database

    Allows manually adding data connections that currently exist in the system.

    The first table will be queried by default during business database detection. 

    You can also customize the query statement for detection.

    FTP

    Allows manually adding FTP file servers that currently exist in the system.

    Redis

    Allows manually adding Redis status servers that currently exist in the system.

    OSS

    Allows manually adding OSS storage servers that currently exist in the system.

    Performing Detection

    You can perform individual or all detections on the added network components.

     

    Viewing Detection Result

    The detection result is displayed on the Network Component Detection page.

     

    The detection logic and return results of various components are shown in the following table.

    Component

    Detection Logic

    FineDB

    1. Connectivity detection:

    Check if the component is properly connected.

    Check the connection time consumption between a browser and a component.

    2. Component network inspection:

    Store binary files of 1 MB, 10 MB, and 100 MB in sequence. 

    Then query and delete them.

    Record the time of storage, query, and deletion.

    Business Database

    1. Connectivity detection:

    Check if the component is properly connected.

    Check the connection time consumption between a browser and a component.

    2. Component network inspection:

    Query a statement. The first table obtained by the SELECT statement (default statement) will be used by default. You can modify the statement.

    Record the time of a browser sending a request, the database receiving the request, the database sending the response, the browser receiving the response, and executing the query statement.

    FTP

    1. Connectivity detection:

    Check if the component is properly connected.

    Check the connection time consumption between a browser and a component.

    2. Component network inspection:

    Store files of 1 MB, 10 MB, and 100 MB. Then download and delete them.

    Record the time consumption of upload, download, and deletion.

    Redis

    1. Connectivity detection:

    Check if the component is properly connected.

    Check the connection time consumption between a browser and a component.

    2. Component network inspection:

    Store strings of 1 MB, 10 MB, and 100 MB. Then download and delete them.

    Record the time consumption of upload, download, and deletion.

    OSS

    1. Connectivity detection:

    Check if the component is properly connected.

    Check the connection time consumption between a browser and a component.

    2. Component network inspection:

    Store an image, and read and delete it.

    Record the time consumption of upload, download, and deletion.

    Historical Detection Record

    Viewing Historical Detection Record

    You can view all records of basic network detection and network component detection in Historical Detection Record.

    On the Historical Detection Record page, you can:

    • View the detection content and results of each record.

    • Copy, delete, or generate reports for each record.

    • Select multiple records to generate reports in batch.

     

    Cleaning up Historical Detection Record

    Historical detection records will take up certain room of memory. Therefore, you need to make relevant settings to delete them automatically in a regular time.

    Log into the decision-making platform as the admin and choose System Management > Intelligent O&M > Network Detection > Global Setting to set the frequency of clearing up historical detection records.

    The system will clear up records every three months and retain records for the latest three months by default.

    Note: Records of the latest three months refers to the records from the previous three months of the current date. For example, you clean up the records manually on 2019/08/19, and then the system will retain records from 2019/05/19 to 2019/08/19.

    To sum up, at least three months (at most six months) of records will be retained.

     

    Notes

    Problem:

    When you perform network component detection on the MySQL database, an error occurs:

    if you are using the mysql client program, its default max_allowed_packet variable is 16MB. To set a large value

    Cause:

    The amount of data transmitted during detection may exceed the limit of MySQL.

    This is because that the value of max_allowed_packet in MySQL database is too small.

    Solution:

    In this case, you can increase the value of the configuration item max_allowed_packet.

    One:

    In the my.ini file under the MySQL installation directory, change max_allowed_packet in mysqld to 500 M and restart the MySQL database.

    Two:

    1. Set the value of max_allowed_packet to 500 M by using the statement set global max_allowed_packet = 524288000;.

    2. Check whether the modification is successful by using the statement show VARIABLES like '%max_allowed_packet%';.

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