Overview
When you need to view the effect of FineReport templates on mobile terminals, you can preview them through mobile terminals (DataAnalyst, browser, etc.). FineReport supports mobile preview on HTML5 terminals and the FineMobile App. This document describes how to quickly configure the single template preview on DataAnalyst.
Note: To access templates on mobile terminals, you need to have an account and a password for the decision-making platform. For details, see Introduction to the Decision-making Platform.
DataAnalyst Download
1. Go to the FineReport official website and choose Product > Download to go to the page on which you can download the FineReport installation package.
2. Mobile download provides the IOS version and Android version, you can use the mobile browser to scan the code for the installation.
Environment Preparation
Switch the PC and mobile devices to the same network environment. You can keep the network consistent through the following two methods.
1. Create a hotspot for your computer through your smartphone.
2. Connect the smartphone and the computer to the same hotspot.
To prevent the wireless network switchover failure of the computer IP address, ensure that you have unplugged the wired network.
Single Template Access
PC Configuration
1. Open the FineReport designer and open any general report or dashboard. Take GettingStartedEN.cpt as an example, select Mobile Preview, as shown in the following figure.
2. The following figure shows the browser display page on a PC.
Attribute | Note |
---|---|
GettingStartedEN | Report name |
Type | Report preview type and can be set to Preview or Data Entry. Note: Data Entry is not supported in dashboards. |
QR Code | The report access link's QR code can be directly recognized and accessed by DataAnalyst and third-party browsers. |
Copy Link | If the IP address in the current URL is localhost, localhost will be automatically recognized as the IP address of the current network. A prompt displaying "Ensure that mobile terminals are on the same network as the current PC" is shown below the link. |
DataAnalyst Server Configuration
1. After the installation, the first time you open DataAnalyst, the prompt message "Before logging in, you should add a server to your server settings!" will be displayed. Click Set Now.
2. Click New Server, or return to the main page and choose Server > New Server, and scan the QR code generated in the previous step, as shown in the following figure.
DataAnalyst Login Server
Click the symbol in the upper right corner New Server to confirm the new server information. Enter your username and password on the App login page. This document takes the built-in user Alice (account: Alice; password: 123456) in the FineReport designer as an example. After successfully logging in to the DataAnalyst, you can jump to the template page, as shown in the following figure.
Notes
Problem Description
When you preview templates on mobile terminals, the server fails to be connected or the browser fails to be opened after you scan the QR code, as shown in the following figure.
Cause
Not-Configured Network Environment
Cause: The mobile terminal is not on the same network as the current computer.
Solution: For details, see section "Environment Preparation."
Firewall Block
Cause: If you confirm that you have performed operations based on the document process and the application has been configured correctly, the error may be caused by the Windows firewall.
Solution: Directly disable the Windows firewall and proceed with preview operations on mobile terminals. Alternatively, configure the Windows firewall to open the unauthorized port based on the following steps.
1. Choose Windows Security > Firewall & network protection > Advanced settings > Inbound Rules > Import Policy.
2. Select Port in Rule Type, select TCP and Specific local ports in Protocol and Ports, enter 8075 on the text box, and save the setting, as shown in the following figure. Click Save.
IP Address Identification Error
Cause: Since the computer connects to multiple networks in a short period, the network corresponding to the IP address in the QR code link is different from that connected to the mobile terminal.
Solution: Enter ipconfig /all in the CMD prompt window to view the actual IP address of the local device. Compare the obtained IPv4 address with the IP address in the link below the QR code generated in the report, as shown in the following figure.