Overview
When using the designer, you may encounter situations where you cannot save or open a designer template, but you don't know how to locate or solve the problem. This document describes the solutions for common problems according to the common bug causes and template saving mechanism, by which you can find out and solve the problems in the actual situation.
Report File Saving Mechanism
Common Problems in Template Creation
Template Creation Failure
Problem: You cannot create a template.
Solution: The problem is usually a permissions issue, and you can solve the problem by checking remote design permissions and server directory permissions.
Blank General Report Generation by FRM Report Creation
Problem: You create an FRM report, which generates a blank general report.
Solution: The problem is an issue with the new adaptive plugin, and you can solve the problem by disabling or upgrading the plugin.
Scattered Designer Image in Template Editing
Problem: After you open the designer and add an FRM report, the images on the screen are scattered and incomplete wherever the mouse goes, making the report unusable.
Cause: This problem is related to the graphics card configured in the computer.
Solution:
1. You are advised to modify the FineReport configuration file, and find the designer.vmoptions file under the bin directory of the designer installation path, as shown in the following figure.
2. You are advised to modify the information of the file designer.vmoptions: -Dsun.java2d.d3d=false which means to close the JAVA 3D function.(Direct3D, a property parameter of the Java Swing 2D system. Sometimes the Direct3D function may lead to JVM Crashed, which is set to true by default.) The following figure shows the effect.
3. You can solve the problem by restarting the designer.
Common Problems in Template Opening
The template currently opened in the designer is subject to the following verifications:
1. Whether the currently opened template has been locked by someone else.
2. Whether the current template structure (xml) is normal.
If the check results are normal, the template can be opened normally. If the template cannot be opened, you can detect the problem with the following methods:
1. You can check the log error to see whether the problem is related to a plugin according to the specific error report. The problem may be related to an extension chart plugin.
2. If the log contains no valid messages, the problem may be the xml corruption.

Blank General Report Opened by FRM Report
Problem: You open an FRM report, but a blank general report appears.
Solution: The problem is an issue with the new adaptive plugin, and you can solve the problem by disabling or upgrading the plugin.
Unable to Start Browser in Report Preview
Problem: When previewing a report, you may encounter the following two situations where the report cannot be displayed on the B/S side: You cannot start the browser, and the report is displayed in a pop-up window.
Solution: You can solve the problem by setting the default browser for your computer.
Unable to Preview All Templates on the Designer
Problem: You cannot jump to the template or create a template by clicking the preview icon on the designer with the error: ERROR [standard] --job class not found, jobKey: DATA_PREPARE.DATA_PREPARE_FR-FB001.
Solution: You can solve the problem by changing the default browser for your computer or installing a preset browser plugin.
Preview Prompt on Browser Page: Hmmm… can't reach this page
Problem: After you click the preview icon, the prompt "Hmmm… can't reach this page" appears.
Cause: The problem in the designer local preview is mostly due to built-in server startup failures.
Solution:
1. You need to confirm that the built-in server is turned on. The green triangle represents the on status at this time. The red square or no such icon represents the failure of the built-in start. The following figure shows the two statuses.
2. You need to check whether the problem is related to the designer port.
If you do not restart the designer after changing the default port, you can solve the problem by restarting the designer.
For the port occupancy in the tomcat of the designer and local server, see Port Occupancy Check.
3. If the antivirus software or the system firewall is installed in the system, you can solve the problem by disabling the antivirus/firewall and re-clicking the preview icon (which automatically starts the built-in server).
4. Problems in Designer Installation
If the designer installation directory is on the C drive, you can start or reinstall the designer as an administrator.
If there is a mismatch between the number of bits in the designer and the number of bits in the operating system, you are advised to re-download and install the designer with the matching number of bits.
Jumping to the Browser Page by Clicking the Preview Icon with a Blank Template Page
Cause:
1. The problem is related to browser caching. If the preview is blank in Internet Explorer while normal in other browsers, the problem is related to compatibility issues.
2. The problem is related to designer cache files: The designer is started multiple times or illegally shut down (the designer process is not shut down cleanly), resulting in abnormal designer cache files under the user's directory, and the templates appear to be previewed as blank.
3. The problem is related to the template itself.
The template file is too large.
The server data, such as global parameters, is used in the template, and the global parameters are calculated abnormally.
The amount of data in the widget data dictionary of the parameter panel is too large, or the default value of the data dictionary is abnormal.
Load events, start events, or end events in the template cause problems.
The performance issue of the template causes a large blank period before the template loading animation, and the browser page is not responding.
4. The db.lobs inside the embed's finedb is deleted, causing the binary content not to be read, with an error reported: com.fr.third.org.hibernate.HibernateException: IOException occurred reading a binary value. The template preview is blank.
Solution:
1. You are advised to clear your browser cache first.
Compatibility view check: You need to see whether the compatibility view (which is disabled generally) is enabled because some JS of the template does not support IE5, the default document mode in the compatibility view.
Plugin impact check: Most of the problems are because the JS introduced by the plugin doesn't support lower versions of IE, or the third-party plugin is incompatible. If you can make sure that the problem is caused by a plugin, you can file a bug.
The problem of the Chinese template name: When a Chinese template in JS can not be loaded in IE, you can check whether the template with an English name can be loaded normally. If so, you are advised to encode the Chinese template.
2. You are advised to close the designer process, clear the fineRepot100 or fineRepot110 in the user directory of the C drive (you can move the file out first, and the activation code is kept in FineReportEnv.xml, please pay attention to keep it), and restart the designer.
3. You are advised to modify the relevant settings according to the specific analysis of the template. You can close the platform, and choose System Management > Extracted Data Cache > Always Re-read Template. The process is slow the first time, but fine after that.
4. You are advised to replace the db.lobs in the new finedb into the project.
Common Problems in Template Saving
No Real-time Effect of Template Saving
Problem: Template saving does not work in real time.
Solution:

1. This problem is due to the caching set for the platform. You can solve the problem by choosing System Management > Extracted Data Cache > Cache Configuration and disabling Always Re-read Template.
2. If the problem is still not solved after Always Re-read Template is disabled, you are advised to disable the new engine.
Template Saved as 0kb
Problem: Templates are saved as 0kb.
Cause and solution one: Insufficient space on the project disk.
1. You can use the Disk Cleanup function to clean up your disk safely and conveniently.
2. You can expand the disk.
Cause and solution two:
Cause: The file index node inodes in Linux is full, and you can check the utilization of inodes by using the command df -i.
Solution: You can clean up extra files or increase the number of inodes.
Cause and solution three:
You are advised to check whether the template name contains ? * and other characters, and if so, you can solve the problem by removing those characters.
Template Saving Failure
Problem: You cannot save a template.
Solution:
1. You are advised to check whether the server JAR and designer JAR versions are the same, and if not, you can solve the problem by setting the same JAR. If the versions are the same, you need to check whether the JAR is missing. For details, see Abnormal Jar Packages Detection.
2. You are advised to view Log Error Messages.
If the error message is because there was insufficient free space available after evicting expired cache entries, this problem is related to the Tomcat environment, and you can solve the problem by increasing the maximum cache value.
If the error message is socket write error, this problem is related to the network on some Windows systems that have the IPv6 TCP stack installed, and you can solve the problem by adding the jvm configuration item -Djava.net.preferIPv4Stack=true.
If the error message is nginx 413 error, limit request size (template size exceeded), you can solve the problem by modifying the configuration item body size of nginx.
If the error message is write account error, the problem is due to the insufficient operator's permission, and you can solve the problem by modifying the folder permissions.
3. With no abnormalities in the logs, you are advised to view specific manifestations of the problem.
If only one template can not be saved, the problem may be caused by the default size limit of 2m for the post request. In this case, you can solve the problem by modifying the post request size of the tomacat.
If all the templates (both new and old templates) can not be saved, the problem is almost related to the permissions. In this case, you are advised to check the server directory permissions.
No Effect of Template Saving
No changes in browsing results regardless of the template modification
Problem: After you modify the template, the preview in the browser is unchanged.
Cause: After you visit a page with your browser, the result will be cached for a while. If you modify the template and preview it again, the preview effect is the same as before, because the browser will directly load the previously cached results with the same path and parameters.
Solution: You can clear the browser history and refresh the page to see the post-modified results.
No changes in the preview with the modification in template setting
Solution: You are advised to check whether the modifications are configured correctly, for example, whether the parameter name is bound to the parameter widget after clearing the browser cache.
Template File Saved as Temp File by Abnormal Close of the Designer
Problem: When the designer is closed abnormally, the template file is lost as a temp file.
Solution: You can recover the file by changing its suffix to cpt or frm.
Prompt in Template Saving
Problem: The following prompt appears when saving the template “Inconsistent locking information, whether to generate a backup file.”
Solution: The problem is due to the inconsistent uuid, which may be caused by the following reasons.
1. The template is forced to be unlocked by the administrator during the editing process.
2. The working directory is switched.
Common Problems in Template Preview
Unable to Preview Properly
Problem: The template cannot be previewed properly by clicking the preview icon.
Solution:
1. You can check the default browser settings, and modify the default browser.
2. You can install the plugin Preset Browser Plugin.
Inconsistency Between the Preview and Actual Effects
Problem: The preview effect is inconsistent with the actual effect of the template.
Solution: The problem is caused by cache settings configured in the platform. You can solve the problem by choosing System Management > Extracted Data Cache > Cache Configuration and disabling Always Re-read Template.
Unable to Preview the Report That Can Be Opened in the Designer.
Problem: The report can be opened in the designer, but cannot be previewed with the error message:
cannot open the url Successful.
Solution:
1. This problem is mostly related to the default browser settings (firewalls, and antivirus software), since some antivirus software can automatically change the default browser.
2. If you can preview the report after switching to the local working directory in remote design, this problem may be related to the jar package problem.
3. This problem is related to url issue, when you preview the configured url in the remote design and find an extra space at the end of the IP address with an error message.
Garbled Character Problem
Reasons for garbled characters:
Garbled characters appear when the two ends of the mutual access use different encodings that can not be recognized by each other.
For example, if the English words spoken by an American in China are transliterated into Chinese, some confusing statements that cannot be understood by everyone will appear. For example, the expression "I love you" can be parsed as "hey tiger oil", which cannot be understood, thus generating garbled characters.
Reasons for garbled characters when you open the template in the designer:
1. Language displayed as garbled characters is caused by the lack of the corresponding language fonts.
2. Inconsistent encoding of the designer, server, and transfer tool causes the template to display garbled characters when opened after remote design or transfer.
Solution:
1. You can install the corresponding language pack and a plugin to optimize the performance.
2. You can modify the encoding of the designer, server, and transport tool to present a consistent encoding. Sometimes you cannot modify the encoding after integrating the encoding into your system, and even if the encoding is modified, you need to modify it again when needed. In this case, you can use the built-in CJK encoding in FR, and don't need to think about the page encoding or server encoding.
For example, you can pass Chinese values to parameters and export the renamed garbled characters by URL.
Thai Garbled Characters in Designer
Garbled characters appear when you edit Thai text in designer cells or formula editing boxes.
Cell:
Formula editor:
Cause: The Thai text is not supported in OpenJDK.
Solution:
You can copy the %JAVA_HOME%\jre folder in the JDK installation directory and overwrite the %FR_HOME%\jre folder in the designer installation directory.
You can copy tools.jar from the %JAVA_HOME%\jdk\lib directory in the JDK installation directory to the %FR_HOME%\lib folder in the designer installation directory.

Note:
1. Without tools.jar, the designer cannot start properly.
2. The required JDK version: JDK 1.8 and a minor version of JDK 8u102 or above.
Boxes in Garbled Chinese in Charts
Cause: The boxes appear because of the lack of Chinese fonts.
Solution: You can download and update the corresponding Chinese font base corresponding to the computer system.
Garbled Characters in the Thai and Korean languages
Solution: You can modify the server encoding where the project is located to UTF-8.
Misaligned Designer Page with the Menu Displayed in English
Cause: You may use a plugin element that doesn't exist in the current environment when opening a template last time.
Solution: You can click Ctrl and N on the keyboard to create a new template and exit the designer, and then start the designer again.
Garbled Characters on Designer Database Query Page
Problem: All English in the SQL editing area of the database query page is garbled, as shown in the following figure.
Solution: For details, see Common Problems in Database Query.
Japanese Data Source Preview with Garbled Characters
Problem: The Japanese data are displayed normally in the report and the database, but the preview in the browser is garbled.
Solution: The Japanese characters that are displayed normally and those that are not displayed normally are not the same. You can check the font installation package, and install the correct font package.