反馈已提交

网络繁忙

备份还原

  • 文档创建者:susie
  • 历史版本:33
  • 最近更新:Carly 于 2024-12-19
  • icon提示:

    对于运维平台部署的帆软项目,运维平台提供「备份管理」功能。支持一键备份,支持自动备份,可实现异地备份。

    对于运维平台部署的帆软项目,无法使用本文的平台备份还原功能,进行相关内容还原。

    请通过运维平台完成:备份项目还原项目。支持一键备份、自动备份、异地备份。支持一键还原、宕机还原。



    1. 概述

    1.1 版本

    报表服务器版本功能变更
    11.0-

    1.2 应用场景

    • 用户需要使用旧版本的插件,但插件管理中只能搜到最新版本插件。

    • 用户误删重要的报表模板。

    • 用户更新 JAR 后,基于某些原因想要回退。

    1.3 功能简介

    平台提供备份还原的功能,支持对「平台配置」、「报表模板」、「JAR 包」、「插件」进行备份还原,以及在线对服务器工程进行更新升级。如下图所示:

    26.png

    1.4 不支持的场景

    War 包压缩部署不支持备份还原,War 包非压缩部署支持备份还原。

    WebLogic 下 War 包部署时,默认是压缩部署的,WebSphere、Tomcat 下 War 包部署时,默认是非压缩部署的。

    2. 备份

    2.1 设置备份路径

    注:仅超级管理员可设置该路径。

    超级管理员登录数据决策系统,点击「管理系统>智能运维>备份还原」,点击「全局设置」按钮,设置备份路径,如下图所示:

    默认备份路径为../backup,备份文件存储在工程的%FR_HOME%/webapps/webroot/backup文件夹下。

    用户可修改 backup 文件夹为其他文件夹,但是不支持保存到非工程路径下。

    若修改备份路径时去掉前面的../,那么备份文件存储在工程的%FR_HOME%/webapps/webroot/WEB-INF文件夹下

    image.png

    2.2 备份方式

    在「平台配置」、「报表模板」、「JAR 包」、「插件」Tab 页面,均支持手动备份和自动备份两种方式。如下图所示:

    2.2.1 手动备份

    点击「手动备份」,弹出对话框,可自定义名称,点击「确定」,手动备份完成。如下图所示:

    28.png

    2.2.2 自动备份

    超级管理员在「全局设置」中可设置自动备份的「备份频率」、「份数上限」、「备份容量」、「备份失败提醒」等。如下图所示:

    image.png

    各设置项介绍如下表所示:

    设置项说明注意事项
    备份频率默认为「每周」,自动备份时间是凌晨两点-
    份数上限

    每个模块自动备份上限默认为 5 份

    当份数已满上限后,在做新的自动备份时,删除最早一份自动备份

    份数上限修改后,不立刻生效

    下一次触发备份时自动进行检测,并生效

    备份容量

    每个模块自动备份可占磁盘默认为 1024 M

    当磁盘容量已满后,在做新的自动备份时,删除最早一份自动备份

    备份容量修改后,不立刻生效

    下一次触发备份时自动进行检测,并生效

    备份失败提醒

    若自动备份失败后,系统可通过「短信提醒」、「平台消息」、「邮件提醒」

    短信提醒需要「开启短信功能」,详情请参见 短信 

    邮件提醒需要「配置邮箱服务」,详情请参见  邮箱 

    2.3 备份的文件

    备份的文件默认存放在%FR_HOME%\webapps\webroot\backup目录下,具体位置如下表所示:

    注1:超级管理员可修改备份文件的存放位置,请参见本文 2.1 节。

    注2:为提高安全性,自动备份的文件名称后面会加上随机字符,并非乱码。

    备份内容
    简介备份生成的文件夹
    平台配置备份系统的平台设置项config
    报表模板备份%FR_HOME%\webapps\webroot\WEB-INF\reportlets文件夹中的模板reportlets
    JAR 包备份%FR_HOME%\webapps\webroot\WEB-INF\lib文件夹中的 JAR 包jar
    插件备份系统安装的插件
    plugins

    以平台配置举例,备份的文件在 %FR_HOME%\webapps\webroot\backup\config 下,其中 manual: 手动备份auto: 自动备份。如下图所示:

    31.png

    2.4 删除备份

    勾选需要删除的备份,点击「删除」,确认删除,即可删除之前的备份,自动备份和手动备份操作步骤一样,如下图所示:

    30.png

    2.5 注意事项

    问题描述:

    备份失败,报错「java.sql.SQLDataException: data exception: string data, right truncation;  table: FINE_CONF_ENTITY column: VALUE」

    原因分析:

    fine_conf_entity 表中存在数据长度超长,导致备份失败。

    解决方案:

    方案一:将超长的数据字段筛选出来删掉 。

    方案二:仅支持mysql类型的外接数据库使用该方案。

    超级管理员可通过「fine_conf_entity可视化配置插件」,修改BackupConfig.customValueLength参数值,来调整最大长度限制,重启服务器后设置生效。如下表所示:

    配置项修改规则
    BackupConfig.customValueLength

    参数值需为正整型

    默认值为65536

    3. 还原

    3.1 注意事项

    1)还原某个版本的备份后,被还原版本不会被自动删除,自动对当前版本进行备份。

    例如在1号零点备份了一次插件,生成备份A。2号零点还原备份A时,会自动将2号零点工程使用的插件进行备份,生成备份B。且还原操作完成后,备份A仍然存在。

    2)还原操作可能会对定时任务(例如定时调度、定时备份等)产生影响。

    还原后,工程对比当前系统时间,可能会判定定时任务执行遗漏,导致系统定时任务在还原成功后立即执行一次。

    3.2 还原方式

    点击手动备份/自动备份下备份的文件,点击「还原按钮」,点击「确认」按钮后弹出「还原完成,请重启」,重启服务器即可生效,如下图所示:

    29.png

    不同内容还原生效的方式略有不同,详情如下表所示:

    还原内容
    描述
    平台配置

    重启工程后,还原生效

    报表模板

    无需重启,立即生效

    • 当前工程下没有、备份中有的模板会新增

    • 当前工程下有、备份中有的模板会覆盖更新

    • 当前工程下有、备份中没有的模板会保留

    JAR 包重启工程后,还原生效
    插件无需重启,立即生效

    注:重启服务器时要保证服务器正常关闭,不能暴力关闭服务器比如直接叉掉 Tomcat 服务器的运行窗口。

    4. 更新升级

    注:由于工程所在服务器环境可能存在隐患,例如内存不足、网络通信异常,因此不推荐在正式工程使用本节方案

          建议正式工程使用手动升级方案,详情请参考:工程小版本手动升级方案 。

    4.1 自动推送更新

    「自动推送更新」按钮默认打开,当有更高版本的JAR 包发布时,系统将自动推送至平台。如下图所示:

    32.png

    4.2 更新升级

    1)新版本发布后,登录服务器,查看并处理推送信息,如下图所示:

    63.png

    2)点击「立即更新」,进行版本更新,如下图所示:

    平台.png

    4.3 重启服务器

    注:更新完成后,为确保工程的正常使用,必须立即重启服务器

    更新完成后,重启服务器生效。

    4.4 注意事项

    问题描述:点击「立即更新」后,F12查看,发现报错「414 Request-URL too large」

    原因分析:出现该报错,并生成一个很长的地址,是云端运维插件中报表服务的产品配置信息与云中心交互的流程,可忽略。

    解决方法:

    如不希望显示该报错,可使用超级管理员账号登录数据决策系统,访问http://ip:port/webroot/decision/v1/cloud/feature/config/recordFineMarkId/false即可

    从 false 改为 true 则是开启该功能。配置修改成功会返回 :

    {

    "data": true

    }

    附件列表


    主题: 数据决策系统
    已经是第一篇
    已经是最后一篇
    • 有帮助
    • 没帮助
    • 只是浏览
    中文(简体)

    鼠标选中内容,快速反馈问题

    鼠标选中存在疑惑的内容,即可快速反馈问题,我们将会跟进处理。

    不再提示

    10s后关闭



    AI

    联系我们
    在线支持
    获取专业技术支持,快速帮助您解决问题
    工作日9:00-12:00,13:30-17:30在线
    页面反馈
    针对当前网页的建议、问题反馈
    售前咨询
    采购需求/获取报价/预约演示
    或拨打: 400-811-8890 转1
    qr
    热线电话
    咨询/故障救援热线:400-811-8890转2
    总裁办24H投诉:17312781526
    提交页面反馈
    仅适用于当前网页的意见收集,帆软产品问题请在 问答板块提问前往服务平台 获取技术支持