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Plugin Management FQA

  • Last update:  2023-08-11
  • Overview

    Version

    FineBI Version

    6.0

    Problem Description

    There may be some issues during plugin installation and management.

    This document provides solutions to common issues of plugin installation/maintenance.

    Abnormal Plugin Management Interface

    Plugin Version Update

    Problem:

    Log in to FineBI as the admin and choose System Management > Plugin Management. In the plugin management interface, sometimes a prompt box pops up saying "A new version is available in the plugin store. Do you want to update?"

    Cause & Solution:

    In this case, the updated plugins are those in the FanRuan App Store, not the installed plugins in your project. You can click OK.

    Blank App Store Interface/Unable to Log in with FanRuan Account

    Problem:

    1. After logging in to the FineBI system as the admin, choose System Management > Plugin Management, and the App Store page is blank.

     

    2. When you log in to the plugin store with FanRuan account, a prompt pops up, indicating that an error occurs.

     

    Troubleshooting Step One: Check the external network address.

    Cause:

    The server is not connected to the external network.

    Solution:

    Open the needed network according to the external network address. For details, see FineBI's External Network Address.

    Troubleshooting Step Two: Check URL Management Center.

    Cause:

    The server can be accessed through the external network, but URL Management Center is disabled in the General tab page of the System Management node, causing the plugin engine module to be disabled.

    Solution:

    Log in to the decision-making platform as the admin, choose System Management > System Setting > General, enable URL Management Center, and click Save.

    iconNote:

    1. If URL Management Center is disabled in the remote environment, the issue described in this section also occurs.

    2. For details about the introduction of URL Management Center, see General.

    Failed Online Installation of Plugin

    Error: connection time out

    Problem:

    Online installation of plugin failed, and an error message occurs: connection time out.

    Cause:

    The current project cannot be successfully connected to the online plugin store.

    Solution:

    Open the needed network according to the external network address. For details, see FineBI's External Network Address.

    Online Installation/Update of Plugin

    Problem:

    The installation/update of plugins in the decision-making platform is stuck, with no progress bar or Installation completed displayed. However, after refreshing the page, the plugin has been installed/updated.

    Cause:

    WebSocket port is occupied and unable to push notifications to the browser.

    Solution:

    Open the WebSocket port. For details, see WebSocket Connection Failed.

    Failed Local Installation of Plugin

    Local Installation/Update of Plugin

    Problem:

    After the plugin package is installed from the local, the installation progress bar and the prompt (xxx plugin is installed successfully) are not displayed.

     

    Cause & Solution:

    1. The plugin package is too large, causing slow installation.

    • Wait patiently.

    2. Unable to establish a connection in the engineering environment to the position where the installation package is located. For example, the external network cannot be connected.

    • Open the needed network according to the external network address.

    3. The plugin installation directory has no permission.

    • Assign 777 permission to the path %FR_HOME%\webapps\webroot\WEB-INF\plugins of the plugin installation.

    Failed File Upload/Installation Package (Request Entity Too Large) Not Found

    Problem:

    When the plugin is installed locally, a prompt pops up, indicating that the file upload failed or installation package is not found, and if you check the log through F12, the error ouccurs: 413 Request Entity Too Large.

    Cause:

    The uploaded plugin package is too large. By default, Linux supports maximum file upload size of 1 MB.

    Solution:

    1. Install the plugin manually rather than locally. For details, see Plugin Management.

    2. Modify the configuration file of Linux.

    • Find the nginx.conf file and change the body size.

    • After the change, reload Nginx with the command nginx -s reload. If the command fails to reload, restart the Linux server to load it.

    Expired Plugin

    Problem:

    A prompt indicates that the XXX plugin has expired, and you need to go to the FanRuan App Store to purchase it.

    Cause:

    The project used by users is registered and paid plugins that have not been purchased can be tried for free for 90 days. After 90 days, users need to purchase a license to use them.

    • When the FineBI project is not registered, plugins can be used for free requiring no authorization.

    • After the FineBI project is registered, free plugins can be used normally requiring no authorization.

    • After the FineBI project is registered, purchased paid plugins with authorization can be used normally.

    • After the FineBI project is registered, paid plugins that have not been purchased can be tried for free for 90 days. After 90 days, users need to purchase a license to use them.

    Solution:

    Purchase the plugin license and add it to the project. For details, see Plugin Registration.

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    主题: System Management
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