Registration FAQ

  • Last update:  2023-07-18
  • Overview

    This article mainly introduces the causes and corrective methods of system registration problems in different registration scenarios.

    License Upload Stuck

    Problem description:

    The page is stuck in the process of uploading the license file.

    Troubleshooting:

    Check the modification time of the FanRuan .lic file in %BI_HOME%/webroot/WEB-INF/resources to judge if the file has been successfully uploaded. 

    1) The file was not uploaded successfully.

    Possible cause: The system blocks the PUT request as an invalid request.

    Solution: You can install a plugin to convert PUT and DELETE requests to POST requests. 

    2) The file was uploaded successfully.

    Possible cause: The front end did not refresh in time.

    Solution: Manually refresh the page to see if the registration is successful. If the registration still fails, please refer to the following according to the error information. 

    License Upload Failure

    Problem description:

    An error message pops up saying "File FanRuan.lic can't pass validation. Please check it" in the process of license file upload.

    Solution:

    Log into the FineBI system, choose System Management > Security Management> Security, temporarily disable File Upload Verification, and then enable it after registration.

    Xnip2023-07-18_14-37-13.jpg

    Certificate Expired

    Problem description:

    It prompts "Fail to register. Please re-register" in the process of registration. When you click for more information, it prompts "Expired Time: xxxx-xx-xx".

    Possible cause:

    The registration license file used in the current project has reached the expiry date agreed upon in the contract.

    Solution:

    1) If the expiration date has passed, please contact sales to renew the license.

    2) If the expiration date agreed in the contract has not yet arrived, but the license has expired, please contact the sales to get the correct registration license.

    Version Mismatch

    Problem description:

    It prompts "Fail to register. Please re-register" in the process of registration. When you click for more information, it prompts the following information:

    Certified APP Version: 9.0

    Local Application Version: 10.0

    Possible cause:

    The version upgrade of FanRuan products is divided into upgrades (such as upgrading from 9.0 to 10.0, from 10.0 to 11.0), and updates (such as updating from 10.0.1 to 10.0.2).

    1) Upgrades affect the license.

    Cross-version upgrades, such as upgrading from 9.0 to 10.0 affect the license files, and re-registration or migration of the license is required.

    2) Updates do not affect the license.

    In-version updates, such as updating from 10.0.9 to 10.0.10, have no impact on the license.

    Solution:

    1) If it is a newly registered project and the project version agreed upon in the contract is consistent with the product version, please contact sales to request the correct registration license.

    2) If it is an upgraded project, the old registration license cannot be used. Please contact sales for post-upgrade license migration. 

    MAC Address Mismatch

    Problem description:

    It prompts "Fail to register. Please re-register" in the process of registration. When you click for more information, it prompts the following information:

    Authenticated MAC Address: xxx

    Local MAC Address: xxx

    Troubleshooting:

    A media access control address (MAC address) is a unique identifier assigned to a network interface controller (NIC) for use as a network address. Network nodes with multiple network interfaces must have a unique MAC address for each NIC in the same network. The MAC address in the registration license must be able to match any MAC address of the server.

    The MAC address format for Linux or Unix systems is different from the general MAC address format, for example, 0*001F296EFD64.

    Server SystemDeployment MethodPossible Causes and Solutions

    Windows

    -

    Possible cause: 

    The NIC is changed, resulting in a change of MAC address.

    Solution: Contact business personnel for reauthorization.

    Possible cause: 

    The MAC address of the server where the project is located has been modified.

    Solution:

    Option 1: Change the MAC address back.

    Option 2: Contact business personnel to get the license.

     

     

     

     

     

     

     

     

     

     

     

     

     

     

    Linux

     

     

    Docker

    Possible cause:

    If the MAC address and the universally unique identifier (UUID) of a Docker container are not fixed, the MAC address changes randomly on reboot.

    Solution:

    1) It is recommended to fix the MAC address for Docker.

    2) If the MAC address is not bound, it is recommended to use Private Cloud/Public Cloud for authentication.

     

     

     

     

    Virtual machine

    Possible cause:

    MAC addresses of virtual machines are divided into 

    1) Fixed MAC address: the virtual machine can be configured with a fixed MAC address that remains unchanged on reboot. 

    2) Same MAC address with the host: keep the MAC address consistent with the MAC address of the host machine that remains unchanged on reboot. 

    3) Dynamic MAC address: the prefix is the same, the last four bits change randomly, and the MAC address changes on reboot.

    Solution:

    1) Confirm whether the host hardware has been replaced or the system has been reinstalled recently. The change will lead to a change in the MAC address. Please contact the business personnel to get the license. 2) If the virtual machine uses a dynamic MAC address, it is recommended to use Private Cloud/Public Cloud for authentication.

     

     

     

     

     

    Physical machine

    Possible cause:

    Restart the physical machine with a script not as a root user or there is no access to corresponding commands.

    Solution:

    Try to start as the root user and grant access to the corresponding command.

    Possible cause:

    When starting as a root and a non-root user, the MAC address of the middleware of the Linux system (such as Tomcat) will be different.

    Solution:

    Try to start as the root user and keep the MAC address consistent.

    Machine Code Mixmatch

    Problem description:

    It prompts "Fail to register. Please re-register" in the process of registration. When you click for more information,  it prompts the following information:

    Authenticated Machine Code: xxx

    Local Machine Code: xxx

    Troubleshooting:

    FactorsPossible Causes and Solutions

    System hardware

    Possible cause: Hardware such as CPU, hard disk, motherboard, etc., are replaced, resulting in the change of the machine code. 

    Solution: Contact business personnel for reauthorization.

    JDK

    Possible cause: Java Development Kit (JDK) is required to read the machine code. If JDK changes, the machine code may also change. 

    Solution: Change back to the original JDK and restore the environment variables.

     

    Virtual machine

    Possible cause: Restarting the virtual machine will change the machine code.

    Solution: Contact business personnel for reauthorization.

    It is not recommended to select Local Machine Info as the AUTH Method for virtual machines. Select Private/Public Cloud instead.

     

    Permission

    Possible cause: When starting as a root and a non-root user, the machine code of the middleware of the Linux system (such as Tomcat) will be different or cannot be obtained.

    Solution: Try to start as the root user and keep the machine code consistent.

     

    Cloud system

    Possible cause: Modifying configurations will change the machine code.

    Solution: Contact business personnel for reauthorization.

    It is not recommended to select Local Machine Info as the AUTH Method for virtual machines. Select Private/Public Cloud instead.

    Application Name Mismatch

    Problem description:

    It prompts "Fail to register. Please re-register" in the process of registration. When you click for more information,  it prompts the following information:

    Certified Application Project Name: xxx

    Local Application Project Name: xxx

    Possible cause:

    The project address is like http://ip:port/project_name/decision, where the project_ name is webroot by default.

    This error usually results from a change in the project name.

    Solution:

    When sending an authorization request email to the business personnel:

    If you have specified the project name, then the license returned is valid for the project noted in the email.

    If you have not specified the project name, then the license returned is valid for webroot project.

    Please modify the project name to the same as that in the license file.

    License Exhausted

    Problem description:

    It prompts "Fail to register. Please re-register" in the process of registration. When you click for more information, it prompts "The maximum license number has been reached".

    Troubleshooting:

    Registration MethodFactorsPossible Causes and Solutions

     

     

     

     

     

     

     

     

     

     

    Local machine info

     

     

    Multiple projects on the server

    Possible cause:

    Another project running on the server is using the license.

    Solution:

    Check the modification time of the FanRuan.lic file in %BI_HOME%/webroot/WEB-INF/resources of other projects on the same server of this project.

    If it is a newly added license file, delete it, and go to the correct project to re-register.

     

     

    Repeated loading of the project

    Possible cause:

    Tomcat domain is incorrectly configured, and there are two <host> in Tomcat's server.xml, one domain name and one IP address, causing repeated loading of this project.

    Solution:

    Delete the <host> of the IP address in the XML file, and only retain the <host> of the domain name. The IP address can still be accessed, and there is no need for extra configuration.

     

     

     

    Incorrect startup path

    Possible cause:

    A virtual path is configured in server.xml, causing the project to start twice.

    Solution:

    Option 1: Comment out the docBase configuration in server.xml, then restart the project and register.

    Option 2: Move the webroot project out of the webapps folder, specify the report project access path in the XML file, then restart the project and register.

     

     

     

     

     

    Public cloud

     

     

    License being used by the old project

    Possible cause:

    A maximum registration quantity will be submitted with your application for public cloud authorization.

    This error will occur if the registration limit is exceeded.

    Solution:

    Unbind the license from the old project and then bind it to the new project.

     

     

    Physical information being changed

    Possible cause:

    The physical information of the virtual machine changes due to restart, causing registration seats to run out.

    Contact technical support to confirm whether your public cloud license is occupied.

    Solution:

    Ask technical support to assist with unbinding before binding the license to the new project. 

    Incorrect Certificate Content

    Problem description:

    It prompts "Fail to register. Please re-register" in the process of registration. When you click for more information, it prompts "The certificate content is incorrect".

    Troubleshooting:

    Factors 

    Possible Causes and Solutions
    User permission not configured 

    Possible cause:

    The user who starts the project does not have permission to write, and when the user configures 777 permission, it prompt "[Resource] Write failed!"

    Solution:

    Reconfigure the permission to write or start as root user.

    Repeated running of the migration program

     Possible cause:

    A new license is generated after the migration program runs successfully for the first time. Running the migration program again after registration with the new license will invalidate the current license.

    Solution:

    Contact business personnel for reauthorization.

    OthersCheck possible factors one by one according to the actual condition of the project if the error is caused by other reasons. It is recommended to contact technical support to solve the problem.

    Local Container Authentication

    All Nodes are Restarted

    Problem description:

    Local Container is selected as the authentication method. After a restart, the registration page reports an error saying "All nodes are restarted".

    Possible cause:

    A re-registration is required after a restart if you use local container authentication.

    Solution:

    Scan the code using your phone for authentication.

    Error Code 40002, Lic Has Been Used by Other Machines

    Problem description:

    After modifying the configuration library of the server, restarting the server, and scanning the code with the mobile phone to authenticate, you see a prompt saying "Error code 40002, lic has been used by other machines". 

    Possible cause:

    A re-registration is required once the configuration library of the server is modified if you use local container authentication.

    Solution:

    Contact business personnel to cancel the license of the original server and register using the Container.lic file sent by the business personnel.

    Private Cloud Authentication Program Startup Exception

    The following errors may occur if the authentication program starts abnormally. Please check according to the specific error information. 

    Errors

    Uninstalled

    The authentication server has been uninstalled before. If you need to use the authentication server again on the same authorization server, you need to obtain the machine information again and re-register.

    Expired

    It is related to the system time.

    If the system time at registration is 16:18:55, 21st, Dec, the private cloud takes effect from 16:40:29, 21st, Dec.

    Error code 30002

    Abnormal account status

    1) No new machine information was generated after the original authentication server is destroyed. Instead, the original machine information was used, resulting in duplicate sessionid in the rif machine information file.  

    2) It is related to the permissions of executing the startup command, and it is recommended to run as root user.

    Address already in use

    The port is occupied. Start the authentication program using another interface.

    Add -port to specify the new port when starting the program on the command-line interface, as shown below:

    Windows: .server.exe -port 8090.

    Linux/Mac: ./server -port 8090.

    Public Cloud Authentication 

    Network Issues

    1) The FineBI project server used by users must be connected to the authorization server through the public network. Customers who are not allowed to use the Internet cannot use this registration method.

    IP addresses to be connected are listed below.

    Domain NamePortDescription

     https://register.fanruan.com

    443

    Public cloud authentication server

    https://cloud.fanruan.com

    443

    URL management center

    2) The URL management center is not enabled, causing the project unable to connect to the Internet.

    The admin logs into the FineBI system and chooses System Management > System Setting > General to enable URL Management Center, as shown below.

    Xnip2023-07-18_14-39-09.jpg

    System Time Issue

    Possible cause: The system time on the project server is inconsistent with the actual time.

    Solution: Modify the system time of the server to the actual time.

     Illegal Characters in Account Name

    Possible cause: Public cloud accounts cannot contain Chinese characters and Chinese punctuation.

    Solution: Contact business personnel to change the public cloud account.

    Limit Exceeded

    During registration, the registration time, the number of data connections, the number of concurrent IP addresses, and the number of users are limited. If the limit is exceeded, an error or exception will occur.

    • If the current system is registered, super admin can view the limit values by logging in to the decision-making system and visiting http://IP:port/webroot/decision/v11/register/info/license, as shown below.

    • If the number of data connections reaches the limit value, newly added data connections will not be displayed and cannot be used.

    • If the number of concurrent IP addresses reaches the limit, other IP addresses cannot log in.

    • In the case of permanent registration, the expiration time is 100 years later. After that, you can contact the business personnel of Fanruan for free registration.

    • Replacing server hardware may cause a change in the machine code, resulting in registration failure.

    • Changing the project name will cause inconsistent project names, resulting in registration failure.

    • If the number of users reaches the limit, you cannot add users, and it will prompt "Conflict with other administrator operations, please refresh and try again".  

    • If the number of distributed nodes reaches the limit, newly added nodes will not be displayed and cannot be used.

    Xnip2023-07-18_14-43-09.jpg

    Lack of Function Points 

    If some functions are not available, cannot be opened, or errors like "You've used an unregistered function" and "java.lang.NullPointException" occur when you are using FineBI, some function points were not purchased at registration. You can check the registered function points by choosing System Management > Registration Management > Function List in the decision-making platform, as shown in the following figure.

    iconNote:
    For detailed introduction of each function point, see Registration Management.

    If you need to add and purchase function points, contact business@fanruan.com.

    Xnip2023-07-18_14-44-58.jpg

    Multiple Registration Methods Used

    If there are both a license file and an encryption lock on the server, the license file takes precedence, and the server will read the encryption lock only if the license file does not exist. In other words, for the authentication method, Local Machine Info takes precedence over Dongle.

    Blank Chart due to Invalid License

    If charts cannot be previewed on the designer when you use a new license, 

    it is because you did not restart the web server after placing the FanRuan.lic file in the project directory %BI-HOME%\webroot\WEB-INF\resources.

    The web server must be restarted for the license to take effect.

    Null Point Error

    If an error message appears saying "java.lang.NullPointException" when you are previewing some templates, it is because this template contains some functions that are not included in your license.


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