Overview
Version
FineBI Version | Functional Change |
6.0 | / |
Functions
FineBI allows receiving and sending emails, and both operations need the email account information.
1. Allows setting multiple system sender email addresses and setting default sender email address.
2. Allows viewing historical email sending records and querying sending records based on sender’s mailbox, recipient’s mailbox l, template name, and other conditions.
Setting Sender Account
There are two steps:
1. Add a sender/senders.
2. Select the default sender from the added senders.
Note: If the default sender is not configured, the mailbox is also not configured.
Adding a Sender
The admin logs into FineBI, and clicks Manage > System > Mailbox > Add Sender to set the sender account.
The sender account settings are explained in the table below:
Email Settings | Explanation |
Mail Server (SMTP) | Select the mail server.
|
Port and Encryption Method | Set the port and encryption method for email service.
Note: 1. It is recommended to use more secure TLS protocols. 2. If you want to set an encryption method, you need to ensure that the certificate used for encryption has been added to Java’s list of trusted certificates otherwise the client will not be able to read the encrypted response. |
Sender Address | Enter the sender's email address.
|
Password | Most email accounts only require entering the email password. |
Show Name | Name of the email sender, which can be manually edited and entered |
Send Test Mail | Test whether the mail server is configured successfully. |
After Sender Account Setting is configured, click Send Test Email, enter a recipient email, and click OK.
The test mail received by the recipient is displayed as Congratulation! Your mail server is configured successfully.
Click OK to add the recipient successfully.
Note:
1. The email body is displayed in HTML format. Some fonts that are not supported will be displayed as SimSun Font.
2. The unsupported fonts are those that contains special symbols like spaces and - in the font name, such as Wingdings 3.
FineBI allows configuring multiple sender addresses and editing/deleting sender addresses.
Setting Default Sender
After adding the sender, the admin can select one of the added senders as the default sender of the system and click Save to make it take effect.
Note: If the sender address corresponding to the default sender is deleted, then the default sender is empty and the mailbox configuration is not completed.
Enabling POP3/SMTP Service and Generating Authorization Code
After enabling POP3/SMTP service, you can send and receive emails in clients. Failure to enable may result in email configuration issues.
Outlook Mailbox
Log into Outlook mailbox, click Settings > Mail > Sync email, and enable POP service.
After enabling, you can view server information like the server name, port, and encryption method recorded in SMTP setting.
When configuring the sender account in the decision-making platform, you need to enter the server name in FineBI. Port and encryption method of the mail server need to be configured according to the following text.
Exchange Mailbox
Before adding the sender account, you need to collect the following information:
Mail Server (SMTP): IP address of the mail server
Sender Address: Exchange email address
Password: Login password for Exchange email address
The admin logs into FineBI, clicks Manage > System > Mailbox > Add Sender, and sets the sender account. Enter the collected information in advance and select Do Not Encrypt as Encryption Method.
After Sender Account Setting is configured, click Send Test Email, entera recipient email, and click OK.
The test mail received by the recipient is displayed as Congratulation! Your mail server is configured successfully.
Click OK to add the recipient successfully.
Sending Records
You can query the system's historical email sending records based on conditions such as sender, the recipient's email address, template name, and email sending date.
The sending record displays information such as Sender, IP Address, Receive Email, Template Name, Accessed Resources, Send Time, and Send Result.
Notes
Network Configuration
Ensure connectivity between the FineBI project and the email server.
1. You need to ensure that the project can access the external network normally when using a mail server in the external network.
2. If you use your own internal email server, there is no need to connect to the external network. Just ensure that there is connectivity between the FineBI project and the email server.
Unsuccessful Test Email Sending for Not in Java Trust List
Problem:
On the intranet server, there is no problem sending SSL encrypted emails through Foxmail, but there is a problem through FineBI. It can be sent out by changing to unencrypted port 25.
An error is prompted: Could not connect to SMTP host: SMTP.fanruan.cn, port: 465, response: -1.
Cause:
The email server set on the intranet needs to be added to Java’s list of trusted certificates. Certificates that have not been added to the Java’s trusted list cannot send emails. Other clients such as Firefox which have their own certificate trust system can send normally.
Solution:
Import the certificate into Java’s list of trusted certificates.
Incorrect Verification Code
If you send emails frequently within one minute, an error message Failed to get verification code will be displayed.
You can continue sending after one minute.