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The FineBI system has a built-in collection of user information, including basic user information, user departments, user positions, user roles, and platform users.
Log in to the FineBI system as the admin and choose System Management > User Management. Four tab pages are displayed: All Users, Department, Role, and Platform User, as shown in the following figure.
You can add users with the following three methods.
Manually adding users
Manually enter user information, departments, and roles.
You can only add one user at a time.
You can edit, disable, and delete users.
Adding Users
Importing users
Import user information, departments, and roles from the server dataset.
You can import multiple times. Once imported, the user is unrelated to the server dataset.
Importing Users
Synchronizing users
Synchronize user information, departments, and roles through the server dataset.
A system can synchronize with only one dataset at a time.
When the User Editability setting is disabled, you cannot edit users.
You can disable users, but you cannot delete users.
Synchronizing Users
The FanRuan application may contain some initial default test users (different versions may contain different users, all of which are listed here).
Built-in user list: Abby, Anna, Alice, Ben, Billy, Cherry, demo, eoco, hanwen, Jack, Jenny, Lily, Lisa, Mike, sunlin, Tom, wangwei, zhangshan
Built-in user password: 1
For formal projects, you are advised to delete the default built-in test users in FineBI System > System Management > User Management.
If you want to keep using built-in users, manually reset the user passwords.
On the Department tab, you can perform the department management of a company, which includes the management of departments, positions, and personnel.
Department Adding
In the Department List, select a manually added department, click the + button in the upper right corner, enter Department Name, select the superior department from the drop-down list of Superior Department, and click OK to add a subordinate department, as shown in the following figure.
Department Hierarchy Adjusting
You can modify the superior departments and the hierarchical structure of manually added departments.
For example, Audit Group is a subordinate department of Finance Group 1, and now you want to move it under Finance Group 2.
Hover the cursor over Audit Group, click the Edit button, adjust Superior Department by selecting Finance Group 2, and click OK, as shown in the following figure.
Audit Group has been adjusted to a subordinate department of Finance Group 2. The positions and users under the department are also adjusted and moved.
After the adjustment of department hierarchy, the subordinate department cannot automatically inherit the Task Schedule configuration for the new parent department.
For example, the default user group for Task Schedule is Human resources. Now, adjust Finance Group 1 to a subordinate department of Human resources.
The default user group for Task Schedule now contains all subordinate departments of Human resources and their positions, except for Finance Group 1 and its positions.
Department Renaming
Hover the cursor over a department, click the Edit button to rename the department, and click OK.
After the department is renamed, the configured permissions will not be affected.
Department Deleting
Hover the cursor over a department, click the Delete button, and click OK. The department and its subordinate departments will be removed from the department list.
Positions in the deleted department still exist in the position list of the system. Admins can configure these positions for other departments.
Users in the deleted department still exist in the user list. However, the department is deleted from Dept.-Posit. of these users .
Editing Users for Departments
Admins can bind specific users to each department that is not added by user synchronization.
Select a department other than All Departments, click Edit User in the upper right corner, and the personnel management dialog box will pop up, as shown in the following figure.
Admins can add or delete users under the department. The system supports one-click full selectionand one-click clearance, as shown in the following figure.
Click users in Unselected User to move them to Selected User.
Similarly, click users in Selected User to move them to Unselected User,
as shown in the following figure.
You can select the department to view the users under it in the user list.
Position Adding and Configuring
Select a department, and click the edit button in the upper right corner of Position List. The Edit Position window will appear, where you can add, delete, or modify positions for that department, as shown in the following figure.
The positions in the checkbox are generated by Import User and can be selected and added as positions for this department. The positions generated by Synchronize User cannot be selected.
You can quickly find the positions generated by Import User with the search box. If no item is found after you search for a position, you can click the + button to add it.
Position Deleting
Hover the cursor over a certain position, click the Delete button, and click OK. The position will be removed from the position list of the department.
Deleted positions still exist in the position list of the system. Admins can configure the positions for other departments.
For example, you have selected and added the Finance Team Leader position for both Finance Group 1 and Finance Group 2. If the admin deletes the Finance Team Leader position from Finance Group 2, the Finance Team Leader position in Finance Group 1 will not be deleted.
Editing Users for Positions
Admins can bind specific users to each position.
Select a position under a department, click Edit User in the upper right corner, and the personnel management dialog box will pop up, as shown in the following figure.
Admins can add or delete users under the position. The system supports one-click full selection and one-click clearance, as shown in the following figure.
You can perform role management and personnel management on the Role tab page.
Role Management
On the Role tab page, click the + button in the upper right corner of Role List to add a new role to the system, as shown in the following figure.
Admins can bind specific users to each role.
Select a role, click Edit User in the upper right corner of User List, and a personnel management dialog box will pop up, as shown in the following figure.
Admins can add or delete users under the role. The system supports one-click full selection, one-click clearance, and filtering of personnel based on departments and positions,, as shown in the following figure.
You can batch-add users for built-in roles (not generated by Synchronize User).
Click Batch Add, enter the usernames in the Add Users in Batches box, separate each username with commas(,), and click OK, as shown in the following figure.
1. All users added successfully
If all users are added successfully, a prompt "X user(s) added successfully." will be displayed.
Duplicate usernames are considered the same user. Deduplication will be performed when users are added successfully.
If you add a user that has been added to Role, the user will be counted again during batch-add.
Users that are added successfully to a role will be automatically moved from Unselected User to Selected User, as shown in the following figure.
2. Partial users added successfully
The following situations may lead to addition failures:
A username that does not exist in the platform is added. Subordinate admins add any username that is not within their management scope.
If there are spaces before or after the separator(,), they will be automatically removed before the username matching. There are spaces at the beginning and end of the username, resulting in matching failures.
If the FineDB database type is DB2, MySQL, or SQL Server, and there is a space at the end of the actual username, the username can still be successfully matched and added as a user.
If there is a comma (,) in the username, it will be considered as a separator to separate the username into two usernames. The addition will fail if the two users do not exist on the platform.
If there are users that failed to be added, a prompt "X user(s) added successfully, X user(s) failed to be added." will be displayed. You can click Details to view the usernames that failed to be added, as shown in the following figure.
For details, see Platform Users.
In the corresponding platform system, you can edit and select users to assign permissions on viewing the platform to the users, as shown in the following figure.
To change the default settings, you need to click Edit User and then set and modify the user permissions . For PC users, click Edit User in the upper right corner and select the corresponding user.
If the user is not in the corresponding list, the user cannot log in to the platform.
For example, Alice is enabled but not listed as a Platform User. Therefore, Alice has no permission to access the FineBI system, as shown in the following figure.
There will be no restriction on platform users if you disable.
The previous configuration on restricted users will be kept if you enable User Restriction again.
In the default state of the FineBI project, where the number of PC users, view users, and designers are set to unlimited, all users are data analysis users by default.
If the project is officially registered:
1. During registration, if there is no limit on the number of users, you need to enable User Restriction before configuring the platform users. Otherwise, by default, all users have platform usage, FineBI viewing, FineBI design, and mobile platform permissions.
2. During registration, if the number of users is limited, there will be a maximum limit on the number of platform users.
Problem:
When performing the following operations in User Management, operations will fail, and a popup prompt will be displayed, indicating that "xxx external database plugin has expired, the current operation is not effective, and this function is currently affected. Perform registration in time".
Add/Edit/Delete/Disable/Import users
Add/Edit/Delete departments
Add/Edit/Delete roles
The following figure displays the popup prompt.
Cause:
The project uses the information innovation version of the external FineDB database. The function point authorization of this type of database has expired, which affects the user management function, making the function unusable.
Solution:
You can contact FanRuan's sales personnel to renew or purchase the using authorization related to this type of database.
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