Backup and Restoration

  • Last update:September 01, 2023
  • Overview

    Version

    Report Server Version

    JAR Package

    Functional Change

    11.0

    /

    /

    Application Scenarios

    • Only the latest version of a plugin can be found in Plugin Management when you need its old versions.

    • Important report templates are deleted accidentally.

    • You want to back up after JAR package updates.

    Function Description

    You can back up and restore Platform Configuration, Report Template, JAR Package, Plugin, and Update&Upgrade. You can also update and upgrade the server project online.

     1.png

    Unsupported Scenarios

    When the WAR package is deployed in the WebLogic server, the package is compressed by default, which cannot be backed up and restored. When the WAR package is deployed in WebSphere and Tomcat servers, the package is uncompressed by default, which can be backed up and restored.

    Backup

    Setting Backup Path

    iconNote:
    Only the super admin can set the backup path.

    Log in to the decision-making system as the super admin, choose System Management > Intelligent O&M > Backup & Restore, and click the global setting icon to set the backup path, as shown in the following figure.

    The default backup path is .../backup. The backup file is stored under the path %FR_HOME%/webapps/webroot/backup.

    You can store the backup file in another folder, but cannot store it under paths beyond the project.

    If you remove the characters (../) at the beginning when modifying the backup storage path, the backup file will be stored under the path %FR_HOME%/webapps/webroot/WEB-INF of the project.

     2.png

    Backup Method

    Two backup methods Manual Backup and Auto Backup are supported on the Platform Configuration, Report Template, JAR Package, and Plugin tab pages.

    Manual Backup

    Click Manual Backup, customize the backup name in the pop-up dialog box, and click OK to finish the manual backup.

     3.png

    4.png

    Auto Backup

    The super admin can set Backup Frequency, Upper limit of copies, Backup Capacity, and Backup Failure Notice under Global Setting > Auto Backup.

     5.png

    The explanation of these settings is shown in the following table.

    Settings

    Explanation

    Notes

    Backup Frequency

    The default frequency is One Week, with the auto backup time as 2:00 A.M.

    /

    Upper limit of copies

    The default upper limit number of auto backups in each module is 5.

    If the upper limit is reached, the earliest auto backup needs to be deleted when you create a new one.

    The upper limit after modification does not take effect until the auto detection is performed when the next backup is triggered.

    Backup Capacity

    The default available disk capacity for auto backups in each module is 1024 MB.

    If the disk capacity is full, the earliest auto backup needs to be deleted when you create a new one.

    The backup capacity after modification does not take effect until the auto detection is performed when the next backup is triggered.

    Backup Failure Notification

    If the auto backup fails, you can be notified through SMS, platform, or email.

    Before selecting SMS Reminder, you need to enable SMS function. For details, see SMS Service.

    Before selecting Email Reminder, you need to configure the email service. For details, see Email Service.

    Backup Files

    The backup files are stored by default under the path %FR_HOME%\webapps\webroot\backup, as shown in the following table.

    iconNote:

    1. The super admin can modify the storage location of backup files. For details, see section "Setting Backup Path".

    2. To enhance security, the names of auto-backup files are appended with random characters (not garbled code).

    Backup Content

    Explanation

    Folder After Backup

    Platform Configuration

    Platform settings in the backup system

    config

    Report Template

    Back up templates under the path %FR_HOME%\webapps\webroot\WEB-INF\reportlets.

    reportlets

    JAR Package

    Back up JAR files under the path %FR_HOME%\webapps\webroot\WEB-INF\lib.

    jar

    Plugin

    Back up installed plugins.

    plugins

    Take platform configuration backup as an example. The backup files are stored under the path %FR_HOME%\webapps\webroot\backup\config, in which the folder name is consistent with the backup method. (The manual folder stores manual-backup files while the auto folder stores auto-backup files.)

     6.png

    Deleting Backups

    Select backups to be deleted, click Delete, and click OK to delete previous backups. Deletion operations for auto backup and manual backup are the same.

     7.png

    Notes

    Problem:

    Backup failed, with an error message java.sql.SQLDataException: data exception: string data, right truncation; table: FINE_CONF_ENTITY column: VALUE.

    Cause:

    There exists excessively long data in the table fine_conf_entity table, causing backup failure.

    Solution:

    1. Filter out and delete excessively long data fields.

    2. This solution can only be used in external databases like MySQL.

    The super admin can adjust the maximum length limit by modifying the value of the parameter BackupConfig.customValueLength through the Fine_Conf_Entity Visual Configuration plugin. The setting takes effect after you restart the server. 

    Configuration Item

    Modification Rule

    BackupConfig.customValueLength

    The parameter value needs to be a positive integer (default value as 65536).

    Restore

    Notes

    The backup for one version to be restored can still be retained after restoration. At the same time, the system automatically backs up the current version.

    For example, you back up a plugin at 0:00 A.M. on August 1st, with Backup A being generated.

    If you restore Backup A at 0:00 A.M. the next day, the system automatically backs up the plugin used at this time, with Backup B being generated. After restoration, Backup A is still retained.

    Restore Method

    Select backup files (through either Manual Backup or Auto Backup), click the restoration icon, and click OK. Then a prompt box pops up, saying Restore is successful, please restart the server to take effect.

     8.png

    9.png

    Different restoration content takes effect in different ways, as shown in the following table.

    Restoration Content

    Explanation

    Platform Configuration

    Takes effect after you restart the project.

    Report Template

    Takes effect immediately.

    • Adds backup templates that are not in the current project.

    • Overwrites and updates backup templates in the current project.

    • Retains project templates that are not in the backup.

    JAR Package

    Takes effect after you restart the project.

    Plugin

    Takes effect immediately.

    iconNote:
    Ensure that the server is closed normally when you restart the server. Do not forcefully close the server such as directly closing the running window in the Tomcat server.

    Update/Upgrade

    iconNote:

    Be careful to use this solution for project upgrades in a formal environment, because failures may be caused by problems like memory exhaustion and abnormal cluster communication, which affects project using.

    You are advised to upgrade projects manually.

    Auto Push Update

    The Auto Push Update function is enabled by default. If JAR packages with higher versions are published, the system can automatically push them to the platform.

     10.png

    Update/Upgrade

    1. Log in to the server after a new version is published, view the push message, and process it.

     11.png

    2. Click Update Now to update the version.

     12.png

    Restarting the Server

    iconNote:
    To ensure that the project can be used normally after update, you need to restart the server immediately.

    The update takes effect after you restart the server.

    Notes

    Problem: It is ineffective to click Update Now, with an error (414 Request-URL too large) occurring after you check with F12 key.

    Cause: The error represents the interaction process between the product configuration information of the report service in theCloud Operation Maintenance plugin and the cloud center. You can ignore it.

    Solution:

    If you do not want the error to occur, log in to the decision-making system as the super admin and access the path http://IP address:Port number/webroot/decision/v1/cloud/feature/config/recordFineMarkId/false to disable the error prompt function.

    You can enable the error prompt function by changing false to true. The following code is returned after successful modification:

    {

    "data": true

    }


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