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Troubleshooting Steps for Permission Management Exception

  • Last update:  2023-07-21
  • Overview

    You may meet problems such as no permissions when accessing dashboards  or ineffective permission settings due to improper operations when using FineBI.

    This document provides troubleshooting steps for permission exceptions.

    No Permission for Dashboard Accessing

    No Permission for the Overall Dashboard

    Problem:

    When you access a dashboard, an error pops up in the entire dashboard: Sorry, you cannot view this page. You do not have access to this page. Please contact the administrator.

     21.png

    Solution:

    1. Choose System Management > Template Authentication to check if Template Authentication is enabled. If Role Permission Authentication is configured and the error occurs when you directly share the dashboard, the error is shown in the following figure.

     1.png

    If Role Permission Authentication is configured and the error occurs when you share the dashboard through the URL of the dashboard preview, the error is shown in the following figure.

     2.png

    Solution:

    • Choose System Management > Template Authentication and disable Template Authentication if you do not need.

    3.png

    For details, see Template Authentication.

    • If you do not need the template authentication for a certain template, you can find the template you want to view in Template Need Authentication and disable Template Authentication. For example, set the Company Comprehensive Operation Dashboard as no need to authenticate.

     4.png

    • If you need to enable Template Authentication for the problem template, you can configure the viewing permission for it in General Permission Configuration.

     5.png

    2. Choose System Management > User Management > Platform User > PC User and confirm the classification of the current user. Add the user to BI View User or BI Design User in BI User.

     6.png

    No Permission for Some Components

    Problem:

    When you access a dashboard, an error occurs in some components of the dashboard: You are currently not authorized to view the component data.

     7.png

    Solution:

    1. Choose System Management > Permission Management and confirm if the user has Data Authorization for Component Data.

     8.png

    2. If the data table used is a self-service dataset, you need to check if Permission Inheritance is enabled and if the user has the viewing permission for the parent table of the self-service dataset.

    For details, see Permission Inheritance.

    Ineffective Filter Permission

    Confirming a User's Basic Information

    Enter a user's information for query in System Management > User Management and lock all departments and roles where the user is located.

     9.png

    View permissions set based on Dept., Position, or Role.

    Confirming Permissions Configured for Users

    Confirm that the permissions of the corresponding dashboard or the data table in Public Data are assigned to users.

    Confirming Logical User Permission Settings

    For details, see Special Scenarios for Row and Column Permissions.

    No Export Button for a Dashboard in the Directory

    Problem:

    Alice logs into her account. She cannot export the entire dashboard in the directory or export individual components.

     10.png

    Solution:

    Confirming Export Configuration Permissions

    Log into FineBI as the admin. Choose System Management > Permission Management > Directory and enable Export permission.

     11.png

    Confirming the State of Template Authentication

    If you want to have the Export permission of the dashboard in the directory (enable Role Permission Authentication first), you need to assign the Export permission to both General Permission Configuration and Template Authentication.

    iconNote:
    If Dept.Role, or User has no Export permission in Template Authentication (regardless of whether the Export permission is enabled in Permission Management > Directory), you cannot export the dashboard (including global exporting and component exporting) when editing the dashboard, viewing the dashboard in the directory, viewing the dashboard on the homepage, and viewing the dashboard in Share with Me.

    Therefore, the admin needs to assign the Export permission of BI templates corresponding to the template authentication to Alice.

     12.png

    iconNote:
    For templates shared directly by users or shared via URL, the viewing and exporting permissions depend on the permissions assigned to the user in Template Authentication. That is, if the viewing permission of the template authentication is configured, the user can view the dashboard. If the exporting permission of the template authentication is configured, the user can export the dashboard.

    No Permission for Adding SQL Datasets and Database Tables

    Checking User Type

    Choose System Management > User Management and check if the user is in BI Design User. If not, add the user into BI Design User.

     13.png

    Checking Users' Data Connection Permissions

    Choose System Management > Permission Management and confirm that the user has the data connection permission to add the corresponding database tables and datasets.

     14.png

    iconNote:
    To set Data Connection, you need to enable Global Setting.

    Failure to Move Folders

    Problem:

    Users cannot move folders to other groups.

     15.png

    Cause

    The user needs to have the node management permission of the group to which the user wants to move and the management permission of the folder moved.

    For example, Alice wants to move the Function Data folder to the Industry Data folder.

     16.png

    In this case, the admin needs to assign the node management permission of the Function Data group and the management permission of the Industry Data folder to Alice.

     17.png

    But Alice cannot move folders under the Function Data group to the Industry Data group because she does not have the management permission for the Industry Data group.

    Failure to Create Folders and Datasets in the Corresponding Group

    Problem:

    Users cannot create folders and datasets in the corresponding group.

     18.png

    Cause

    The admin needs to assign the management permission of the corresponding group for the user. For example, assign the management permission of the Data Function group.

     19.png

    In this case, users can have the permission of creating new folders and datasets.

     20.png

    For details, see Public Data Folder Management Permission.


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