Successfully!

Error!

Summary of platform issues

  • Last update:  2022-07-08
  • I. Overview

    This document lists some questions and answers frequently encountered by novices, so that users can refer to them when they encounter problems.

    II. Enter the data decision system 

    A summary of the problems entering the decision-making platform is shown in the following table:

    problem

    plan

    • How to open the decision-making platform

    • How to enter the platform

    • How to enter the decision-making platform

    Click "Server>Platform Management" in FineReport Designer 

    Can refer to:Introduction of Decision-making Platform 

    Must the local designer be opened to access the decision-making platform

    If the server side is deployed , then the deployed server must be turned on to be able to design remotely, regardless of whether the designer is turned on  

    If the server is not deployed , the local designer needs to be opened to access the local decision-making platform

    What is the default port number of the decision-making platform page

    8075

    What is the management platform address

    http://ip:server port number/project directory/decision

    III. Catalog management 

    The catalog management issues are summarized in the following table:

    problem

    plan

    • How to add a directory on the platform

    • How to add a directory

    • How to create a new directory on the platform

    Can refer to: Directory Management

    • Which path is the template of the decision-making platform

    • How to export the template in the platform to the

      designer for viewing

    Enter the decision-making platform as an administrator, click "Manage>Directory", you can view the template path, an 

    example is shown below:

    In what directory is the locally prepared report placed on the platform and can be seen

    %FR_HOME%\webapps\webroot\WEB-INF\reportlets

    How to see the report made by the designer on the decision-making platform

    Can refer to: Directory Management

    • Can the directory list on the platform be deleted

    • Whether the platform directory can be deleted

      and rebuilt

    Can

    10.0 version catalog ordering, decision-making platform adjusts catalog order

    Drag the corresponding directory directly on the directory management interface to adjust the order

    Can refer to: Directory Management

    Decision report catalog migration

    Can refer to: Resource Migration

    I hope that all users can see the entire directory, but can only view the report content with corresponding permissions

    Refer to: Permission fine-grained template content control

    How to configure the home directory of the mobile app

    Can refer to: Management Homepage

    • The platform cannot use catalog management

    • The directory of the decision-making platform is

      not displayed

    • The decision-making platform super-management has no catalog management authority

    • The administrator clicks into the directory management and prompts that there is no permission

    • After logging in on the mobile terminal, the

      directory is not displayed

    • After registration, the catalog will not be displayed and there will be no catalog management

    • After the official registration, there is no catalog

      on the decision-making platform

    Check whether there is no "FR Decision Platform" function point in the function list, you need to register with the "FR 

    Decision Platform" to view it, as shown in the figure below:


    In which table does the platform directory exist

    In the FINE_AUTHORITY_OBJECT table of the FineDB database   

    How to hide the built-in directory of the platform:


    Do not tick PC at "Terminals" , an example is shown below:  

    How can a newly created user let him only see a fixed directory

    Can refer to: User Authorization

    Does changing the directory name affect permissions

    will not

    No directory for user login

    Unassigned permission, please refer to: Hierarchical 

    Authorization

    IV. User Management 

    The user management issues are summarized in the following table:

    problem

    plan

    How to increase users

    Can refer to: Import Users

    There is no place to change the password in the platform user management

    User data is the data after synchronizing users , and can only be modified in the original server data set  

    Platform user management does not have the option to add users

    Synchronous users are enabled and cannot be managed manually   

    The super administrator (admin) could not be found in the user management

    The super administrator does not exist in the user list

    How to change the administrator password

    Modify the "Account Setting", as shown in the figure below:

    Note: General users who log in to the data decision system can also modify their passwords through this method.

     

    • Forget the administrator account and password

    • How to deal with the decision-making platform if

      the password is forgotten

    Can refer to: reset the administrator account

    The user password is generated on 10.0, and you cannot log in after it is generated

    Need to click "OK" to take effect, as shown in the figure below:

    How to view the user corresponding to a role

    As shown below:

    • In the FineDB database, which table is the user

      information stored in 

    • In which table can the user be queried

    • Where are the login user names and passwords

      of the decision-making platform stored

    fine_user table, please refer to: FineDB table structure  

    Different users show different homepages

    Set up multiple homepages + permissions

    How to delete users in batches

    As shown below:

    The user list is empty after synchronization

    Possible Causes:

    There is an administrator username in the synchronized data set

    How to add users after synchronizing user data sets

    Synchronize again after modification in the user data set

    Batch import of users

    Can refer to: Synchronize Users 

    The difference between synchronizing users and importing users

    Import users:

    Importing is generally a one-time operation, and the next importing needs to be manually imported. Multiple non-tree data sets can be imported and displayed on the platform. Platform users may be a collection of multiple imported data sets.

    Sync users:

    The synchronization user has set the synchronization frequency, which can automatically synchronize multiple times. When the set frequency is reached, automatic synchronization will be performed. The data that changes in the data source are continuously synchronized to the platform, and the source of the platform user can only be the currently synchronized data set. It cannot be a collection of multiple data sets. Switching the data set synchronization will clear the previously synchronized data

    Get login user name

    $fine_username function

    Cancel account

    The administrator can delete the user on the platform, please refer to  User Management  

    V. Rights Management 

    The rights management issues are summarized in the following table:

    problem

    solution

    The difference between authorization and viewing permissions

    View authority: the secondary management can see and use this management system node 

    Authorization authority: the secondary management can authorize this node to other users in the "authority management

    (provided that the secondary management can view the 

    "authorization management" node)

    What are the scope of authority of sub-administrators

    Can refer to: Secondary Administrator Permission

    • The admin login to the decision-making platform

      prompts that there is no permission problem

    • The admin account does not have directory

      management permissions

    Lack of "FR Decision Platform" function points

    How does Fanruan management system assign permissions to other users

    Can refer to: Hierarchical Authorization

    Can the management system give a user authority

    Can refer to: User Authorization

    How does the admin administrator authorize directory management permissions for other personnel

    Can refer to: Directory Authorization

    Is there any document that describes the level of authority

    Can refer to: Hierarchical Authorization

    According to the catalog to see the corresponding user permissions

    The example is as follows:

    • Can the dashboard display different content

      according to the authority

    • Do different people log in to the same table to

      display different columns of data

    • Permission control of report content

    Refer to: Fine-grained Template Permission Control

    Toolbar permissions

    Can refer to: Permission fine-grained toolbar control

    • I hope that all users can see the entire directory,

      but can only view the report content with

      corresponding permissions

    • Different people have different permissions to

      view data

    Can refer to: Permission fine-grained template content control

    Fine-grained settings of report permissions, if it is a multi-role, how to use it as a judgment condition

    Can refer to: Parameter control of Permission granularity

    Permission fine-grained parameter control

    Can refer to: Remote design data connection permission control

    The report prompts that there is no operation authority

    The reporting task is set according to the role, so only the personnel under that role have the authority

    The decision support system does not have permission to view the page error code: 12400002

    Unregistered limit concurrency

    General users do not have permission to report 

    templates

    Turn off template authentication

    VI. Appearance configuration 

    The appearance configuration issues are summarized in the following table:

    problem

    solution

    • Modify the login page

    • Set up the home page of the platform

    • On the login page, can you remove the words

      "Decision-making platform" on the left?

    Can refer to: Login Page

    How to restore the login page

    Can refer to: Login Page

    Custom login page

    Can refer to: Login Page

    • 10.0 Are there any other styles for the theme of

      the decision-making platform

    • Change of the theme of the decision-making

      platform

    Can refer to: Theme plugin

    How to modify the platform style logo

    Can refer to: Login Page

    Platform style modification

    Platform style settings

    Can refer to: Platform Style

    How to change the background picture of the

    decision-making platform

    Can refer to: Fresh style plug-in

    The title of the homepage of the decision-making platform can be changed

    Modify "Login Title " 

    Can refer to: Login Page

    VII. System Management 

    The system management issues are summarized in the following table:

    problem

    solution

    Login timeout setting duration

    Can refer to: Login timeout

    How to use the SMS platform

    Can refer to: SMS Service

    Do I need to purchase the SMS platform of FineReport 10.0

    Yes, it is a function point

    SMS notification wants to customize content

    Can refer to: SMS application signature and template

    • How to configure email

    • How to register email

    Can refer to: Email Service 

    After setting the mailbox, the test mail failed

    The authorization code entered in the "password" field is not a password, please refer to: Email Service 

    Configure the mailbox test mail to show that it is always sending

    Possible Causes:

    Did not write the recipient

    How to modify servlet application name in report access pathCan refer to:Modify the Servlet path name in the report access path

    VIII. Task schedule

    The timing scheduling problems are summarized in the following table:

    problem

    solution

    Is IE11 compatible with FR10.0

    Compatible, but Google Chrome is recommended

    • The decision-making platform has no task

      schedule function

    • The decision system cannot find the task

      schedule function point

    There is no "task schedule" function point, as 

    shown in the figure below:

    Can the task schedule be executed once every two weeks

    In the Task Schedule Setting is provided at a Simple Repeate Execution performed to  

    How to set the task schedule email sender

    Can refer to: Send Mail Regularly

    IX. Mobile platform 

    The mobile platform issues are summarized in the following table:

    problem

    solution

    How to configure the QR code of 

    Finereport version 10.0

    Can refer to: Mobile platform 

    The server address is: http:/ip:server port number/project directory/decision

    How to display the report developed by the FineReport template designer on the mobile platform

    Refer to: HTML5 end access Report / Project , 

    App scans the Mobile platform 

    Mobile refresh button

    Can refer to: Template Settings

    There are several mobile directory structures

    Refer to: [General] Directory Structure Plug-in

    Directory icon set

    Can refer to: App Directory

    X. Registration Management 

    Note: For FineReport server registration steps, please refer to: Local Machine AUTH  

    A summary of the problems during registration of the FineReport designer is shown in the following table: 

    problem

    solution

    The difference between registration code and activation code

    The registration authorization is to bind the server, and the registration code is the authorization of the function point. If the server is registered, the function point contained in the registration file can be used

    The activation code is the activation of the designer tool. You need an activation code to install and use the designer for the first time. As long as you can successfully open the designer interface, it means it has been activated successfully

    • What are the registration methods

    • The difference between various

      registration methods

    Local machine information authentication:

    The local registration method is to bind the MAC address and machine code of the machine where the report server is provided by the customer to generate a uniquely identified authorization file. Once there is a change in information, the registration file will become invalid; it is suitable for physical machines and will not change the hard disk and JDK. , Network card, etc.

    Private cloud certification:

    The popularity of cloud servers, because there is no fixed physical information, the physical information of the report server will change, making the local registration method no longer applicable; at this time, a server with fixed physical information is required as an authorization server (an independent server). A smooth network is required between the report server and the authorization server

    In the case of clusters, private cloud authentication is used, and each node does not need to send registration information to the business.

    Public cloud certification:

    The registration method when the user does not have a fixed physical machine and does not want to build a separate authorization server

    Encryption lock authentication:

    For some large projects, the same report project may be published on multiple servers or some projects cannot disclose the MAC address of the server casually. The physical information of the machine where the report server is located is not fixed, and the user does not want to provide a machine with fixed physical information as an authorization server

    • The difference between registered

      and unregistered

    • Impact of unregistered

    • What are the limitations of not

      registering

    Refer to: Registration and Authorization

    • How to register the server

    • Registration steps

    • How to apply for the official

      registration code

    • How to register an official

      authorization document

    Refer to: Local Machine AUTH

    • Export registration information

    • What information needs to be 

            provided to register

    Refer to:Local Machine AUTH

    How to see which feature is registered

    As shown below:

    What is the reason for the wrong use of unregistered functions

    Related function points are not registered

    Error: a registration code is required

    Refer to: Registration and Authorization

    10.0 Can the registration file be registered to 8.0

    can not

    9-10 Do you need to re-register

    9.0 upgrade to 10.0 requires migration authorization

    Upgrade under 10.0 version without re-registration

     

    Will upgrading from 9.0 to 10.0 affect the authorization file and need to re-register

    need

    Under what circumstances will it cause the loss of FanRuan's registered Lic, and then need to re-register

    Server replacement, MAC address change, machine code change, project name change, etc.

    • Application for registration of dongle

    • Notes for encryption lock registration

    Can refer to: Encryption lock authentication

    The registration code becomes invalid after upgrading to 10.0

    FineReport 9.0 upgrade FineReport 10.0 can not use the original Lic file 

    Show that the report has not been registered, please buy

    Refer to: Registration and Authorization

    • The server cannot be registered,

      and the upload fails several times

    • The server is not registered

      successfully

    Possible Causes:

    Check whether there are multiple Lic files under the server , if there are multiple, delete and re-register 

    10.0 In which directory is the authentication file FanRuan.lic placed

    %FR_HOME%\webapps\webroot\WEB-INF\resources

    XI. Cloud operation and maintenance 

    A summary of cloud operation and maintenance issues is shown in the following table:

    problem

    solution

    How to configure cloud operation and maintenance

    Refer to: Cloud operation and maintenance steps

    Some uploaded data of cloud operation and maintenance

    Logs of some platforms, used to check the health of the system

    Do I need to pay for cloud operation and maintenance functions

    unnecessary

    XII. Data connection 

    The data connection problems are summarized in the following table:

    problem

    solution

    Platform data connection method

    Refer to: Configure data connection

    When does the decision-making platform  need to configure the data connection

    If the project is deployed on the server and the function of "remote design" is not purchased, the data connection needs to be configured on the data decision system

    FineDB data connection

    Refer to: Built-in HSQL FineDB

    FRDemo's data connection method

    FRDemo designer and platform have built-in connection, users can use it directly 

    Data connection does not display table

    Possible Causes:

    Did not write database name

    How to modify the data connection name

    In the designer:

    Click "Server>Define Data Connection", double-click the database name to modify

    In the platform:

    Configure data connection , click the "Edit" button to modify the configuration items  

    • Data connection fails after remote

      design connection

    • Remote design, preview data set,

      display data connection failure

    • The remote connection data set

      shows that the data connection failed

    The JAR of the designer and the server are updated to the same

    XIII. Plug-in management 

    The plug-in management issues are summarized in the following table:

    problem

    solution

    Why is there no plugin management in the designer

    There is no "plug-in management" for remote design, switch to the local directory

    Where to upload plug-ins in Finereport 10.0 decision platform 

    Can refer to: Server plugin management

    How to install plugins on the platform

    Can refer to: Server plugin management


    Attachment List


    Theme: Product Introduction
    Already the First
    Already the Last
    • Helpful
    • Not helpful
    • Only read

    Doc Feedback